Cannot get my GBA roms to work via EZFlash 3in1

Discussion in 'NDS - Emulation and Homebrew' started by Horganic, Nov 13, 2012.

Nov 13, 2012
  1. Horganic
    OP

    Newcomer Horganic Newbie

    Joined:
    Nov 12, 2012
    Messages:
    2
    Country:
    Canada
    Hi all,

    I coded a few GBA games back in the day, and unfortunately, lost the HDD that had the source and original build/tool-chain. All I have left are the roms (sample attached)that were thankfully still available via the original compo pages!

    At the time, I could play these on my GBA hardware via an EZFlash (I think?!), and via VisualBoyAdvance.

    Now, my GBA is long gone, along with the EZFlash, but I have DS Lite, a CycloDSEvolution, and an EZFlash 3-in-1 (with 3in1ExpPack v1.9)

    The roms still work in VBA, but when booted via the 3-in-1 (in either NOR or PSRAM mode), they don't get past the GameBoy startup screen. The pink Nintendo piece displays as garbage.

    Does anyone have any idea how I might be able to get these roms working on my DS? I was quite proud of my efforts, and it's a shame to not be able to enjoy it on hardware.

    --Mike
     

    Attached Files:

  2. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    the attached version will work.

    -another world
     

    Attached Files:

  3. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Just run it through GBATA and click the button that fixes the rom's header. I just tested this in VBA using a real GBA BIOS file and it does indeed fix the issue.
     
  4. Horganic
    OP

    Newcomer Horganic Newbie

    Joined:
    Nov 12, 2012
    Messages:
    2
    Country:
    Canada
    It's alive!! I have all three of my roms working with GBATA (never even knew that existed before!).

    Thanks so much for your responses guys. When I posted, I never imagined it would be solved in less that 12 hours!! I cannot believe I forgot what an amazing community this is.
     

Share This Page