Can you use new UMDs with 5.00 M33-6 Promethius?

Discussion in 'PSP - Games & Content' started by Limitin, Sep 21, 2010.

Sep 21, 2010
  1. Limitin
    OP

    Newcomer Limitin Newbie

    Joined:
    Sep 15, 2010
    Messages:
    5
    Country:
    United States
    I was wondering if you could use new UMDs with the current M33 mods out there, or if they would all detect a lower firmware and want you to upgrade? Am I restricted to only having newer games on my memory stick?
     
  2. MarcusRaven

    Member MarcusRaven HBC Theme Maker

    Joined:
    Feb 5, 2010
    Messages:
    928
    Location:
    N. Carolina
    Country:
    United States
    Promethius v2 is compatible with newer ones. I've been playing Kingdom Hearts on UMD no problem. [​IMG]
     
  3. Blaze163

    Member Blaze163 The White Phoenix's purifying flame.

    Joined:
    Nov 19, 2008
    Messages:
    3,767
    Location:
    Coventry, UK
    Country:
    United Kingdom
    prometheus 2 is compatable with any UMD that requires firmwares up to 6.30. Anything needing 6.31, such as the new Ace Combat X2 (at least the UK version) will not work. With that in mind, anyone know what firmware Phantasy Star Portable 2 needs for the UK UMD?
     

Share This Page