can vita with cfw play new games?

Discussion in 'PS Vita - Hacking & Homebrew' started by LTK, Feb 4, 2014.

  1. LTK
    OP

    LTK GBAtemp Fan

    Member
    406
    50
    Jul 28, 2008
    West Midlands
    Before I install the cfw I was wondring if it can play new vita releases with cfw?
     
  2. Ryupower

    Ryupower Brood

    Member
    2,930
    441
    Oct 8, 2007
    United States
    was FW do you have now
    3.01 should play any game
    till a new FW come out
     
  3. LTK
    OP

    LTK GBAtemp Fan

    Member
    406
    50
    Jul 28, 2008
    West Midlands
    I'm on 3.01 yea, I have the exploit and about to install cfw. Basically I want to know if it will play ffx hd
     
  4. Ryupower

    Ryupower Brood

    Member
    2,930
    441
    Oct 8, 2007
    United States
    it might work,
    but the game not out, so there is no tell if a FW update will be needed or when the next update is coming
     
    LTK likes this.
  5. 71r3n

    71r3n Advanced Member

    Newcomer
    72
    19
    Sep 24, 2011
    Germany
    NOPE, You cant.
    The cfw is PSP only (PSP-Emuator in Vita is sandboxed).
    Watch wololo.net for more detailed infos.
    Greetz 7
     
  6. ResleyZ

    ResleyZ Swiggity swaggity swooty, I love my own booty

    Member
    528
    119
    Oct 11, 2013
    Netherlands
    Silicon Valley
    I'm just gonna assume you completely misunderstood his post.

    As long as the game requires FW 3.01 or lower, you will be able to play it. If there is a FW update available, don't install it, as it will remove the exploit. You can still download stuff from PSN though. Look through the forums of www.wololo.net to be sure though.
     
  7. 71r3n

    71r3n Advanced Member

    Newcomer
    72
    19
    Sep 24, 2011
    Germany
    OMFG. Sry dude. Im at work and only halfeyed on this page. Sry again. Didnt read it carefully enough. Also english isnt my native language. ^^
     
    LTK likes this.
  8. ov3rkill

    ov3rkill GBAtemp Maniac

    Member
    1,003
    369
    May 10, 2009
    Australia
    in a cardboard box
    PSP games, yet. Vita games, no.
    There's already a new game exploit being announced on Wololo.
    Get it before you'll miss your chance.
     
  9. 71r3n

    71r3n Advanced Member

    Newcomer
    72
    19
    Sep 24, 2011
    Germany
    Haha dude you made the same failure as i did, thinking he want to pla vita backups. He just wanted to know if he can play the latest games (life FF-X HD) oon his Vita while stayin on of 3.01 cause of TN-V4.^^
     
  10. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,696
    10,721
    Jul 11, 2009
    United States
    I forgot
    It depends on whether there's a Vita update before the release date in March, and whether FFX requires that latest update.
     
  11. reprep

    reprep GBAtemp Advanced Fan

    Member
    935
    301
    Jul 5, 2012
    i hope ffx won't require the new update and we will play it via 3.01. though we might have to say goodbyte to ff x-2 as it will be download only.
     
  12. ov3rkill

    ov3rkill GBAtemp Maniac

    Member
    1,003
    369
    May 10, 2009
    Australia
    in a cardboard box

    haha. yup. i immediately replied and just skimmed through it. hahaha. my bad.
     
  13. Blyzzard30

    Blyzzard30 Advanced Member

    Newcomer
    50
    1
    Mar 2, 2014
    United States
    Not sure if still looking but I have FFX HD on my Vita and am still 3.01 so I say no issue with the exploit as of right now