Question Can NSPs Installed via DevMenu Be Run on Hekate+SDFiles v6.1?

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Gootah, Aug 2, 2018.

  1. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    I can't get them to boot! I installed with DevMenu, then try to boot. I get an error. I'm running layered FS+Sig Patches.
     
    Xyphoseos likes this.
  2. jakkal

    jakkal GBAtemp Addict

    Member
    12
    Apr 27, 2018
    United States
    You need hekate with sigpatches
     
  3. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    Did you read the OP?
     
  4. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    It should. Did you try selecting CFW+Sigpatches instead?
     
  5. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    Yeah, I tried all of the options. It doesn't run anything installed by DevMenu or SX. Have you successfully run anything?
     
  6. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    I haven't updated the SD files yet. I will tomorrow and do some testing
     
  7. mawile1

    mawile1 Newbie

    Newcomer
    1
    Aug 2, 2018
    China
    i heard that need a FS.kip1
     
  8. jakkal

    jakkal GBAtemp Addict

    Member
    12
    Apr 27, 2018
    United States
    Maybe you need to use your head to realize that the sigpatches need to be on the micro SD card as well
     
  9. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    So i just tested the 6.1 SD files and all is working fine for me. Maybe you're missing a file
     
  10. gallymimu

    gallymimu EE Expert

    Member
    5
    Mar 15, 2009
    United States
    I had the same problem. used hekate with sig patches, used the right ipl config, had the sig patches on the sd card, used sdfiles 6.1. No dice.

    Works fine with ReiNX
     
    bytar, charlieb and ModderFokker619 like this.
  11. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    Maybe you need to use your head and realize that I'm using SD files 6.1 and the package is all inclusive.
     
    gallymimu likes this.
  12. tomx86

    tomx86 GBAtemp Advanced Fan

    Member
    4
    Jun 3, 2015
    Poland
    With version of ReiNX (payload, and sd files)?
     
  13. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    Thanks, I'll recopy. You pasted the files in and launched the LFS+Sigpatches option?

    Edit: Recopy didn't resolve anything. Has to be interference from something.

    — Posts automatically merged - Please don't double post! —

    Do you have more info on this?
     
    Last edited by Gootah, Aug 3, 2018
  14. Tom288

    Tom288 Newbie

    Newcomer
    1
    Jun 27, 2018
    Germany
    What my setup looks like and I have no problems.

    modules/oldlayered/loader.kip1
    modules/oldlayered/sm.kip1
    modules/oldlayered/fs_mitm.kip1
    FS510-exfat_nocmac_nosigchk.kip1
    atmosphere=1
     
  15. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States

    Mine seems to be the same, I'm assuming kip1 files are for 1.0

    kip1=modules/newfirm/loader.kip
    kip1=modules/newfirm/sm.kip
    kip1=modules/newfirm/fs_mitm.kip
    atmosphere=1
    kip1patch=nosigchk

    I'm also on exfat, but I don't know what that kip you're launching is unless it's the exfat patch. The unit I'm doing this onis update to 5.1, are sig patches compatible with 5.1? Probably should have looked that up first...
     
  16. gallymimu

    gallymimu EE Expert

    Member
    5
    Mar 15, 2009
    United States
    version of ReiNX isn't relevant to the problem because hekate (3.2 and sigpatch version) with sdfiles 6.1 did not result in usable sigpatches.

    If you are asking about what version of stuff DOES work then: If I use ReiNX meteos release v2.1-2.2 sigpatches work fine.

    — Posts automatically merged - Please don't double post! —

    I am however not really messing with it anymore as ReiNX seems to do everything needed cleanly and simply.

    — Posts automatically merged - Please don't double post! —

    don't be a jerk. You are better off keeping comments like this to yourself.
     
    charlieb and tomx86 like this.
  17. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    6
    Feb 1, 2016
    Portugal
    Under my bed
    I actually launched CFW+Sig Patches+FTP but LayeredFS should be working too. As was said before, maybe you are missing the FS510-exfat_nocmac_nosigchk.kip1 file
     
  18. Gootah
    OP

    Gootah GBAtemp Regular

    Member
    3
    Aug 11, 2013
    United States
    Ah I see, it's a separate sig patch for my fw. I have sig patches already because hekate has them built in. I know now that there's a fw limitation on that, or at least that's what it looks like from the file name. thanks, will let you know if it works.

    Edit: I didn't need that file. I found some atmosphere files that someone ripped from ReiNX and moved them to my SD card. Moral of the story here is that SD files does not contain the latest sig patches for 5.1. Thanks guys!
     
    Last edited by Gootah, Aug 4, 2018
  19. gallymimu

    gallymimu EE Expert

    Member
    5
    Mar 15, 2009
    United States
    Thanks for following up with what worked. It definitely isn't clear that the sigpatches need to be swapped out.
     
Loading...