Can I safely run the EA Active update on my Soft Modded Wii?

Discussion in 'Wii - Hacking' started by lval, Jun 3, 2009.

  1. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    I know this really sounds like a noob question, and why the hell would I want to update my Wii? Well my girlfriend got the legitimate version of EA Active, and it wants to run an update. She "needs" to be able to play the game through the disc channel rather than loading it through BLG to block the update. I have a 3.3v1 wii with cios249 rev10 installed and the BLG channel. So can I run the update safely? I do not do much with the HBC and as long as the BLG channel continues to work I would be satisfied. Please help, and thank you. I apologize if this has been asked and answered already.
     
  2. Servdogg

    Member Servdogg GBAtemp Regular

    Joined:
    Apr 13, 2009
    Messages:
    201
    Country:
    United States
    You could upgrade to 4.0 with waninkoko's updater, install preloader .29, install cioscorp, and enable the no update hack in preloader settings. Then backups and originals will play through the disc channel and no games will request updates anymore.

    Don't run the Nintendo update, that is never a good idea.
     
  3. cthg

    Member cthg GBAtemp Regular

    Joined:
    Jan 22, 2009
    Messages:
    197
    Country:
    United States
    Or, you can downgrade to 3.2 and install preloader .29 and block updates...

    but yes I think the backup loader will still work if you do the disk update... if you already have CIOS INSTALLED!!!
     
  4. Servdogg

    Member Servdogg GBAtemp Regular

    Joined:
    Apr 13, 2009
    Messages:
    201
    Country:
    United States
    yeah, you could do what cthg says too, the key is blocking updates with preloader. And it's stupid to not have preloader installed anyway so get to it. And preloader only works on 3.2 (or lower) and 4.0 I think, so you probably will need to upgrade or downgrade.
     
  5. D-an-W

    Member D-an-W GBAtemp Regular

    Joined:
    Nov 13, 2002
    Messages:
    120
    Country:
    United Kingdom
    I had to install IOS53 using WAD Manager for it to run, other than that I blocked updates and it was fine. Not really sure if you can do that with your setup, but might be worth looking into?
     
  6. kimikal27

    Member kimikal27 GBAtemp Maniac

    Joined:
    Oct 28, 2008
    Messages:
    1,381
    Location:
    Galway
    Country:
    Ireland
    follow Servdogg instructions, myself i don't care for preloaded or cioscorp since i know what I'm doing and i don't have any kids playing whit my wii so if you what you can skip that step, mainly upgrade to 4.0 with waninkoko's updater and startpatch (not sure if this name is right), it's what i have and works for me.
    this way you don't need to worry about updates
     
  7. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    I have read a mixed bag of comments about wan's updater, and preloader for that matter, (some love it and others get bricks -- and I don't mean to insult those who love it or the man himself). But, I am not sure if I am prepared to take the risk. Is there a way for me to safely and easily go to 3.4 from where I am now, so that Active won't want to update? I have extracted the contents of the update using WUFE if anybody is interested... Or is it even riskier, and I should just man up and go to 4.0? Thank you all for the response.
     
  8. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Just install the disc update. It won't hurt anything and you'll get to 3.4 like you want.

    And if you're scared about bricks use BootMii and/or Preloader.
     
  9. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    I hoped this was the case. May I ask another question? Since I am at 3.3v1 I do not have the "trucha bug", my understanding is 3.4 has that. Is it the case that the bug blocks the install of cios 249 ver 10 rather than searching it out and deleting it? I am assuming this is what you mean when you say it "won't hurt anything." Thank you.
     
  10. SanGor

    Member SanGor Witchhunter

    Joined:
    Aug 21, 2008
    Messages:
    993
    Country:
    United States
    actually preloader has never directly caused a brick, it's just the users who don't read the readme and/or uninstall important things the system needs to boot.
    Also many say their console is bricked just because they can't boot the systemmenu anymore, though preloader an the HBC still work...
     
  11. Servdogg

    Member Servdogg GBAtemp Regular

    Joined:
    Apr 13, 2009
    Messages:
    201
    Country:
    United States
    exactly SanGor. Preloader is nothing to be afraid of. I'd be way more afraid of not having preloader. Without it installed, it is pretty easy to brick the wii.
     
  12. mikeyt1998

    Member mikeyt1998 YouTube Glitcher

    Joined:
    Aug 11, 2007
    Messages:
    1,359
    Location:
    Dalton-in-furness, north west
    Country:
    United Kingdom
    update officially,
    install preloader 0.29,
    enable: Skip Disc Update Check

    3.3 has the trucha bug, 3.4 doesnt lol

    and yes, it only blocks the installation of cIOS, it will not seek and destroy it lol

    and if you ever want to update the cIOS you can just overwrite it with a newer one, since it's already there the wii will not block it's installation.
     
  13. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    I thought the big thing was the Oct 23 update (which I thought was the bug, and is 3.3v2 and 3.4)...
     
  14. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    the Trucha bug is what allows cIOS installation, not what blocks it. You've got it all backwards. Nintendo killed the bug in an attempt to stop the backup loaders, but we've been able to bypass all their efforts so far.

    Once you have cIOS you're free to do any update because cIOS contains the trucha bug and so can update itself or be used to patch the bug into other IOS's.
     
  15. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    Oh I am such a noob, huh? Thanks for putting up with the trivial questions, it makes perfect sense. I will report back after I run the update.
     
  16. kelzinha

    Newcomer kelzinha Newbie

    Joined:
    Jul 14, 2009
    Messages:
    1
    Country:
    Antarctica
  17. lval
    OP

    Newcomer lval Member

    Joined:
    Apr 21, 2009
    Messages:
    10
    Country:
    United States
    I completely forgot to post results (too busy playing the Wii), my apologies. It worked perfectly for me. The way I understand it is, Wan's cios installs in slot 249 (which is unused by any update). So as long as the disc update is from your own region, it shouldn't have any ill effects to BLG since its patches do not affect slot 249. That seems unclear, but I hope it helps.
     

Share This Page