Can I install Rebug directly on a OFW 3.41 PS3?

Discussion in 'PS3 - Hacking & Homebrew' started by Cyber Akuma, Dec 28, 2016.

  1. Cyber Akuma
    OP

    Cyber Akuma GBAtemp Regular

    Member
    179
    15
    Mar 12, 2009
    United States
    Or would I need to upgrade it to OFW 3.55 first?
     


  2. Supster131

    Supster131 (づ。◕‿‿◕。)づ *:・゚✧

    Member
    3,193
    2,210
    Jan 19, 2016
    United States
    My Computer
    Edit: Oh crap, I read your title as 4.41.
    Yes, pretty much was Cyan said.
     
    Last edited by Supster131, Dec 28, 2016
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,311
    8,772
    Oct 27, 2002
    France
    Engine room, learning
    I'm still on 3.41 too and haven't take the time to do it.
    I was said many times that it's fine, even if all CFW website only talk about being on 3.55 (rebug), but it's "safer" to update to OFW3.55 first.

    to me, it acts like a firmware update, you can update from any previous firmware accepting the CFW signature. 3.41 and 3.55 should work (they changed the firmware signature/keys in 3.56!), though, I'm not 100% sure.
    If you try it, please report :)
    if you want to be safe, update to 3.55 first.
     
    baileyscream likes this.
  4. baileyscream

    baileyscream Advanced Member

    Newcomer
    92
    33
    Feb 22, 2015
    Update to 3.55 first then you can install any cfw from there



    Sent from my iPhone using Tapatalk
     
  5. kevin corms

    kevin corms Advanced Member

    Newcomer
    93
    26
    Feb 21, 2015
    Canada
    not needed, just flash whatever custom firmware you want.
     
  6. baileyscream

    baileyscream Advanced Member

    Newcomer
    92
    33
    Feb 22, 2015
    No
    You need the 3.55 ofw installed first as a base then you can install any cfw over the top
    If you don't then your going to have issues


    Sent from my iPhone using Tapatalk
     
    Psionic Roshambo likes this.
  7. zecoxao

    zecoxao GBAtemp Fan

    Member
    339
    739
    Dec 25, 2013
    it's perfectly fine to go from 3.41 to any cfw...
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,311
    8,772
    Oct 27, 2002
    France
    Engine room, learning
    yeah, that's what I thought too.
    it's like telling people they need to install OFW3.55 before installing OFW4.81
    they can just install the latest one, it contains ALL the files used by that firmware.
     
  9. baileyscream

    baileyscream Advanced Member

    Newcomer
    92
    33
    Feb 22, 2015
    I disagree. Not all modified firmwares have all the original files
    Regardless of that the files that have been modified still need the original files installed as a base to ensure no issues during the installation of the cfw / mfw


    Sent from my iPhone using Tapatalk
     
  10. Cyber Akuma
    OP

    Cyber Akuma GBAtemp Regular

    Member
    179
    15
    Mar 12, 2009
    United States
    Getting really conflicting answers here....
     
  11. sj33

    sj33 GBAtemp Addict

    Member
    2,714
    1,717
    Oct 22, 2013
    Japan
    Of course. You're going to get people who see it as a firmware upgrade and thus logically suggest updating directly, and other people who worry that certain files won't get updated if you do this. Both are understandable perspectives.

    Just update to 3.55. It will take an extra 5 minutes of your time.
     
  12. Cyber Akuma
    OP

    Cyber Akuma GBAtemp Regular

    Member
    179
    15
    Mar 12, 2009
    United States
    Where can I reliably get a 3.55 file that I know wasn't tampered with then?
     
  13. mikey420

    mikey420 GBAtemp Fan

    Member
    448
    133
    Dec 11, 2015
    United States
    You can install it over ofw 3.41. Anyone saying you need 3.55 first is wrong. The 4.xx cfw are based on ofw 4.xx not 3.55 this means they are complete updates that will install all the 4.x dependancies to the system. Just make sure its a cfw and not ofw you install or you'll be stuck on ofw 4.xx
     
  14. kevin corms

    kevin corms Advanced Member

    Newcomer
    93
    26
    Feb 21, 2015
    Canada
    Just get the newest rebug, it's complete and stable. There's a firmware collection on this forum.
     
    Last edited by kevin corms, Dec 30, 2016
  15. yusuo

    yusuo GBAtemp Addict

    Member
    2,553
    905
    Oct 19, 2006
  16. baileyscream

    baileyscream Advanced Member

    Newcomer
    92
    33
    Feb 22, 2015
    No all mfw/cfw are based on 3.55
    The newer firmwares that use the 3m patches are also based on 3.55 and built on the same revision
    So 4.81 modified firmwares are based on 3.55 and built from 4.81 ofw
    Not all firmwares contain bdvd key updates for example or syscon updates
    So by skipping then your missing out on updating these services
    You may update to a nobd or nobt firmware so your now missing the bluray or Bluetooth files that installing 3.55ofw first would have installed for you.
    You might update to ps3ita firmware and then find the console crashes at boot due to it missing needed files that are installed if you go to 3.55 first
    And yes if you go down to 3.41 and double install to fill both ros areas then go to any ps3ita it does crash

    I do also Acknowledge that there are plenty mfw/cfw's out there that do have all the needed files and will update directly to just fine
    But why skip installing a base firmware.
    You wouldn't skip re-installing 3.55ofw via fsm or qa-flag after downgrading to 3.55
    When it is possible to set the flag and then install a cfw instead of 3.55ofw
    No you wouldn't because you want to set that base


    Sent from my iPhone using Tapatalk
     
  17. jellybeangreen2

    jellybeangreen2 GBAtemp Regular

    Member
    172
    25
    Dec 9, 2015
    I have done downgrades and fresh CFW installs before, on some occasions, not all; doing a direct upgrade from 3.41 OFW to 4.81 CFW can cause bricks. Just for piece of mind, I'd install 3.55 OFW, then do the direct upgrade of rebug or starbucks. Completely your choice. Which model PS3 do you have?
     
  18. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,311
    8,772
    Oct 27, 2002
    France
    Engine room, learning
    I thought CFW/MFW were based on their OFW (CFW4.81 based on OFW4.81)
    but it's in fact a 3.55 edited to act like a 4.81? if that's the case I can understand some MFW can miss some files.

    then upgrading from 3.41 "might" work, it only depends which custom firmware you use?
    it would be interesting to get a proper answer from rebug team.

    it's always safer to update to 3.55 first, as it's the recommended one by rebug.
    I will update to 3.55 myself when I'll install the CFW. like said, it's just min of my life :P
     
  19. mikey420

    mikey420 GBAtemp Fan

    Member
    448
    133
    Dec 11, 2015
    United States
    You're entirely wrong. They are based on newer than 3.55 but use the signature of the 3.55 hack. They are patched to continue to accept this signature on the newer firmwares. Beyond that they have nothing in common with 3.55 OFW/CFW. They use many similar patches but they usually need to be ported to the new firmware offsets.
     
  20. Cyber Akuma
    OP

    Cyber Akuma GBAtemp Regular

    Member
    179
    15
    Mar 12, 2009
    United States