Can "backup" WADs be played from SD under FW 4.0? Because mi

Discussion in 'Wii - Hacking' started by Dan_Aykroyd, Jun 29, 2009.

  1. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Hi guys,

    As topic, is it possible to play a backuped game WAD (not from Wii... [​IMG]) in the SD menu of the latest FW 4.0?

    To tes this, what I did was this: installed The Legend of Zelda for NES to the Wii memory using WAD Manager 1.4. Then, copied it using the own Wii channels menu to the SD card. After that, when I go and try to start the game from the SD (using the new, small icon of the SD card in the main screen), what I get is a "Copying failed" message, and it doesn't work.

    I'm guessing that this has something to do with it not being encrypted with the Wii encryption key or something along those lines. Am I right? Isn't this possible to achieve? It would be great, as someone could potentially have a lot of WAD installed in a 8 GB SD card, and then only buffering them to the Wii NAND by starting them from the SD menu. If this doesn't work, is there any other way to get the same functionality - something that would copy from SD to Wii, run, delete from Wii?

    Thanks in advance!
     


  2. micahkanchan

    Member micahkanchan GBAtemp Regular

    Joined:
    Sep 21, 2008
    Messages:
    116
    Country:
    Canada
    Lol..yea. You need all your ioses trucha patched so the trucha bug is present in 4.0. The best thing to do is to launch softcorp from the softmii package which will download all the latest 4.0 ioses and patch them w/ trucha on the fly. This way you can run your downloaded wads from the sd menu.
     
  3. Shonk

    Newcomer Shonk Advanced Member

    Joined:
    May 11, 2009
    Messages:
    61
    Country:
    United States
    ios 60 isnt patched
     
  4. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Do you know which IOS specifically should I downgrade? Because I rather not go downgrading them all!

    The one I downgraded recently (after the original post) is the IOS36, in order to support AnyTitle Deleter and StartPatch, and haven't tried running the games from SD afterwards (will try now to see if that was the IOS!)

    Thanks, please let me know if you know
     
  5. micahkanchan

    Member micahkanchan GBAtemp Regular

    Joined:
    Sep 21, 2008
    Messages:
    116
    Country:
    Canada
    It's not really downgrading. Its the latest ioses from nintys server patched on the fly with cioscorp. Of course you could just patch ios60 with softcorp, but specific games that call on ioses like onslaught won't function properly. Best bet is to patch them all with the trucha bug. It saves you from a lot of problems.
     
  6. Shonk

    Newcomer Shonk Advanced Member

    Joined:
    May 11, 2009
    Messages:
    61
    Country:
    United States
    I already told you ios60 controls the copy to and play from function in 4.0

    even if you patch all other ios's it still wont work if 60 isnt patched



     
  7. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    Yep, he's right.
     
  8. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Ups, shorry Shonk, thanks for your answer; I'll try that then!

    Can I just install the patched (previous) IOS60.wad and be done with it? I don't want to run CIOSCORP to do this since it seems to modify a lot of stuff in the Wii that I don't want.

    Since WADs can't be posted here, could you please provide me with the string to look for it in Google? Something like "IOS36-64-v1042.wad", but of course, about the IOS60 trucha version.

    Thanks again for your collaboration!
     
  9. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    if you have wifi, simply run ios60 updater. if you cannot find it, let me know.


    Check your pm in oh...5 minutes.
     
  10. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Thanks Troy! I'm downloading the pack as we speak! [​IMG]
     
  11. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    5) Run the IOS60 updater
    say NO to install IOS61
    say YES to install IOS60
    say YES to patch IOS60
    say NO to install the shop channel
     
  12. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Sorry but, by "IOS60 Updater" do you mean the "IOS Downgrader"?

    I run it, and it started to install other IOses... but I don't want do downgrade (or patch) more than the IOS60! Is this it?
     
  13. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    No, i mean IOS60 Updater. It may be called IOS60 installer,

    Don't run random apps. You may screw up your wii.
     
  14. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Oh... I see [​IMG]

    Then I'll be trying my NAND restore for the BootMii boot2 installation now [​IMG]

    Hope it goes well
     
  15. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada
    Ugh.


    IOS downgrader won't wreck your system, sheesh. I didn't say it would. all i said was don't run random apps without knowing what they do.
     
  16. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Yes, but I want to have a "clean" as possible system, and now I think that the IOS downgrader might changed / added some IOS.

    Any way to check that or to rollback those changes without resorting to bootmii?
     
  17. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    niggas be misintrepreting nowadays!
    trust, troythezombie knows what he speak of.
     
  18. TroyTheZombie

    Member TroyTheZombie GBAtemp Advanced Maniac

    Joined:
    Mar 3, 2009
    Messages:
    1,631
    Location:
    Calgary, Canada
    Country:
    Canada

    Its a GOOD thing to downgrade your IOS files, hell, its needed in most cases. leave it as it is.

    Just run IOS60 updater. And if your that paraniod, run waninkoko's updater again. That will bring any ios's back to current versions, with the trucha bug intact.

    All IOS downgrader does is roll back SOME IOS files to versions that had the trucha bug in them (thats a good thing)
     
  19. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Having downgraded IOS's isn't a bad thing and shouldn't adversely affect anything on your Wii. Also having it add IOS's means you were probably missing some and installing those will only increase compatibility with more things. Don't worry about already having run it and just run the IOS60 installer and have it install and patch IOS60.
     
  20. Dan_Aykroyd
    OP

    Member Dan_Aykroyd GBAtemp Fan

    Joined:
    Oct 30, 2008
    Messages:
    318
    Country:
    United States
    Yeah, I thought about running Wanin's updater to FW4.0 too, but isn't that supposed to use the most "hack friendly" IOSes? Doesn't that mean that i'll keep the trucha signed ones?
     

Share This Page