Hacking Calendar Fix for WoodR4 Themes

NDStemp

GBAtemp?! No! NDStemp
OP
Member
Joined
Aug 30, 2008
Messages
627
Trophies
0
Age
28
Location
Canada, Ontario
Website
Visit site
XP
168
Country
Canada
It's quite simple actually. Just make the calendar folder and put those 4 files in then there's a .ini file named 'uisettings'. Under [big clock], [calendar year], [calendar month], and [calendar day]

There should be " show = 0 "
Change it to " show = 1 " if you haven't and voila! Your calendar/time should now be appearing.

1 means yes
0 means no

Here's an example.
Code:
[big clock]
x = 136
y = 155
show = 1

[calendar year]
x = 179
y = 164
show = 1

[calendar month]
x = 132
y = 164
show = 1

[calendar day]
x = 140
y = 23
highlightColor = 0x25b5
dw = 16
dh =14
show = 1

Please delete this if it was already posted.
 

Mages4ever

Well-Known Member
Member
Joined
Sep 30, 2008
Messages
406
Trophies
0
Location
Canada
Website
Visit site
XP
100
Country
Canada
Yum.
Thanks
biggrin.gif

However, they are at "Show=1" and they still don't show up
tongue.gif

Unless the uisettings.ini is supposed to be in the calendar folder
tongue.gif
(But I don't think so)
 

NDStemp

GBAtemp?! No! NDStemp
OP
Member
Joined
Aug 30, 2008
Messages
627
Trophies
0
Age
28
Location
Canada, Ontario
Website
Visit site
XP
168
Country
Canada
Mages4ever said:
Yum.
Thanks
biggrin.gif

However, they are at "Show=1" and they still don't show up
tongue.gif

Unless the uisettings.ini is supposed to be in the calendar folder
tongue.gif
(But I don't think so)

I think there should be a space after 'show' and the equal sign.

So... "show = 1"
 

Mages4ever

Well-Known Member
Member
Joined
Sep 30, 2008
Messages
406
Trophies
0
Location
Canada
Website
Visit site
XP
100
Country
Canada
Mines like:
Code:
[big clock]
x = 25
y = 154
show = 1

[calendar year]
x = 229
y = 2
show = 1

[calendar month]
x = 209
y = 2
show = 1

[calendar day]
x = 146
y = 33
show = 1
 

basher11

Well-Known Member
Member
Joined
Jun 29, 2009
Messages
4,385
Trophies
0
XP
511
Country
United States
NDStemp said:
It should be showing, I don't know why it doesn't for you. Mind giving me the theme you're trying to get the calendar working for?

maybe there isn't a calendar for the skin?
 

Dark^'^Knigh

Well-Known Member
Member
Joined
Apr 25, 2007
Messages
1,043
Trophies
0
Location
Paradise
Website
Visit site
XP
86
Country
Mages4ever said:
Huh.
Mkay, I'll try your mirror o-o

Edit
Uhm, what the fooking chickens? It works.
Thanks? I guess? LOL.
When I first tried these themes for my AK2i a couple of months ago, I couldn't get the calendar to show up correctly. A short time afterwards (upon checking default skin in firmware), I realized I had incorrectly spelt the "calendar" folder as "calender" in all of my theme folders.
 

Dark^'^Knigh

Well-Known Member
Member
Joined
Apr 25, 2007
Messages
1,043
Trophies
0
Location
Paradise
Website
Visit site
XP
86
Country
Mages4ever said:
Oh shet.
I did that.
I'm dumb. I can't spell x)
I thought it might have been, that's why I posted it "delicately"....
nyanya.gif

There's not much to the setup, so it has to be something simple (given the themes are pre-made). At least others now have access to this info, should they have similar issues.
 
General chit-chat
Help Users
    kenenthk @ kenenthk: https://youtube.com/shorts/_nIv1PWxJhQ?feature=share