Calendar Fix for WoodR4 Themes

Discussion in 'R4 DS' started by NDStemp, Apr 11, 2010.

Apr 11, 2010

Calendar Fix for WoodR4 Themes by NDStemp at 6:20 PM (5,196 Views / 0 Likes) 18 replies

  1. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
    It's quite simple actually. Just make the calendar folder and put those 4 files in then there's a .ini file named 'uisettings'. Under [big clock], [calendar year], [calendar month], and [calendar day]

    There should be " show = 0 "
    Change it to " show = 1 " if you haven't and voila! Your calendar/time should now be appearing.

    1 means yes
    0 means no

    Here's an example.
    Code:
    [big clock]
    x = 136
    y = 155
    show = 1
    
    [calendar year]
    x = 179
    y = 164
    show = 1
    
    [calendar month]
    x = 132
    y = 164
    show = 1
    
    [calendar day]
    x = 140
    y = 23
    highlightColor = 0x25b5
    dw = 16
    dh =14
    show = 1
    Please delete this if it was already posted.
     
  2. basher11

    Member basher11 GBAtemp's Official Vocaloid Lover

    Joined:
    Jun 29, 2009
    Messages:
    4,382
    Country:
    United States
    good stuff my man
     
  3. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
    Lol. When I found out it was this simple, I felt stupid. =]
     
  4. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Yum.
    Thanks [​IMG]
    However, they are at "Show=1" and they still don't show up [​IMG]
    Unless the uisettings.ini is supposed to be in the calendar folder [​IMG] (But I don't think so)
     
  5. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
    I think there should be a space after 'show' and the equal sign.

    So... "show = 1"
     
  6. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Mines like:
    Code:
    [big clock]
    x = 25
    y = 154
    show = 1
    
    [calendar year]
    x = 229
    y = 2
    show = 1
    
    [calendar month]
    x = 209
    y = 2
    show = 1
    
    [calendar day]
    x = 146
    y = 33
    show = 1
     
  7. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
    It should be showing, I don't know why it doesn't for you. Mind giving me the theme you're trying to get the calendar working for?
     
  8. basher11

    Member basher11 GBAtemp's Official Vocaloid Lover

    Joined:
    Jun 29, 2009
    Messages:
    4,382
    Country:
    United States
    maybe there isn't a calendar for the skin?
     
  9. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
  10. penthaler

    Member penthaler GBAtemp Fan

    Joined:
    Oct 28, 2009
    Messages:
    357
    Location:
    mystique
    Country:
    Czech Republic
  11. Iggizaki

    Newcomer Iggizaki Member

    Joined:
    Sep 13, 2009
    Messages:
    21
    Country:
    Indonesia

    That one, eh? I tried using that theme on my wood. I think the problem lies with the font color. The calendar clearly shows up, and it highlights what day and date it is, it just doesn't show the numbers for some reason [​IMG]
     
  12. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
  13. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Huh.
    Mkay, I'll try your mirror o-o

    Edit
    Uhm, what the fooking chickens? It works.
    Thanks? I guess? LOL.
     
  14. Dark^'^Knigh

    Member Dark^'^Knigh GBAtemp Maniac

    Joined:
    Apr 25, 2007
    Messages:
    1,043
    Location:
    Paradise
    Country:
    Australia
    When I first tried these themes for my AK2i a couple of months ago, I couldn't get the calendar to show up correctly. A short time afterwards (upon checking default skin in firmware), I realized I had incorrectly spelt the "calendar" folder as "calender" in all of my theme folders.
     
  15. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Oh shet.
    I did that.
    I'm dumb. I can't spell x)
     
  16. Dark^'^Knigh

    Member Dark^'^Knigh GBAtemp Maniac

    Joined:
    Apr 25, 2007
    Messages:
    1,043
    Location:
    Paradise
    Country:
    Australia
    I thought it might have been, that's why I posted it "delicately".... [​IMG]
    There's not much to the setup, so it has to be something simple (given the themes are pre-made). At least others now have access to this info, should they have similar issues.
     
  17. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Heh. I wish renaming had spell check.
     
  18. NDStemp
    OP

    Member NDStemp GBAtemp?! No! NDStemp

    Joined:
    Aug 30, 2008
    Messages:
    627
    Location:
    Canada, Ontario
    Country:
    Canada
    Aha, glad to know that it's working for you. ^^
     
  19. Mages4ever

    Member Mages4ever GBAtemp Fan

    Joined:
    Sep 30, 2008
    Messages:
    406
    Location:
    Canada
    Country:
    Canada
    Thanks [​IMG]
    I should learn how to not rely on auto-correct.
    I'm going to update my FAQ now o-o
     

Share This Page