Caffeine updated to support FW 4.1.0, works on patched Switches

Discussion in 'GBAtemp & Scene News' started by RattletraPM, Jun 25, 2019.

  1. gRoberts84

    gRoberts84 Member

    Newcomer
    1
    Jul 1, 2019
    United Kingdom
    I'm in now :) Just trying to get EmuMMC working. Black screens :(
     
  2. j0hnnyj0hns

    j0hnnyj0hns GBAtemp Regular

    Member
    5
    Jun 3, 2016
    United States
    I use ChoiDujourNX for emuNAND
     
  3. 2pacsawyer

    2pacsawyer Newbie

    Newcomer
    1
    Jul 2, 2019
    United States
    EDIT from what I said below:

    I went on the gethub page for atmosphere and manually updated to 0.9.2 and it booted right into the CFW. Now I have to figure out how to play games... I was able to install a .nsp game but when I launch the game it tells me that the Nintendo account used to purchase this software has been unlinked.
    ----------------------------------------------------------------------------------------------------------------------------------
    The first day ever owning a switch I was able to get the "fake news" installed and I was able to load the HomeBrew menu from PegaScape. I'm also able to load Hekate. When I select Launch then CFW It looks like its working. I see the AtlasNX Kosmos screen followed by the Nintendo boot logo.

    The boot logo just sits there and never loads into the CFW. I left it at the boot logo for about 45 minutes without it continuing. The display dims at the boot logo and I can tap the screen which brightness the screen so I don't think it's frozen. Am I doing something wrong or does it really take this long to load the CFW?


    Ipatched Switch running 4.1.0
    I used the Caffeine Exploit by following the guide on switch.homebrewdotguide's website
     
    Last edited by 2pacsawyer, Jul 2, 2019
  4. Dev_

    Dev_ Member

    Newcomer
    2
    Jul 31, 2018
    Morocco
    one question pls is it safe to apply 4.1.0 exfat update to sysnand with choidujourNx ?
     
  5. gRoberts84

    gRoberts84 Member

    Newcomer
    1
    Jul 1, 2019
    United Kingdom
    Sorry all, issue was because of a bug with atmosphere - my issue has been sorted.

    No. Emunand I'd say yes but only if you are using offline.
     
    Dev_ likes this.
  6. OperationNT

    OperationNT GBAtemp Fan

    Member
    6
    May 1, 2016
    France
    It should work but it's very risky on patched unit: if there is the slightest issue, your Switch is definitly transformed into a paperweight.
    If you take the risk, don't forget to disable AutoRCM!
     
  7. 2pacsawyer

    2pacsawyer Newbie

    Newcomer
    1
    Jul 2, 2019
    United States
    I would boot into hekate and use the emuMMC creation tool. This allows you to backup and run the system firmware on a micro sd card. As you cant enter RCM on a ipatched witch if you mess up the original firmware your basically bricking your switch from what I understand. If you mess up the emuMMC you can just delete it and create a new one.
     
  8. Dev_

    Dev_ Member

    Newcomer
    2
    Jul 31, 2018
    Morocco
    thanks guys for the REPLAY i did update the sysnand on the patched unit to 4.1.0 exfat with choidujournx 1.0.2 everthing is fine the only thing to make sure is to uncheck the "prevent efuse from burning (enable autoRCM )". it works fine + i did used a micro sd with 2 partion first with exfat for normal use + second fat32 for emunand with lastest firmware
     
    Last edited by Dev_, Jul 10, 2019
    ModderFokker619 likes this.
  9. CaptainSodaPop

    CaptainSodaPop GBAtemp Regular

    Member
    6
    Aug 10, 2012
    Croatia
    Is it realistic to expect that this will ever be compatible with 8.01?
     
  10. stick267

    stick267 GBAtemp Advanced Fan

    Member
    5
    Dec 17, 2018
    United States
    I believe Nintendo patched this exploit in 8.0, so it will never work on any firmware 8.0+.
     
    teamlocust likes this.
  11. eteles

    eteles Member

    Newcomer
    2
    Jun 3, 2009
    Brazil
    I have a patched 6.2.0 unit... Will it be available for my unit soon?
     
    teamlocust likes this.
  12. eteles

    eteles Member

    Newcomer
    2
    Jun 3, 2009
    Brazil
    What about 6.2.0?
     
  13. teamlocust

    teamlocust Advanced Member

    Newcomer
    4
    Oct 28, 2017
    India
    any eta for patched units above 4.1.0 upto 7.0.1 ???

    — Posts automatically merged - Please don't double post! —

    any updates?

    — Posts automatically merged - Please don't double post! —

    any updates for patched units above 4.1.0 ???

    — Posts automatically merged - Please don't double post! —

    any updates for 5.1.0 deja vu?
     
  14. Essasetic

    Essasetic Your Local TX Fanboy Rebirth

    Member
    11
    Jun 16, 2018
    United Kingdom
    No. Be patient it'll come eventually.
     
  15. teamlocust

    teamlocust Advanced Member

    Newcomer
    4
    Oct 28, 2017
    India
    thanks for the prompt reply, gonna pack my ipatched switch 5.1.0 and store it in my cupboard then.
     
  16. deSSy2724

    deSSy2724 GBAtemp Fan

    Member
    4
    Sep 11, 2015
    Germany
    Can someone please tell me if the foollowing scenario is possible?

    My unpatched Switch is still on OFW 2.X (never hacked, never updaed, never played/installed anything to it)... now im wondering is there any way to avoid using jigs/rcm dongle and to avoid using autorRCM, is the following setup possible?

    Bootloader to choose between:
    1. Untouched OFW 2.X (never updating it)
    2. Cloned OFW/sysnand from the untouched one and update it to the latest 9.X firmware to be able to use with my legit purchased games and eshop/online play
    3. Dual boot SX OS CFW and Atmosphere CFW for all the other stuff like homebrews/backups on the latest 9.X firmware (keeping it offline forever)

    Basically, that without jig/rcm dongle/autorcm and without burning fuses?
     
    Last edited by deSSy2724, Oct 5, 2019
  17. raxadian

    raxadian GBAtemp Maniac

    Member
    6
    Nov 10, 2018
    Argentina
    Don't update the firmware, that's the worst option when it comes to the Switch.

    Edit: Unfortunately my Switch is on 5.1
     
    Last edited by raxadian, Oct 5, 2019
  18. Jonhy

    Jonhy GBAtemp Regular

    Member
    5
    May 22, 2016
    United States
    If you want a warmboot, update to 4.10 to use the caffeine.

    Do some research beforehand though.
     
  19. guily6669

    guily6669 GbaTemp is my Drug

    Member
    7
    Jun 3, 2013
    United States
    Doomed Island
    Caffeine says it supports from 2.0.0 to 3.0.0 and 4.01 to 4.1.0 so he probably don't need to update it to 4.1... But no idea as I never tried this, my FW is on 3.02 and its sad that there is always no love for 3.02 and I'm not gonna update to 4.1 either, I want my sysnand intact unless it would be to modify something for coldboot, then I would update to whatever FW it would require :grog:.


    It's sad that no one still shown anything with the coldboot exploits running:sad:, but I don't care if it comes even years from now, my console will be waiting for it and in the meanwhile I have a ON\OFF switch in my joy-con for RCM and keep using the phone to inject (cheap way).
     
    raxadian likes this.
  20. Jonhy

    Jonhy GBAtemp Regular

    Member
    5
    May 22, 2016
    United States
    I mean there probably will never be an interest till EOL. There's absolutely no loss to updating to 4.10 though. I don't get the interest of staying on 3.X.
     
Loading...