Browserhax on 4.1.0-6E is it possible?

Discussion in '3DS - Flashcards & Custom Firmwares' started by FaSMaN, Nov 30, 2015.

  1. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Hi everyone,

    In my never ending quest to hack my launch day o3DS (currently stuck on the firmware above), I wanted to launch RXTools, from Browserhax , and tried following several of the guides posted online to get Browserhax working, visiting several websites from my 3ds (launch.rxTools.net , Reboot.ms , http://dukesrg.github.io/?rxxxxxxx , and a few others)

    When I access the site , but no matter which site I visit and try to load the exploit, my wifi light blinks a bit, the browser closes , and I get a error stating my save games might be corrupt , nothing actually launches

    All I want to do is to upgrade the console to either 4.5 or 9.2 as I have a shiny copy of Cubeninja and Oot waiting to load a better exploit....

    Is there any hope for me, I dont want to buy a game to upgrade as Ninendo stopped selling 3ds games at all of the games shops around me, and I dont know what revision I will get when ordering one online , not to mention they are very pricey there.

    Is there any hope for me , or should I just upgrade to 10.3.0-28 , enjoy some hombrew and wait for a better expoit to downgrade?
     
  2. MassExplosion213

    MassExplosion213 .

    Member
    1,405
    953
    Feb 15, 2015
    United States
    Get ahold of a DS flashcart and do MSET.
     
  3. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Doesnt mset work from browserhax as well, reboot.ms does have a option to load it?

    The only reason I am asking is becouse I really dont want to order another flash card online , they (Customs) allready helped themselves to a GW I ordered several months back?
     
  4. TheCheeze

    TheCheeze Member

    Newcomer
    19
    5
    Nov 3, 2014
    United States
    That happened to me too. I redownloaded RXtools and it started working (4.1.0 at the time)

    -edit-

    Almost forgot i had redowloaded the slot key or whatever it is called too. Dont know which was the fix since i did both at the same time
     
    Last edited by TheCheeze, Nov 30, 2015
  5. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    You need to upgrade the system to specific firmware. 9.0 will do. Use a game to get your firmware to 9.2 or down to 8.1.0 (?) and then use browserhax.
    Browserhax is not the same as a MSET downgrade and without a Gateway, you cannot do that. (I think...) So, you're options are:
    Get Gateway,
    Or upgrade the console to 9.0/9.1/9.2 ( But no higher than 9.2. )
     
    kiwiis likes this.
  6. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Thanks TheCheeze, do you know what version of RXtools work for you and what site you visited?
     
  7. Rioluwott

    Rioluwott GBAtemp Advanced Fan

    Member
    646
    91
    Feb 23, 2014
    Mexico
    You can launch Rxtools with Cubic Ninja
    Ninjhax work on 4.X too
     
  8. TheCheeze

    TheCheeze Member

    Newcomer
    19
    5
    Nov 3, 2014
    United States
    2.6, and that is still what I use. I have never needed used a flashcart.
     
    FaSMaN likes this.
  9. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Hi Rioluwott , unfortunately according to the Ninjahax website it only does 4.1.0.7E and up, using the 4.1.0.7 exploit just freezes my console, as its on 4.1.0.6

    — Posts automatically merged - Please don't double post! —

    Thanks TheCheeze will give that another go and let you know :)
     
  10. Rioluwott

    Rioluwott GBAtemp Advanced Fan

    Member
    646
    91
    Feb 23, 2014
    Mexico
    Try cleaning th browser and try again also download the files again spiderhax or whatever is difficult to get it working also i think that OoThax work without internet browser but try what i told you
    DO NOT UPDATE
     
  11. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    a Huge thanks to TheCheeze , grabbed a new SD card, formatted it , and bang, exploit is working 100% , I could launch both RXTools , as well as Gateway 3.4.1 (3.5.1 apparently causes bricks)

    Currently I have Gateway Launcher on and doing a full nand backup.

    I just now need to find a good tutorial to downgrade/upgrade to 9.2 using NUS, if I am not mistaken NUS downloader doesnt work any more, and I will have to use a "other" method of obtaining the files :(

    Any advice?
     
  12. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Okay, I am now on 9.2.0 20E

    Heres what I did:

    1. Prepare and format a new SD Card

    2. Guide: https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/

    Do Step 1 , from the above guide, dont do emunand just yet, but make a full nand backup

    3. Do step 2 , but download RXtools 2.5.2 (You need working Dev Mode)

    4. Do Step 3, but instead of going to their website goto: 3ds.reboot.ms

    5. Do STEP 4a , install fbi to health and safety using RXTools (remember to press "R" in RXTools)

    6. Install SysUpdater

    7. Follow: How to Update your 3DS/2DS to 9.0 or 9.2 , remember to press "R" in RXTools

    8. Enjoy.

    Optional: Make another backup of your system
     
    Last edited by FaSMaN, Dec 1, 2015
    Milo5789 likes this.
  13. Alex3dss

    Alex3dss I like sharing Japanese music

    Member
    414
    44
    Aug 21, 2015
    Netherlands
    Location unknown
    You know whats funny? I just made a thread about this and there the question has been answered XD
     
  14. Ruby Gloom

    Ruby Gloom GBAtemp Maniac

    Member
    1,553
    505
    Sep 25, 2015
    Dalvík, Iceland
    I know I still might be wrong on this... But, I thought browserhax only worked on 6.0 and up...? Thus why I stated they needed to update.
     
  15. Alex3dss

    Alex3dss I like sharing Japanese music

    Member
    414
    44
    Aug 21, 2015
    Netherlands
    Location unknown
    Probably it is only 6.0 - 10.1. When you have a 3ds on 9.9 - 10.1 you need the Tubehax DNS to make Browserhax work. Bellow 9.9 you dont need the DNS
     
  16. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    3,000
    1,053
    Jun 28, 2014
    United States
    Arizona Bay
    Use mset to update the firmware. -6 browser doesn't support rxtools but being on 4.x you can just update to 9.2 with rxtools booted from mset
     
  17. TheCheeze

    TheCheeze Member

    Newcomer
    19
    5
    Nov 3, 2014
    United States
    I think you guys missed the part where both the OP and myself had gotten it working (via browserhax) on 4.1 browser (not even version -10. Is definitely possible without using mset or a card or OoT
     
  18. FaSMaN
    OP

    FaSMaN Advanced Member

    Newcomer
    72
    4
    Jun 6, 2005
    Yup its working 100% on 4.1 could do everything , except boot Homebrew Channel (no payload for my exact version but lets say your on 4.2, it will work),

    RXTools worked perfectly on 4.1.

    Could have happily kept it on 4.1 but decided to use FBI and NUS to upgrade it to 9.2 so I can use Homebrew aswell.

    Didnt need any other exploits other than Browserhax .

    For more info read the Github, but mostly Browserhax depends on the Internet Browser version not the System version, its also vital to remember that the browser doesnt always get updated from a gamecard and might need the full update.
    https://github.com/yellows8/3ds_browserhax_common