Bringing my Wii back to life

Discussion in 'Wii - Hacking' started by Prince Valmont, Feb 7, 2010.

Feb 7, 2010
  1. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Ok, small story short: I used to frequent this board, use to mod my wii way back when. But since August, I've strayed away and I want to get it back to tip top hacked shape, and I need your help.

    First off, here are my current specs:
    • Firmware: 3.2U
    • HBC: Version 1.0.1 installed
    • Softmod: cIOSCORP (old old version, which will cause a problem I'm sure)
    • Preloader v0.28
    • IOS v30
    • Sysmenu v289
    • cIOS38 rev14
    Now the first step I tried taking was to update the HBC to v. 1.0.6, which gave me the following message:

    HackMii v.0.6
    This installer can NOT continue!
    "...no known vulnerable IOS installed..."

    Upon researching www.hackmii.org, I found out it's most likely caused by my install of an early version of cIOSCORP.
    • What I want to do is remove this old version of cIOSCORP.
    • Then I want to update my HBC
    • Then update my system menu to 4.1 (which I believe causes less problems than 4.2; correct if wrong)
    • Install a safeguard (like Priiloader & BootMii)
    • Install the newer, more stable release of cIOSCORP (what are we up to now, 3.6?).
    How plausible could this be? I'm sure once I get the hang of things, I'll be a quick learner. The first step I want to do: Remove the old cIOSCORP. How can I go about doing this without bricking my system?
     
  2. lolzed

    Member lolzed The GBAtemp Pichu

    Joined:
    Sep 13, 2008
    Messages:
    2,466
    Location:
    There
    Country:
    Philippines
    removing cIOSCorp is easy,get the 3.6 version,then install it(or uninstall the old one,not sure if there is an option for this,but find the way to uninstall) then run the Hackmii installer,once you got Bootmii(FIRST!)and everything up,go 4.2 or 4.1,your choice.If your gonna use the System Update,IOS wont be a problem,but if your gonna install the System Menu via WAD Manager,install IOS 70 for 4.2 and 60 for 4.1 first

    more info here
    http://gbatemp.net/index.php?showtopic=171901
     
  3. mauifrog

    Member mauifrog DA KINE WiiHacker

    Joined:
    Jan 21, 2010
    Messages:
    1,585
    Country:
    United States
    Sounds fine to me.

    I would put your wii online, use dop-ios-mod v11.5 with ios249
    Install ios34 without patches, install ios60 with patches
    Then run the hackmii installer v0.6 and install HBC, Bootmii as boot2 if you can, ios if you can't, DVDx if you like not sure if it is updated or not.

    Then run the cIOSCORP 3x uninstaller
    Update to 4.1, use dop-ios-mod or the safe updater, be sure to install ios60 with patches first
    Then install cIOSCORP 3.6

    After that install priiloader and perhaps cios38-r17
     
  4. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
  5. toejam316

    Member toejam316 GBAtemp Regular

    Joined:
    Apr 20, 2007
    Messages:
    259
    Country:
    New Zealand
    Or if you want to virginize your Wii then re-hack it, just update online to 4.2, then follow one of the many, many tutorials available.
     
  6. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Ok, using dop-ios-mod, I've installed ios249. Now, using the same program, I'm attempting to install ios34 without patches. Under the DOP-IOS menu, I've selected IOS, then scrolled to IOS34 and tried to install the latest v3348 of IOS34, but it's not asking me if I want patches or not. Am I supposed to be using the DOP-IOS to install IOS34 & IOS60? And will I be prompted to install patches or not?
     
  7. Krestent

    Member Krestent What to post?

    Joined:
    Mar 31, 2009
    Messages:
    3,952
    Country:
    United States
    You just deleted your cIOS by installing IOS249 with DOP-IOS MOD. The IOS249 on Nintendo's server is a stub, it doesn't do anything.
     
  8. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    That's impossible (or should be anyway). DOP-IOS MOD doesn't let you install stubs...if he really installed it with DOP-IOS MOD, there's a bug that needs squashing.
     
  9. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Well when the program first starts up, it asks me which IOS I would like to use to install other IOSes?, I selected IOS: 249 and then hit A. That's all I did with this program so far.
     
  10. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    What DOP-IOS are you running? You should use DOP-IOS MOD 11.5.

    It should ask about the patches. You should say NO them for IOS34 and IOS61, and YES to them for IOS60. If it doesn't ask, I have no clue why.
     
  11. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    It is indeed 11.5.
    So to progress forward, I tell it to run under IOS249, then select IOSs, scroll left to select IOS34. Then I have some different options:
    (A) Install latest v3348 of IOS34
    or
    (-)/GV:(L): Install old v1039 of IOS34
     
  12. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    Install the latest version of IOS34 and IOS61.

    When you get to IOS60, it's only going to offer the "old" v6174. Just install the v6174.
     
  13. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Alright, techboy, it's working like a dream now.

    Another question, and this one is just me being picky.

    I installed bootmii as Boot2, but is there anyway to disable it popping up every time I turn on the wii? Just having to get up to the system to push reset each time to load the system menu causes a slight annoyance. There's a way to load it from HBC, isn't there?
     
  14. FenrirWolf

    Member FenrirWolf GBAtemp Psycho!

    Joined:
    Nov 19, 2008
    Messages:
    4,343
    Location:
    Beaverton, OR
    Country:
    United States
    Get the bootmii configuration editor from wiibrew. You can use it to skip the bootmii screen or autoboot the system menu or HBC after a few seconds of inaction.
     
  15. veganjustice

    Newcomer veganjustice Advanced Member

    Joined:
    Nov 20, 2008
    Messages:
    69
    Country:
    United States
    To add on to that, even if it is installed as IOS you'll still have it installed as boot2, and you'll still get the BootMii menu at boot.

    But, as FenrirWolf said, the bootmii configuration editor is a great tool.
     
  16. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Alright, took your advice, did the configuration tool. Perfect. Thank you.
     
  17. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Now for IOS61. Using DOP-IOS, do I want to install using the FakeSign patch?
     
  18. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    Don't apply any patches to IOS61.

    Doing so on IOS61 can make your HBC appear upside down, and causes issues with the shop channel.

    While you're in DOP-IOS MOD, install the latest shop channel as well. Old versions nag you to update when you run them.
     
  19. Prince Valmont
    OP

    Member Prince Valmont GBAtemp Regular

    Joined:
    Oct 7, 2007
    Messages:
    208
    Location:
    Midwest
    Country:
    United States
    Yeah, that's why I went for IOS61. As always, Thanks again for the advice!
     

Share This Page