Bought new DSTwo, unknown firmware [3DS]

Discussion in '3DS - Flashcards & Custom Firmwares' started by l30nc1t0, Nov 25, 2011.

Nov 25, 2011
  1. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    Hi y'all from Argentina.

    I have just received my DSTwo (I have been using a RTS Lite from http://www.r4isdhc.com/rtssliver/ fine).

    The problem is as follows: I formated the microSD card, then copied the EOS files (from http://down.supercar...11_1108_eng.zip). The card seems to be working fine (I have not tried to run anything from it yet), and EOS boots normally. It shows itself as "Alex Rider Stombreaker THQ" to the console.

    Now, I have been postponing the 3DS console update ever since I bought it, and it is currently in version 2.1.0-3U. Before upgrading I decided to (just in case) upgrade the DSTwo card first with firmware 1.13 (from http://down.supercar...e_v1.13_eng.zip), following the directions provided in http://forum.superca...d-8832-1-1.html (yes, I know it is intended for v2.0.0-3). But nothing happens.

    So, to summarize: I have a 3DS console with firmware 2.1.0-3U; a running DSTwo with EOS kernel v1.11.1108 but with unknown firmware version. I want to upgrade the console, but just to be sure the DSTwo will work after the console upgrade, I want to upgrade the DSTwo itself. Yet when I rename the "dstwoupdate.dat" to "dstwoupdateb.dat" from firmware v1.13 nothing happens, it just loads the main screen normally where I can select EOS.

    What should I do to upgrade the flashcard? Should I not rename the updater file? Any suggestions?

    Many thanks in advance! :D :D :D

    PS: For those who will say "use an old DS", I do not own a previous Nintendo product (this is my first console), and I don't know anyone with DS console. If I have to go with that option, I will have to pay for "support" at some random console store around (if it's even possible). :blink:
     
  2. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    Pardon me if I am wrong (I don't have a DSTwo myself, so I don't know how it works), but I don't think you have to rename the file.

    That method on the guide is only used if your SCDS2 doesn't run on the 3ds firmware. From what I see, you have a DSTwo that can run on the current 3ds firmware, but want to update your DSTwo's boot-strap first before updating your 3ds' firmware. Meaning, you don't have to rename the file in order to update. Keep the file name the same and (from my limited knowledge on DSTwo carts) it should automatically start the update process.

    Hope this works~
     
  3. Luigi2012SM64DS

    Banned Luigi2012SM64DS G-old member

    Joined:
    Aug 27, 2011
    Messages:
    2,060
    Location:
    Minecrapt
    Country:
    Canada
    you already have frimware 1.13 go update your fine :)
    the guide you read is old. but it still works.
     
  4. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    Thanks @s4mid4re and @Luigi2011SM64, I renamed the file back, it recognized the upgrade from v1.12 beta to v1.13 (still "Alex Rider Stombreaker THQ").

    Finally I updated the console from v2.1.0-3U to v2.1.0-4U (I thought the latest was v2.2.0-4). Nothing has bricked, everything seems to work fine except my old savegames (I'll find a solution for that later).

    Thanks again, and sorry for asking such a dumb question. I was afraid it would brick my new, shinny flashcard. :D

    My regards.
     
  5. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    hehe np with me~

    As for saves, the DSTwo can use one of two save extensions: .sav or .nds.sav. Look at your save and see which one it is. Then, look at your settings and see if the save extension is set the same as the extensions on your currently existing saves.
     
  6. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    @s4mid4re, thanks again. Both of them are ".sav" files, I believe it has to do with different headers. I'll look in to it.

    Once again, thanks!
     
  7. Pablitox

    Member Pablitox GBAtemp Advanced Fan

    Joined:
    Oct 18, 2011
    Messages:
    615
    Country:
    United States
    you are so lucky bro, but i will get one soon! btw im from Argentina :D

    i have a question, can i use the flashcart helper to update so i can use it on a 3DS?
     
  8. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    @Pablitox

    Hi, nice to see a compatriota around here... I don't know about Flashcart Helper, I have downloaded all the files from the official site (manually).

    I bought my DSTwo from Lightake, and I'm assuming they upgraded the firmware before shipping (since it came with v1.12 beta), and I placed the order about a month ago and received it today (China takes its time to deliver :D). Luckily, my 3DS was still on August's firmware (v2.1.0-3U), and it has not pushed me to the newest update yet. I believe that's the reason I didn't have any issues. Nevertheless, I somehow lost all my saves (although I do have a backup), and I'm trying with the site http://www.shunyweb.info/convert.php, but still no luck :(.
     
  9. s4mid4re

    Member s4mid4re  

    Joined:
    Apr 2, 2011
    Messages:
    1,669
    Country:
    United States
    Can you elaborate as to what you mean by "saves not working"? Does it not read the files, or does it say the save file is corrupted? Make sure that the .nds file and .sav's names are identical (i.e. if you have a pokemon black.nds, make sure your save says pokemon black.sav)
     
  10. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    I appreciate your time and consideration, @s4mid4re, I meant the DSTwo was not reading the savefiles (I could create a new one, but the old ones remained as if they were not there).

    I was thinking on the same line as you did: it's either a name compatibility issue, or it's the header (but R4 RTS Lite it supposed to be based on Acekard, and Acekard ".sav" files are compatible with DSTwo). The problem originated when I formatted the microSD card, when I was playing with the RTS Lite I had it in FAT16, so all names are limited to eight characters. But when I formatted it again, for the DSTwo, I did it in FAT32. So now, the save files have grown a full fledge name on their own, hence the incompatibility issue.

    I'm renaming all files now.

    Thanks again.
     
  11. Pablitox

    Member Pablitox GBAtemp Advanced Fan

    Joined:
    Oct 18, 2011
    Messages:
    615
    Country:
    United States
    oh alright then, flashcart helper is an application that helps you to update flascarts without the need of another DS, or so i understood, i want to know if i can use it to uptade it automatically. oh well guess i will have to try, im thinking on buying it in hadriatica using mercadolibre
     
  12. l30nc1t0
    OP

    Newcomer l30nc1t0 Newbie

    Joined:
    Nov 25, 2011
    Messages:
    6
    Location:
    Buenos Aires
    Country:
    Argentina
    @Pablitox. I don't see the use of a third party application to update the flashcard. I have updated my RTS Lite with the 3DS before with no issues whatsoever. I came across this site looking for a solution on the DSTwo because I was afraid of bricking it, since I was unaware of the current firmware in the flashcard. But, then again, it is possible to update with the 3DS console, given the right firmware versions.

    To tell you more, I don't know much about the Flashcart Helper homebrew app (for what I read Ron975 keeps it up date), but I always prefer downloading the latest updates from the original sources. And it's as simple as placing a file in the microSD, launching the "game", select the update (in the case of the RTS Lite) or it will ask for the update (in the DSTwo case), wait for 3-5 minutes while it's updating, and it's done. Then you can update the console if required. The other problem is as follows: if you need to update the flashcard because is not being recognized by the 3DS you will need an old DS or a non-updated console, you won't even have the chance to run a homebrew app because it needs the flashcard to run from. I believe the app you're mentioning it's useful to keep things organized on a working flashcard.

    Anyway, I'm PM'ing you to stay on topic and because I don't know if it's against forum rules to post in another language than English (regarding ML and Hadriatica).

    Best regards.
     

Share This Page