1. Fawe

    Fawe Advanced Member
    Newcomer

    Joined:
    Aug 6, 2020
    Messages:
    95
    Country:
    Germany
    What? You don't need the Nintendo WiFI USB Adapter for Bluebomb, it has nothing to do with it?
     
  2. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    You can use it to push data and updates to the Wii, but yes you don't need it for Bluebomb.
     
  3. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    Not sure if this is the right place to ask this so apologies if it isn't, but I run into a hangup when I try to Bluebomb my semi-bricked Japanese Wii.

    I go through the process of creating the FAT32 USB drive with "boot.elf" from Hackmii installer and plug that into the bottom USB port of the Wii. I run the linux process using Ubuntu 20.04 LTS on my Lenovo laptop and I can get the connection established with the Wii (i.e. "got connection handle"), but then everything pauses at "waiting for response from Stage0" and hangs there indefinitely unless I kill the process.
    I'm not coding minded/particularly IT savvy, but am good at following instructions so I will gladly take any advice from anyone on here (my plan tonight it to remove all other Bluetooth devices from near the Wii when I try to launch the exploit).

    Also FWIW I have tried Modmii/Letterbomb and have not had any success.
     
  4. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    Unless is the Wii mini, you could install BootMii in the SD card using ModWii to try to unbrick it.
     
  5. Fawe

    Fawe Advanced Member
    Newcomer

    Joined:
    Aug 6, 2020
    Messages:
    95
    Country:
    Germany
    Unless he already has BootMii installed, putting the BootMii files on his SD card won't do anything.
     
    alexander1970 likes this.
  6. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    On firmware 4.3 there is a way to hack the Wii using the sd card. Bluebomb is mostly useful if you have a Wii Mini.
     
  7. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    I don't have a Wii Mini unfortunately. I have a Japanese Wii which I received with 2.0J on it and then inserted Wii Sports Resort and did the update and then SMG2 and did the update (foolishly thinking this would help me letterbomb the thing when instead I should have just used ModMii - hindsight is 20/20).
    I tried running the Bluebomb again tonight from a computer with Ubuntu installed instead of just Ubuntu on a flash drive and again I get to "awaiting a response from stage0" where it then hangs.
     
  8. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    See if it works in Puppy Linux Fatdog that has quite a good compatibility with older hardware that latest versions of Ubuntu and Mint don't do.

    Alternatively just ask in the ModMii thread.
     
    Last edited by raxadian, Mar 3, 2021
  9. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    11,232
    Country:
    Cyprus
    You forgot to include a link to the previous discussions we had on this so everyone can fully get up to speed without having to ask the same questions:
    https://gbatemp.net/threads/well-i-feel-sheepish.583838

    @raxadian, if you look at the sheepish thread you'll see we tried a bunch of things and he cannot get letterbomb\wilbrand or str2hax to work (and iirc also disc won't load so disc based exploits don't work), so that's why he's trying bluebomb to try to unbrick his Wii
     
    alexander1970 likes this.
  10. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    Uh.

    So we have a Japanese Wii with no disk drive that's half bricked.

    And neither Ubuntu or Mint work on the computer, at least not for this.

    My best guess is that's because both Ubuntu and Mint latest versions have compatibility problems.

    Instead of Mint 20, use a live CD of Mint 19.3.

    Mint 19.3 is the last Mint version that's compatible with a lot of olf hardware and is still supported until the year 2023.

    Alternatively try Puppy Linux Fatdog 64. Is the version of puppy linux most compatible with hardware that has problems or is old. But it has to he 64 bits hardware or it won't work. Also to use Bluetooth for this hack you need to use Terminal programs.
     
    Last edited by raxadian, Mar 3, 2021
    alexander1970 and XFlak like this.
  11. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    Well, tonight I tried to run the Bluebomb exploit using a bootable USB version of Mint 19.3 and I stop at the same "Awaiting a response from Stage 0" .

    Should I expect anything different from Fat Dog or is there a different problem plauging me/the Wii? (FWIW I have been using the guide here https://wii.guide/bluebomb.html)
     
  12. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    Fatdog is different from Mint and Ubuntu but you will need to use terminal programs to do stuff like send files by Bluetooth.

    However it seems the problem may be that the computer Bluetooth adapter may not be fully compatible with Linux?

    Have you tried borrowing a different computer?

    Edit: Completely useless for this but here I found an old guide for Wifi on the Wii.

    http://web.archive.org/web/20150927083939/http://db.gamefaqs.com/console/wii/file/wii_networking.txt

    ... Wait can you Wii get online?
     
  13. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    I downloaded FatDog, but I honestly don't know how to follow these instructions (https://github.com/Fullmetal5/bluebomb) since I don't have a Wii Mini and as much as I can follow instructions I don't really know what all of the Linux commands are doing.
    I've tried the packaged bluebomb on two different Lenovo computers running Linux so far (one fully installed, one via USB)
    The Wii was connected to the internet at one point (right before I did the wrong region disc update with SMG2), but I don't know how to tell if it is anymore (and I dont have the internet channel)
     
  14. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    In settings you can set up an Internet connection. Can you still access settings? It may also be possible to load the Internet channel from a SD card. Then you can use the Webpage hack... or not.

    Otherwise you may try with a Wii recovery disc... but that may brick your Wii even more.
     
  15. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    Cannot get into settings. Tried the various channels and selecting news and weather brings up "This channel is not available" (in Japanese) and the shop channel says that I did not agree to the terms so I cannot use.

    I tried searching for ways to install the internet channel from an SD card and came up empty...
     
  16. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    Loading the old homebrew app doesn't from just the sd card doesn't work past firmware 4.0 and that could have been used as a gateway to install the Internet channel.

    Anyway if you really wanna risk it, use the recovery disc for your region of Wii. Best case your firmware will be restored to an old version and you will end with a few bad sectors. Worst case your Wii will brick even more and become unfixable.

    Do the Wiimotes even work on that Wii? Otherwise the Bluetooth exploit won't work.

    Edit:

    https://wiibrew.org/wiki/Bluebomb

    Edit2: Bluetooth does have problems in Linux in some laptops. Usually Mint or at least a version of mint will work.

    Edit3: https://github.com/Fullmetal5/bluebomb

    Edit 4: Wii mini hacking Discord? Clarify you have a bricked White Japanese Wii:

    https://discord.gg/MYm9kB7

    Edit 5: I had a similar brick ages ago but it didn't include trying to update to the wrong region. In that case the restore disk worked but again,; is risky as hell.
     
    Last edited by raxadian, Mar 9, 2021
  17. AptMadooms

    AptMadooms Member
    Newcomer

    Joined:
    Feb 26, 2021
    Messages:
    16
    Country:
    Canada
    An update - all is well in the end - I didn't realize that Super Mario Galaxy 2 only updates to 4.2U instead of 4.3U so now I have been able to install homebrew once I used the right version.

    Thanks so much everyone for your efforts. Greatly appreciated!!!
     
    raxadian and XFlak like this.
  18. raxadian

    raxadian GBAtemp Addict
    Member

    Joined:
    Nov 10, 2018
    Messages:
    2,708
    Country:
    Argentina
    What did you do to fix things?
     
  19. XFlak

    XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    11,232
    Country:
    Cyprus
    he reported this in his other thread:
     
    raxadian and alexander1970 like this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Bluebomb, exploit,