Hardware Blue Screen - Memloader Error

Irepairphl

Member
OP
Newcomer
Joined
Apr 11, 2019
Messages
5
Trophies
0
Age
37
XP
62
Country
United States
Hey guys I have a Switch that blue screened. Our customer said the unit was never or altered. I am following 'How to Install run any switch firmware unofficially without burning any fuses' guide step by step but I am getting stuck at STEP 8.2: TRANSFER BOOT0. After injecting memloader, when I try to start ums_boot0.ini I get the following error.

BOOT section 'ENTRY'
pc=0x80110000
1zma: Decoding error = 1
[MTC_LOAD] Error during 1zma decompression, got 0 instead of 246400 bytes out!

Has anyone seen anything like this? I have replaced BQ24193 though it's possible it is still faulty? I checked pin 5 voltages for M92T36 and they read correctly.
 

Attachments

  • 20190513_171944.jpg
    20190513_171944.jpg
    1.1 MB · Views: 285
  • Like
Reactions: Mickysky

Mickysky

New Member
Newbie
Joined
May 20, 2019
Messages
3
Trophies
0
Age
35
XP
49
Country
Chile
In the same situation with some differences in the bytes in the error

BOOT section 'RCM'
pc = 0x80110000
1zma: Decoding error = 1
[MTC_LOAD] Error during 1zma decompression, got 246400 instead of 4294967295 bytes out! will the number of bytes be fine?
I have not been able to solve the problem either, neither by MEmloader tegrarcmgui nor by memloader.bin in sd, greetings.
 

Hyperfluffy

Member
Newcomer
Joined
Mar 22, 2020
Messages
7
Trophies
0
Age
66
XP
39
Country
United States
Have this too with my switch. When you are able to run hecate you can make a backup of boot0 boot1 und rawnand und then alter the backups on your pc with NxNandManager (for boot0/1) and hacdiskmount (for rawnand) and then write it back via hekate.
 
General chit-chat
Help Users
    A @ Argimor: Anyone got any secret knowledge on Monster Hunter Rise Switch saves? Managed to pull the saves...