Blank Wads appearing in ShowMiiWads (VC,WiiWare)

Discussion in 'Wii - Hacking' started by Mr.Wiizard, Apr 3, 2014.

  1. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    Hey everyone, I have been trying for days to get my softmodded Wii 4.3u to play VC/WiiWare and I'm at wits end. I followed the instructions to many tutorials note for note, yet I run into the same problem every time. I have followed this guide to setting up Mighty Channels and also this guide but each time I attempt to load my wad files into ShowMiiWads they show up completely blank. Say if I try adding 50 wads, 20 blank lines will show up and they fail when I right click "extract>to nand". Here is the process I've taken so far.

    1 - I do a BootMii Nand Backup to SD and copy it to my pc.
    2 - I open ShowMiiWads, create the common-key
    3 - I got to Tools>Extract BootMii Dump, copy all the correct folders to my External USB
    4 - I go to ShowMiiWads and Change the Nand Backup Path to my USB root, click ShowMiiNand and I see everything on my wii perfectly.
    5 - Now I click ShowMiiWads, File>Open Folder and locate my collection of wads and hit "OK"
    6 - The program does some thinking, the green progress bar moves and it shows places where wads should be but there are no wads. When I right click on one I get an error box that says "File couldn't be found: c:\users\******\Desktop\WiiWads\Wads\"

    I have tried with both Windows 7 and Windows 8, multiple computers, multiple wad files to be sure i didnt get a corrupt file or anything. I have had the system modded and playing Wii games off the USB constantly with no issues. I'll provide a picture of whats happening to help. (Sorry for the quality.)

    Basically, all I want to do is play WiiWare/VC off a usb loader like i have my WiiFlow set up for Wii games. I'm not commited to Mighty Channels and if theres a better route to take I'd love to give it a shot, but it seems no matter what route i take, I need those wad file to show up in ShowMiiWads.

    Thanks in advance to anyone willing to join me in the good fight! I really hope we can figure this out.
     

    Attached Files:

  2. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,953
    3,735
    Apr 2, 2011
    United States
    The Twilight Zone
  3. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    Thanks for the reply Joostin. I downloaded and tried the modded ShowMiiWads (thank you for the link) but it still did the same thing, showing all blank spaces. On the ShowMiiWads Mod, do you not have to create a common-key? I couldnt find the option.
     
  4. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    Oh shoot, forgot the new picture I'm sorry!
     

    Attached Files:

  5. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,953
    3,735
    Apr 2, 2011
    United States
    The Twilight Zone
    No common key is needed for SMW Mod. It might be because you have so many wads in that folder. Try copying like 4 of them to another folder, then using only that directory.
     
  6. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    I've tried just one, two, a few... nothing still. I put 4 in the folder and 2 blank lines loaded in return.
     

    Attached Files:

  7. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    What seems to be the problem is that for some reason it doesnt see the folder i point it to that contains my wads. Here is the error I get when I try to extract one of these blank lines. Its almost like the program doesnt even notice the folder
     

    Attached Files:

  8. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,953
    3,735
    Apr 2, 2011
    United States
    The Twilight Zone
    Open ShowMiiWads.cfg and post the contents in
    Code:
    
    
    tags
     
  9. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    Ok is this what you requested?

    Code:
    <?xml version="1.0" standalone="yes"?>
    <ShowMiiWads>
      <Settings>
        <Version>1.5</Version>
        <Language>English</Language>
        <LangFile />
        <AutoSize>true</AutoSize>
        <NandPath>X:\</NandPath>
        <WiiGamePath />
        <ShowPath>true</ShowPath>
        <AddSub>false</AddSub>
        <Portable>False</Portable>
        <Accepted>true</Accepted>
        <SaveFolders>true</SaveFolders>
        <CreateBackups>false</CreateBackups>
        <SplashScreen>true</SplashScreen>
        <View>ShowMiiWads</View>
      </Settings>
      <Window>
        <WindowWidth>930</WindowWidth>
        <WindowHeight>728</WindowHeight>
        <LocationX>-4</LocationX>
        <LocationY>-4</LocationY>
        <WindowState>Maximized</WindowState>
      </Window>
      <Folders>
        <MRU0>C:\Users\steve_000\Desktop\Wadss</MRU0>
        <MRU1>C:\Users\steve_000\Downloads\Torrents (Complete)\Wii Shop\Virtual Console\Nintendo 64</MRU1>
        <MRU2>C:\Users\steve_000\Desktop\Wii Stuff\wads</MRU2>
        <MRU3 />
        <MRU4 />
        <Foldercount>1</Foldercount>
        <Folder0>C:\Users\steve_000\Desktop\Wadss</Folder0>
      </Folders>
    </ShowMiiWads>
     
  10. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    10,953
    3,735
    Apr 2, 2011
    United States
    The Twilight Zone
    I don't know what to tell you. :(
     
  11. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    lol yeah man... i been at it since about midnight... I hate to give up but I can't find any solution and I fear I'll get more frustrated and end up really messing things up if I keep poking around. There are no other programs similar to ShowMiiWads, huh? Also, if I can't get the them to load through ShowMiiWads is there any other method to play wiiware/vc on USB using a loader without having to load my wads through ShowMiiWads?
     
  12. Mr.Wiizard
    OP

    Mr.Wiizard Member

    Newcomer
    12
    1
    Apr 3, 2014
    United States
    figured it out... kinda feel like an idiot but oh well. I selected all my wad files, right clicked, properties, unchecked the "Read Only" box and hit ok. Tried two roms so far and they both showed up. I may be jumping the gun but thats the best sign i've seen in a good 15 hours!
     
    modbrain likes this.