Black System Error screen booting any GBA game (custom or official) from rxtools on emuNAND

Discussion in '3DS - Homebrew Development and Emulators' started by Osakasan, Jan 5, 2016.

  1. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    So here's the story: Yesterday i managed to get my o3DS downgraded and ready with EmuNAND and RxTools, installed a patched AGB_FIRM with Riku's AGB_FIRM Signature Patcher and got installed and working CIA versions of Circle of the Moon, Harmony of Dissonance and Aria of Sorrow. In fact, i started a new game with the three of them.

    Today, after having to turn off my 3DS to install microSD manager and a custom GBA game made with GBA ROM converter + Footer Gen & VC Banner generator, no GBA game starts anymore, not even Yoshi's Island wich i already had from the Ambassador program and redownloaded from the eShop works.

    Is there anything else i need to do? Yesterday everything was going smoothly, but it seems i shat the bed somehow.
     
  2. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,711
    634
    Sep 4, 2014
    Italy
    As you patched GBA_FIRM now you need to start cfw everytime you want to launch a gba game, aven a legit one
     
  3. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    I do. In fact i go directly to EmuNAND from Homemenuhax via RxTools
     
  4. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,711
    634
    Sep 4, 2014
    Italy
    Do you have unlinked nands?
     
  5. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    Yes, i though it would be for the better. Is it the root of the problem?
     
  6. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,711
    634
    Sep 4, 2014
    Italy
    I think that if you install the GBA VCs even in sysnand you'll solve this
     
  7. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    Slowly uninstall the microSD manager and a custom GBA game made with GBA ROM converter + Footer Gen & VC Banner generator apps until you successfully get to open it. I dont recommend installing any of these to SysNAND and setup your devide to coldboot it makes it much easier trust me! Also when you have some form of CIA installer installed into EmuNAND and your full sure your nands are unlinked go into emuNAND and update the firmware to the latest. This helped me and I can still install cias use custom themes etc because I have FBI already on my emuNAND before I updated.
     
  8. The9thBit

    The9thBit Advanced Member

    Newcomer
    81
    39
    Mar 25, 2015
    United States
    GBA VC games don't work on unlinked emuNAND. The system always searches for them on sysNAND even after launching from emuNAND, so unless they're linked, you'll need the same game installed for sysNAND.
     
  9. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    So one solution is to relink EmuNAND and SysNAND and reinstall them, isn it?
     
  10. DrCrygor07

    DrCrygor07 Italian Wario Ware bootleg©

    Member
    1,711
    634
    Sep 4, 2014
    Italy
    Or you can simply install gba vc in sysnand, and you can continue playing them in emunand
     
  11. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    They need to be installed on SysNAND aswell as EmuNAND thats what they are tryna say. You dont need to relink and once its installed on both you can play on EmuNAND just fine.
     
  12. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    Tried to do it, ShinyMK, but couldn't for some reason ^^U

    Relinking SysNAND and EmuNAND solved it, apparently, so i'll keep going like that
     
  13. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    If you are, Make sure not to update your emuNAND or your screwed ;)
     
  14. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    Yes, my EmuNAND was updated yesterday while unlinked, so right now i'm on EmuNAND 10.3 linked to SysNAND 9.2

    To be honest i tried to to install the games on SysNAND before linking, using FBI injected into the H&S, but it would simply not boot.
     
  15. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    If I were you, Get FBI.cia and use H&S to install the FBI.cia then from then on use that instead. The games need to be installed on sysNAD (AND) EmuNand to actually boot.
     
  16. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015

    Well... too late for me now ^^U I hope there isn't too many disadvantages in having both NANDs linked, since i'm planning to use EmuNAND as my main system. Thanks for your advices in any case :)
     
  17. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    Since your planning it as your main system I would just unlink them and try get the GBA's working. There are a lot of thing that could go bad when they are linked for example some firmwares have auto-updating from sleep mode which may update your SysNAND too since they are linked. Gotta be careful dude. I wouldnt keep them linked knowing it could go bad just for a GBA or 2.
     
    Osakasan likes this.
  18. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    Ok, now that was scary as hell ^^U I guess its worth to re-unlink.

    This is waaaaaaaaaaay more complicated than it was on Wii.
     
  19. ShinyMK

    ShinyMK known as @initPRAGMA

    Member
    1,507
    533
    Dec 29, 2015
    127.0.0.1
    Ikr, I had a wii homebrewed I wasnt even trying it was that easy.
     
  20. Osakasan
    OP

    Osakasan GBAtemp Advanced Fan

    Member
    805
    453
    Sep 19, 2015
    Ok, did it. It seems like something went wrong yesterday injecting FBI via H&S App. A bit tedious with both NAND unlinked, but it worth it. Thanks!

    However, i guess i'll have to install the official GBA releases via FBI now, since i can't enter the eShop frm SysNAND