Black Screen in M3 adapter Slot-2

Discussion in 'GBA - Flashing Hardware and Software' started by Karmansephmanga, Jul 29, 2019.

  1. Karmansephmanga
    OP

    Karmansephmanga Newbie

    Newcomer
    1
    Jul 29, 2019
    Argentina
    Hi everyone, recently I acquired a GBA with a flashcart M3 Slot-2, After passing the GAMEBOY logo, the screen goes black and does not advance.

    2.

    If I remove the cartridge a little, the following message that the SD card needs to be formatted appears

    3.

    The flashcart seems to work because if I enter it without an SD card, the message that it does not have one appears.

    1.

    I already tried it on an NDS Lite and the result is the same, it worked correctly until recently, I need to know what the problem might be. Thank you!
     

    Attached Files:

    • 2.
      2.jpg
      File size:
      56.6 KB
      Views:
      0
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23
    Nov 21, 2005
    United Kingdom
    What size SD card? What filesystem is it formatted to?

    At this point the M3 is probably pretty old so while you are at it you might want to clean the pins, including in the SD card slot (electrical, not automotive, contact cleaner is good stuff but anything that will evaporate and not leave anything behind or corrode it will do. Get some in there and insert and remove SD card a bunch of times).
     
  3. Karmansephmanga
    OP

    Karmansephmanga Newbie

    Newcomer
    1
    Jul 29, 2019
    Argentina
    hi there, I tried two microSD cards including the one that came by default, the default one is 2GB in FAT format (reformatted to Fat32) and one 512MB in fat 32
     
  4. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23
    Nov 21, 2005
    United Kingdom
    Assuming they appeared fine on the PC it should have been OK there -- I was mainly wanting to make sure they were not SDHC. I don't know which filesystem the M3 kernels preferred in the end but if both were covered here

    Time to clean the pins then.
     
    Karmansephmanga likes this.
  5. WigWrm

    WigWrm GBAtemp Regular

    Member
    3
    Apr 17, 2007
    United States
    I've had this issue in the past (the black screen at bootup). It was because the rechargeable battery inside of the cart was dead. I replaced the battery in my M3 lite and it came back to life afterwards.
     
    Karmansephmanga likes this.
  6. MockyLock

    MockyLock GBAtemp Regular

    Member
    5
    Apr 21, 2011
    France
    I have the same issue in mine.
    Thanks for the tip, i'll give a try asap !
     
  7. Karmansephmanga
    OP

    Karmansephmanga Newbie

    Newcomer
    1
    Jul 29, 2019
    Argentina
    Thanks for your replies!! this helped me a lot
     
Loading...