Black screen after booting up game through USB Loader GX

Discussion in 'Wii - Hacking' started by nonmagical, Aug 17, 2015.

  1. nonmagical
    OP

    nonmagical Newbie

    Newcomer
    1
    0
    Aug 17, 2015
    United States
    TL;DR: Had everything working with a 4GB USB stick, decided to upgrade to more space with 128GB USB stick. Weird issue with formatting. USB Loader GX could detect the games on the 128GB USB stick but crashes trying to load them. Further attempts to load the files to fix any errors have lead to worse and worse results while trying to load them. Out of ideas.

    So the other night I followed this guide (https://gbatemp.net/threads/how-to-...backup-wii-gamecube-and-wiiware-games.360687/) to relatively moderate success. I was able to install everything without too many hiccups (I made a couple mistakes in the process that I had to go back and re-do) and by the end of it I had a 2GB SD card loaded in my Wii as well as a 4GB USB stick that had Super Smash Bros. Melee loaded on it to test out the USB Loader.

    It worked. I was able to turn on Melee and it accessed my memory card like I expected and was able to play the game as if I was using my disk.

    So today I decided I wanted to digitize more of my stuff and I realized I would need a larger storage than a 4GB USB drive if I want to hold more than one digital game at a time. I went to the store and picked up a PNY 128 GB USB drive (didn't feel like lugging around an external hard drive).

    http://www.amazon.com/PNY-Turbo-128GB-Flash-Drive/dp/B00FE2N1WS

    It isn't that exact model (I can't seem to find the exact kind I got. But in addition to saying "PNY 128GB" on the cover it also says "USB 3.0") but it should be close enough.

    Anyway, I got home expecting to just need to format the drive to FAT32 and then copy/paste the files over from my other USB stick. This is when I encountered my first problem. Despite having nothing in it and plugging it in fresh, when I tried to use the FAT32 format program that I used on my previous USB stick, it gave me an error saying that the drive was in use. I found a work around for this though by right clicking on the drive in My Computer and formatting it there using (what I assume to be) Window's default formatting tools. This then allowed me to use the FAT32 format program to format the USB drive using the 32k allocation.

    Thinking all was fine and dandy, I grabbed my files and threw them on the new stick. I also noticed that I had a WBFS folder and I read that that is where I should stick .wbfs files for digital Wii games. So I took my WBFS version of Super Mario Galaxy and threw it in there. After booting it up, I went to USB Loader GX and my games showed up (both Melee and SMG). But sadly when I opened Melee, it just gave me a black screen after showing the Dios Mios starting screen. When I attempted to open SMG, it just went to a black screen before pushing me back out to the main menu. I took the drive out, wiped everything from them, went through the reformatting process again (again needing to do the windows default formatting for the FAT32 to allow me to format it) then copied the files back over. This time was mostly the same (games showed up, SMG kicked me back to the main screen, but Melee this time crashed at the black screen before I even got the Dios Mios loading screen). I should note, by the way, that every time this USB stick failed to load I would try using my original USB stick and it would load Melee just fine.

    I tried one final time to wipe everything from the USB stick, did as much research as I could but couldn't find any answers to this problem that fixed my issue, then attempted to load the files one more time. This time I didn't load SMG, and instead made it a 1:1 copy of my other USB stick. Both formatted to FAT32 (although I had to format the second drive in that gimmicky way), both with the same files.

    This time when I attempted to load USB Loader GX it failed to find the HDD. Unplugged, tried again, failed to find the HDD. Unplugged, plugged in original USB stick, loads Melee just fine.

    Any ideas? Is there a limit to how big the jump drive can be to plug into the Wii? Why did I have to do a patchwork style FAT32 format on it, and would that have made it work incorrectly? Is there a compatibility issue with certain brands of USB sticks? Or am I overlooking something entirely (perhaps simply copy/pasting the files onto a new USB stick is not sufficient?)
     
    Last edited by nonmagical, Aug 17, 2015