Best way to update to 4.2?

Discussion in 'Wii - Hacking' started by jmckutchin, Oct 15, 2009.

  1. jmckutchin
    OP

    jmckutchin GBAtemp Regular

    Member
    222
    18
    Nov 26, 2008
    United States
    Podunk, U.S.A
    I've been seeing a lot of information flooding the message boards in the last week or two since 4.2 came out, and I'm still a bit confused/worried about updating to 4.2.

    Is there any concrete method to updating to 4.2? xzxero says the best way is to upgrade is via Nintendo. Shouldn't I be worried about it bricking my system? I'm already softmodded and have the latest updates (HBC, etc), and am perfectly willing to go through the upgrades again if it means a well working system. I don't have cIOSCORP installed... I think. I certainly don't remember installing it.

    Another option is the safe 4.2 safe upgrader (on this board somewhere), but part of me doesn't like the piecemeal nature of it, or at least that's what I get the jist of it.

    The final option is to just stick with 4.1 or wait a couple weeks/months until lots of new, stable updates are released (really excited for the preloader progress, want to hold off on updating).

    If it's worth anything, I have bootmii installed as IOS. (don't know why you'd need to know that....but still)

    Thanks!
     
  2. jmckutchin
    OP

    jmckutchin GBAtemp Regular

    Member
    222
    18
    Nov 26, 2008
    United States
    Podunk, U.S.A
    Anyone want to chime in?
     
  3. nabster92

    nabster92 GBAtemp Advanced Maniac

    Member
    1,631
    0
    Apr 16, 2009
    United States
    If it ain't broke don't fix it. 4.2 does nothing for you but remove homebrew stuff so you don't NEED to update at all. I would wait until Nintendo releases an update that's actually useful in any way at all.

    But if you do want to update, personally I would trust safe updaters over Nintendo's as they don't fuck with boot2.
     
  4. icebrg5

    icebrg5 GBAtemp Addict

    Member
    2,326
    41
    Apr 1, 2007
    United States
    ive updated 3 wiis through nintendo.All had the older boot2 and were updated to the newer boot2.

    I had 0 problems.
     
  5. littlecubba

    littlecubba Advanced Member

    Newcomer
    67
    6
    Jan 12, 2009
    stick to system menu v4.1 as there are no major improvements...

    (personally don't use cIOSCORP, stick to WiiPower's loader or one of the many USB loaders)

    BUT, if you are going to update to v4.2 make sure you have "BANNERBOMB" for system menu v4.2 and "PIMP MY WII" v1.11 (network problems with v1.2) folk might not be happy cos' i said to use this but it helped me with reinstalling "The HOMEBREW CHANNEL"... also make sure you use "START PATCH v4.2"
     
  6. Lindfalas

    Lindfalas Member

    Newcomer
    33
    0
    Feb 26, 2009
    Hi.

    I always upgrade the Wii I do softmod.
    I have done 50+ pre 4.2 and about 10+ with 4.2.
    Never got any problem.
    So Iwould say it´s safe.

    Greetz
     
  7. jmckutchin
    OP

    jmckutchin GBAtemp Regular

    Member
    222
    18
    Nov 26, 2008
    United States
    Podunk, U.S.A
    Thanks for all the good advice...

    I think I'll update my preloader but stick with 4.1 until necessary.
     
  8. georgecoat

    georgecoat Advanced Member

    Newcomer
    97
    0
    Dec 18, 2008
    United States
    I am in the same situation, only difference just have HBC 0.3 and bootmii as boot2 and preloader 029 with hacks for 4.1U.
    I also opted to stay with 4.1 until some serious upgrade comes.
    Do you have latest HBC 0.6?
    The only things I am thinking to update is newest HBC/bootmii because is bothering me with update message. Is it safe to update it with latest HBC 0.6 as boot2 on 4.1U system?
    Another one is preloader 0.3, is it final and hacks 4.1U works with it or need a new hacks?
    Thanks!
     
  9. ConJ

    ConJ The Toker

    Member
    922
    1
    Jul 18, 2008
    Glastonbury
    Its fine to update the homebrew channel and bootmii. Just use the latest Hackmii installer.

    If youve got Bootmii as boot2, you dont really need preloader.
     
  10. bach3609

    bach3609 GBAtemp Fan

    Member
    367
    0
    May 31, 2009
    Loading................
    hmm although i don't have much experience with this homebrew WII stuff... Have you tried the 4.2 safe patcher?
     
  11. Gavry

    Gavry Member

    Newcomer
    48
    0
    Apr 20, 2009
    I did it manually. Pretty easy really if you know your way around a few tools.

    1. With NUSD download and pack into WADS:

    a. Latest Shopping Channel (For Your Region)
    b. Latest IOS 61 (For Your Region)
    c. System Menu 4.2 (For Your Region)

    2. Get latest DOP-IOS

    3. Run DOP-IOS and install the latest IOS 70. Patch it for Preloader.

    4. Install WADS:

    Shopping Channel
    IOS 61
    System Menu 4.2

    Your now on 4.2 with everything critical installed. You can then use Preloader 0.3 and your back in business.
     
  12. georgecoat

    georgecoat Advanced Member

    Newcomer
    97
    0
    Dec 18, 2008
    United States
    And new Hackmii 0.6 before or after all of this? What about trucha bug on these IOSes? Wich one shuld have it and how to do it?
    Is preloader 0.3 working as good as 0.29 with all the hacks? Are all the 0.3 hacks ready for 4.2U?
    By the way, is Nintendo gonna keep telling me that there is new update after all of this is done?
    Thank you all for suggestions and help and sorry for too many questions.
     
  13. icebrg5

    icebrg5 GBAtemp Addict

    Member
    2,326
    41
    Apr 1, 2007
    United States

    4.2 system menu runs off of ios70 you would need that as well otherwise you would end up with a brick.
     
  14. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    step 3 downloads and installs IOS70
     
  15. icebrg5

    icebrg5 GBAtemp Addict

    Member
    2,326
    41
    Apr 1, 2007
    United States
    I seen he was downloading wads with NUSD and installing them with wad manager.Totally didn't see the dop ios part of it

    my apologies

    EDIT: I thought dop ios couldnt patch ios70 the way it needed to be patched to work with preloader?
     
  16. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    it cant yet.
    not the official ones anyways,
    better to use freethebug
     
  17. jmckutchin
    OP

    jmckutchin GBAtemp Regular

    Member
    222
    18
    Nov 26, 2008
    United States
    Podunk, U.S.A
    xzxero,

    so according to you i could just take my wii right now (softmodded, hackmii, preloader, no cioscorp), upgrade to 4.2 and expect it not to brick, and then use your 4.2 guide to remod my wii?
     
  18. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    correct. it wont brick though, unless theres a power outage or something unlucky.
     
  19. jmckutchin
    OP

    jmckutchin GBAtemp Regular

    Member
    222
    18
    Nov 26, 2008
    United States
    Podunk, U.S.A
    sounds good. I think i'll do it after I beat Final Fantasy IV: The After Years... Don't want something unexpected to happen...

    BTW, What is the something unlucky?
     
  20. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    cables get ripped.
    wii gets thrown out of the window.
    a guy a cannon shoots and the artillery lands on your wii.

    you know, unlucky incidences.