Best SNES emulator?

Discussion in 'NDS - Emulation and Homebrew' started by jensa, Apr 7, 2008.

Apr 7, 2008

Best SNES emulator? by jensa at 3:15 PM (1,395 Views / 0 Likes) 3 replies

  1. jensa
    OP

    Newcomer jensa Member

    Joined:
    Jan 19, 2008
    Messages:
    44
    Country:
    Sweden
    ok, so which 1 is the best SNES emulator?
    i know there is atleast 3:
    SnesDS
    SNEmulDS
    SnezziDS

    so wich one is best?
    i know that the SNES is 16bit just like the genesis... and the genesis emulator with sound doesnt run in full speed, is there any problem like that on any of these SNES emus?
     
  2. Thanatos19

    Newcomer Thanatos19 Member

    Joined:
    Jun 21, 2007
    Messages:
    12
    Country:
    Canada
    SneMulDS

    Though all 3 suffer from graphical issues most games are playable with SNEmulDS being the best one of the 3.
     
  3. Jax

    Member Jax Pip Pip Cheerioink!

    Joined:
    Jul 31, 2006
    Messages:
    4,092
    Location:
    L.A.V.
    Country:
    Portugal
    I second SneMulDS.
     
  4. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    SNEmulDS is the best, followed by SnezziDS, but SnezziDS does require a slot-2 device with GBA compatibility in order to run. SNES DS actually has better compatibility than most give it credit for, but it requires you to build the rom a special way in order to maximize the compatibility, and the tools to build it have disappeared from the main site.

    Speed usually isn't too much of an issue with SNEmulDS, it's the graphical problems that will get to you. This is a trade-off of the way it emulates the games. It uses the DS's dedicated 2D hardware to greatly speed up the rendering time (down to about 5% of the CPU time) but this causes potential graphical glitches. A full software renderer like the ones for the PSP would be much more accurate graphically but would lag like crazy due to the increased CPU power needed.

    Just make sure you get either v0.5 Beta or v0.6 Alpha. For some reason, the blog on the main site reverted back to a time when v0.3 was the latest, but the download link for v0.6 Alpha still remains on the sidebar. Very strange.
     

Share This Page