Best route for updating an already soft modded Wii on 4.1E

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
13,959
Trophies
3
Age
38
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
10,066
Country
Cyprus



I fully get that. But I had already started this process before everyone started telling that updating to 4.3 is pointless. -- Its irking me out now that I've installed all the WADs and it didn't update the system menu. It's going to sit in the back of my mind that something didn't go as planned.. So I'd just like to fix it and update regardless.


If you want help updating to 4.3, you can run ModMii's main wizard and tell it this. If you want to avoid repeating steps you will answer truthfully that your wii is not a virgin and that you know exactly what you want to update. I caution you, as usually I am telling people the opposite (i.e. lie and say it's a virgin even if it isn't, it will have you repeat steps this way but other than being a bit redundant there is no issue with it)

Will need some more info on your priiloader issue to assist, and it's possible it could be a legit issue that should get reported to Daco Taco for investigation, but this sort of thing is rare and priiloader is used by many. Definitely strange

edit:
For now ignore everything I said above and proceed with the following and I think it will resolve all your issues

To manually update to 4.3 you will need to install the 4.3E system menu wad (since your wii is PAL). You can download this from ModMii Classic's download page 1. You also need IOS80, but according to your syscheck you already have this installed (as part of ModMii's extra brick protection feature\option no doubt). So you specifically don't need to worry about that, I only mention it in case years from now someone in a similar situation is reading this and bricks by installing a new system menu without a corresponding system menu IOS.

So all you would need to do is install the 4.3E system menu WAD. Note that this effectively uninstalls priiloader, so you will need to run the priiloader installer again afterwards to reinstall\update it. Coincidentally, this action may actually fix your priiloader issue (I'm thinking if the reason you can't install the latest priiloader has something to do with your current system menu \ priiloader installation, it should work after you install the 4.3E system menu)

Good luck and please report back and let us know how it goes!

edit2: P.S. be sure to check back in soon, a big ModMii update is hopefully coming in the not so distant future that will make updating old apps found on your SD\USB super easy, as well as a ton of other cool things!
 
Last edited by XFlak,
  • Like
Reactions: ThaKarra

ThaKarra

Well-Known Member
OP
Member
Joined
Aug 17, 2018
Messages
140
Trophies
0
Age
31
XP
796
Country
Australia
If you want help updating to 4.3, you can run ModMii's main wizard and tell it this. If you want to avoid repeating steps you will answer truthfully that your wii is not a virgin and that you know exactly what you want to update. I caution you, as usually I am telling people the opposite (i.e. lie and say it's a virgin even if it isn't, it will have you repeat steps this way but other than being a bit redundant there is no issue with it)

Will need some more info on your priiloader issue to assist, and it's possible it could be a legit issue that should get reported to Daco Taco for investigation, but this sort of thing is rare and priiloader is used by many. Definitely strange

edit:
For now ignore everything I said above and proceed with the following and I think it will resolve all your issues

To manually update to 4.3 you will need to install the 4.3E system menu wad (since your wii is PAL). You can download this from ModMii Classic's download page 1. You also need IOS80, but according to your syscheck you already have this installed (as part of ModMii's extra brick protection feature\option no doubt). So you specifically don't need to worry about that, I only mention it in case years from now someone in a similar situation is reading this and bricks by installing a new system menu without a corresponding system menu IOS.

So all you would need to do is install the 4.3E system menu WAD. Note that this effectively uninstalls priiloader, so you will need to run the priiloader installer again afterwards to reinstall\update it. Coincidentally, this action may actually fix your priiloader issue (I'm thinking if the reason you can't install the latest priiloader has something to do with your current system menu \ priiloader installation, it should work after you install the 4.3E system menu)

Good luck and please report back and let us know how it goes!

Thanks so much for taking the time to type this out! I did edit my previous post but maybe you had already posted this before getting a chance to read it.

I downloaded 4.1E via NUS Downloader and installed the .WAD with WiiMod Lite.

After my Wii rebooted back into the system menu, I was then able to run the Priiloader Installer for v0.9 via HBC and this time it worked perfectly!

So now I'm currently sitting on System Menu 4.1E with Priiloader v0.9 installed.

Thanks again for all your help :)
 

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
13,959
Trophies
3
Age
38
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
10,066
Country
Cyprus
Nah, bannerbomb hands down the easier. No need to retrieve any info like Mac address, 1 version works for all wii's. Bannerbomb v1 works on 3.0-4.1, and v2 works on 4.2. Letterbomb only works on 4.3 (although wilbrand's message bomb supports older firmwares)

Str2hax is also another easy one, no need to even use an SD card, and the steps are the same for each wii and don't change based on Mac Addy or any other console specific info

So whole letterbomb is great, I wouldn't call it the best
 

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
13,959
Trophies
3
Age
38
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
10,066
Country
Cyprus
4.3 is the latest system menu version, but there are other items that can be updated, like IOSs. If you want to be able to run the latest games from the disk channel and things like that then you will need the latest IOSs (latest system menu version is not necessary).

Ultimately if a user just runs syscheck, then drags and drops their syscheck.csv onto ModMii.exe it will help them update whatever is outdated, both official stuff and softmods

edit: btw since this thread was made a year ago, YAWM ModMii Edition was released, allowing you to install system menus while retaining priiloader
 
  • Like
Reactions: CoolMe

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: https://youtu.be/hJPK5nB_UMg?si=sS6k1EXAjHzDXrlF