Benefits of 3.90 CFW

Discussion in 'PSP - Games & Content' started by Jaxtaylor, Mar 24, 2008.

Mar 24, 2008

Benefits of 3.90 CFW by Jaxtaylor at 3:34 PM (1,611 Views / 0 Likes) 8 replies

  1. Jaxtaylor
    OP

    Newcomer Jaxtaylor Advanced Member

    Joined:
    Oct 25, 2002
    Messages:
    93
    Country:
    United Kingdom
    Hi Guys.

    I'm currently on 3.71 CFW, and was wondering what the benefits were of "upgrading" to the latest one? I've noticed that certain themes only work on certain FW, is there anything else I'm missing out on?
     
  2. myuusmeow

    Member myuusmeow GBAtemp Advanced Maniac

    Joined:
    Jun 24, 2007
    Messages:
    1,643
    Country:
    United States
    If you have a Phat: Internet Radio (i think this works on the fat, I have a Slim)
    If you have a Slim: Internet Radio, Skype
     
  3. mrgone

    Member mrgone GBAtemp Advanced Fan

    Joined:
    Nov 6, 2002
    Messages:
    728
    Country:
    Germany
    games requiring a higher fireware will run ( like echochrome)
     
  4. mikagami

    Member mikagami GBAtemp Regular

    Joined:
    Jun 9, 2007
    Messages:
    293
    Country:
    United States
    No, most games that come with 3.90 update will run just fine on earlier firmwares. It's just a matter of preference. 3.71 has a lot of good features though, such as a fully working iRShell and lots of great XMB themes.
     
  5. deathfisaro

    Member deathfisaro Narcistic Deathfisaro Fan

    Joined:
    Mar 16, 2007
    Messages:
    2,053
    Location:
    Vancouver, BC
    Country:
    Canada
    Doesn't Echochrome run on 3.71 as well? Or is it not Japanese but Asian region Echochrome?
     
  6. Arnold Schwarzen

    Member Arnold Schwarzen GBAtemp Advanced Fan

    Joined:
    Nov 21, 2005
    Messages:
    787
    Country:
    United States
    I think that 3.71 is supposed to have better PS1 emulation (you can get plugins for 3.90 but they don't seem to work for me, always freezes up my PSP) so I guess I'd keep using that firmware if you play a lot of PS1 games.
     
  7. mikagami

    Member mikagami GBAtemp Regular

    Joined:
    Jun 9, 2007
    Messages:
    293
    Country:
    United States
    With the latest Popsloader you can use plugins from any firmware, so that is not a problem. I haven't had any errors using 3.71 Pops plugins on 3.90.
     
  8. Tanas

    Member Tanas GBAtemp Addict

    Joined:
    Aug 19, 2006
    Messages:
    2,258
    Country:
    United Kingdom
    Like myuusmeow just said, to run psx on 3.90 just use popsloader. [​IMG]
     
  9. myuusmeow

    Member myuusmeow GBAtemp Advanced Maniac

    Joined:
    Jun 24, 2007
    Messages:
    1,643
    Country:
    United States
    If you're remotely interested in running ps1 games, I advise you to read other posts in this thread, because mikagami talks about Popsloader.
     

Share This Page