Hacking Battery Life on Trinket M0 Switch

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
I installed a Trinket M0 into my Switch last year. I chose to install all wires *except* the Vol + strap (six out of seven wires), as I kept reading how hard it was to get to for some folks, and I didn't mind limited the boot options.

I've noticed that when I have the switch in sleep mode (either in sysnand, or from atmosphere emummc) that it seems to churn through the battery faster than I'd expect; from 100% to 70% in 12 hours. And to 50% after about 20 hours. Is this expected?

If I power off the Switch, battery, it seems to hold power at a 'normal' level.

When I booted into the info screen a couple of months ago, here's what it reported:

Fusee_UF2 Information. V6_110320.
Battery: 31% 3693mV
Following Straps Detected:
JOYCON

USB VOLTAGE
Chip-based autoRCM mode active.

Boot Animation 2 selected.
Screensaver is active
Name your payload(s) as follows:
Location: SD Root.
payload.bin
payload1.bin
bootloader/update.bin
For Kosmos users:
bootloader/update.bin


Can I also check - should I be in `autoRCM mode` **without** the Vol+ Strap? If dual boot is better, and someone can explain how to switch to that mode without a Vol+ strap, I'm happy to try it. Any other questions/suggestions welcome. It's not the end of the world if I lose battery much faster with the Trinket, I'm just not sure if it's meant to be doing that.
 

thesjaakspoiler

Well-Known Member
Member
Joined
Nov 20, 2018
Messages
483
Trophies
0
Age
121
XP
635
Country
Afghanistan
Even if the Trinket does not go into a low power mode, it is still using something in the order of 10~20mA.
12 hours would draw about 240 mA from your battery.
The battery of the Switch is about 4000mA.
Then the Trinket should only use up about 5%.
But most Trinket firmwares go to a low power mode after injecting the payload.
Then its power usage is in the micro amp range.

Other possibility is that the Switch is charging the Joycons.
Another possibility might be that your battery is getting old.

About AutoRCM, with the latest CFW you automatically go to AutoRCM.
All you need to do (under normal circumstances) is inject a payload.
 
  • Like
Reactions: HollowGrams

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Did another test. Charged the switch fully, and removed the joy-cons and took measurement:

Fusee_UF2 Information. V6_110320.
Battery: 99% 4118mV
Following Straps Detected:
JOYCON

USB VOLTAGE
Chip-based autoRCM mode active.


I then booted into CFW, and put the switch to sleep for about 12 hours. Took measurement again:

Fusee_UF2 Information. V6_110320.
Battery: 67% 3846mV
Following Straps Detected:
JOYCON

USB VOLTAGE
Chip-based autoRCM mode active.


So, I can discount the joy-cons being the cause of lost battery.

About AutoRCM, with the latest CFW you automatically go to AutoRCM.
All you need to do (under normal circumstances) is inject a payload.
You know that you have to enable it? No cfw do this for the users.

Can you explain this a little more please? Do I need to alter some settings on the Trinket itself? I'm currently booting from the Trinket straight into the latest fusee-primary (renamed as \payload.bin). But, given that I see the issue when booting into OFW/Sysnand as well, I suspect that it's either a config of the Trinket, a battery issue, or maybe something else?
 

BaamAlex

S̶̥͝l̷̹̀͗e̶̼̖̩̅͊e̷̛̦͉̦p̷̘͌͝i̵͇̠̞̿̌n̷̰͚͌̓͝g̷̦̲̍̆͝
Member
Joined
Jul 23, 2018
Messages
4,188
Trophies
1
Age
26
XP
3,492
Country
Germany
Can you explain this a little more please? Do I need to alter some settings on the Trinket itself? I'm currently booting from the Trinket straight into the latest fusee-primary (renamed as \payload.bin). But, given that I see the issue when booting into OFW/Sysnand as well, I suspect that it's either a config of the Trinket, a battery issue, or maybe something else?
You don't need to enable it when you have an trinket m0 inside your switch. I have also a trinket but not autorcm enabled.
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
You should check its capacity full mah and capacity (design) within Hekate.

Thanks - I'll install the hekate payload later and check the battery from there.

You don't need to enable it when you have an trinket m0 inside your switch. I have also a trinket but not autorcm enabled.

Interesting. I'll have to try and research how to disable autorcm - I'm unsure if this is a configuration within the Trinket or somewhere else. :-). And, whether not having the 7th wire for the Vol+ strap matters in this regard.
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Update.

@Hayato213
I've checked the battery in Hekate:

Fuel Gauge IC Info:
Capacity now: 4428 mAh [97 %]
Capacity full: 4523 mAh
Capacity (design): 4667 mAh


This appears to be healthy as far as I can tell.


@BaamAlex
In the Hekate Tools section AutoRCM was set to OFF. I set it back on and then OFF again. On reboot into the Fusee_UF2 screen, it still says Chip-based autoRCM mode active. I presume the AutoRCM is a setting in UF2. Looking at the thread at https://gbatemp.net/threads/trinket...software-new-fusee_suite-uf2-packages.553998/ has instructions for Controls: v6 onwards but I think it's assuming the Vol+ strap is fitted?

I'll have a play around and see if I can get it figured out...
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Update. Went through the 26 pages of the above fusee thread looking for answers. I couldn't see any information on switching between autoRCM and Dual Boot mode when the Vol+ strap isn't connected, so I ended up hard editing the hex code off the TRINKET.UF2 file on the M0. Now when I boot into the Fusee_UF2 information page I see:

Dual-Boot mode is active.

Testing booting into both emunand and sysnand, so that's good. Now to test the battery drain again...
 

Hayato213

( -_・) ︻デ═一' * (/❛o❛)/
Member
Joined
Dec 26, 2015
Messages
10,752
Trophies
1
Location
Vector Industry
XP
5,735
Country
United States
Update.

@Hayato213
I've checked the battery in Hekate:

Fuel Gauge IC Info:
Capacity now: 4428 mAh [97 %]
Capacity full: 4523 mAh
Capacity (design): 4667 mAh


This appears to be healthy as far as I can tell.


@BaamAlex
In the Hekate Tools section AutoRCM was set to OFF. I set it back on and then OFF again. On reboot into the Fusee_UF2 screen, it still says Chip-based autoRCM mode active. I presume the AutoRCM is a setting in UF2. Looking at the thread at https://gbatemp.net/threads/trinket...software-new-fusee_suite-uf2-packages.553998/ has instructions for Controls: v6 onwards but I think it's assuming the Vol+ strap is fitted?

I'll have a play around and see if I can get it figured out...

Battery capacity seem fine, I know it will drain more if you use an emunand instead of a sysnand, mine on sysnand only drain few percent a day.
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Test one

Booted into emunand/atmosphere and put console to sleep. Started at 100%, and just over 12 hours of sleep time later it had dropped to 66%.

Test two

Charged it back to 100% again, booted into sysnand and just under 11 hours of sleep time later it's dropped to 74%.


So, it looks like it's still dropping battery faster despite being dual boot and despite looking like a healthy battery. Any other suggestions?
 
Last edited by dzdncfsd,

Hayato213

( -_・) ︻デ═一' * (/❛o❛)/
Member
Joined
Dec 26, 2015
Messages
10,752
Trophies
1
Location
Vector Industry
XP
5,735
Country
United States
Bump. What else can I do to troubleshoot?

Take a picture of the battery info displayed in Hekate, not the one on the uf2, load a newer version of hekate and take a picture, also no bumping here on the forum, you can post but don't use the word bump.
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Apologies for the b*mp word. I won't do that again.

Have you removed the green led light from the trinket?

If you mean the LED between the USB port and the resistor, yes I removed that.

upload_2021-5-1_13-28-41.png



Take a picture of the battery info displayed in Hekate

Here's a picture taken about a week ago from latest Hekate (at the time):

upload_2021-5-1_13-32-39.jpeg


I can re-do again if needed.

Thanks for your continued suggestions
 

Hayato213

( -_・) ︻デ═一' * (/❛o❛)/
Member
Joined
Dec 26, 2015
Messages
10,752
Trophies
1
Location
Vector Industry
XP
5,735
Country
United States
Apologies for the b*mp word. I won't do that again.



If you mean the LED between the USB port and the resistor, yes I removed that.

View attachment 260983




Here's a picture taken about a week ago from latest Hekate (at the time):

View attachment 260984

I can re-do again if needed.

Thanks for your continued suggestions

I will take pictures of mine tomorrow so it can be compared, I have one that is 4 wires with the led light and it doesn't discharge that fast as your as mine would only drop few percent battery inside horizon os. I would check ground and strap wiring. Should have 7 wires.
 

popy

Well-Known Member
Member
Joined
Jul 31, 2018
Messages
239
Trophies
0
Age
36
XP
1,040
Country
Austria
Also have an trinket since the beginning.
Noticed such draining issue back often when I was on SX OS.

Once when I booted into sx os and reboot to payload into stock I also had such drain.
That's now completely gone since I am on atmosphere.

Do you boot sx os sometimes?

Which trinket firmware and payload do you use?
I am using latest Fusee_Suite with latest hekate and AMS.
Battery draining is completly gone for me.

There is also an issue where the Max battery control ic data is messed up and HOS showing weird things like going from 100 to 0 in seconds but last a long time on 0%. Or jumping around.

If so you can fix this by entering the Fusee_Suite hekate mod (long press power) and run the 3 of 4 battery entries in menu (reprogram fuel gauge...).

Good Luck

Gesendet von meinem ONEPLUS A6013 mit Tapatalk
 

dzdncfsd

Active Member
OP
Newcomer
Joined
Jul 8, 2016
Messages
29
Trophies
0
XP
247
Country
Australia
Thanks for the updates above. I didn't seem to get email notifications, so sorry for not replying sooner.

@Hayato213 thanks for snapping pics of your battery stats. Agreed that mine does seem okay. Your current now/average stats seem to be about 10-20% lower than mine, I wonder if that's something of note. At some point I may just have to re-open the switch up and check all the wires, but I am not sure I'll do it too soon. It was somewhat challenging to do the install, and at the time, due to a loose screen backlight cable I had some issues (posted about in the main Trinket thread at the time) - Internal modchip - SAMD21 (Trinket M0, Gemma M0, ItsyBitsy M0 Express) Guide, Files & Support. I didn't know what the problem was and had very carefully checked and redid any points that seemed potentially suspicious while doing that troubleshooting. It's not impossible there's a bad connection, but I'd be surprised. I used the standard suggested pads to do the six wires, except for the 3V one, where I ran it through to the NAND board alternative point.

@popy
- I have never booted into SX OS
- Trinket firmware Fusee_UF2 V6_110320
- Payload is latest fusee-primary. I guess I could try with Hekate instead, but I read an article at some point suggesting that fusee-primary was the better choice with Trinket, I think...
- Yep, I read about the battery issues you mention, but they don't seem to match what I'm seeing. Mine's not rapidly jumping percentages - it just seems to drain at a faster pace than I'd expect, as if something is using the battery when it is in sleep mode.

At the end of the day, this isn't the biggest issue. I usually use the switch docked and my play sessions don't tend to be so long that this battery drain is an issue. It's weird to me though. Even if I don't solve it I appreciate the offers of help so far, and have enjoyed the troubleshooting journey. And I got to live hexedit the Trinket to set it to dual boot, so all in all it wasn't for nothing :)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: Hmm didn't know they made more Dusk Till Dawn movies watched part one on Pluto TV and they have...