Battery drain on 7.0.1, latest atmosphere and sleep issue

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by reptarzilla, Apr 11, 2019.

  1. reptarzilla
    OP

    reptarzilla Newbie

    Newcomer
    1
    Sep 25, 2018
    United States
    When I put my switch to sleep in CFW, the battery drains all the way within 8 hours.

    I thought the sleep issue was fixed. Is this still a problem, or is it something wrong with just my system?
     
  2. adam1290

    adam1290 Advanced Member

    Newcomer
    3
    Dec 10, 2015
    Are you sure you are putting it to sleep and not powering it off with Auto RCM installed? That kind of battery drain would be expected if it's "powered off" with Auto RCM.
     
  3. reptarzilla
    OP

    reptarzilla Newbie

    Newcomer
    1
    Sep 25, 2018
    United States
    Oh, then maybe I am doing something wrong. I do not use AutoRCM, I use the jig each time I need to send a payload. To put it to sleep, I tap the power button. Do I need to hold down the power button and select sleep? Will that stop the battery drain?
     
  4. stephrk398

    stephrk398 GBAtemp Fan

    Member
    5
    May 29, 2018
    United States
    Yes, try actually selecting 'Sleep Mode' and test it that way.

    Edit: I don't think tapping the power button puts it in true sleep mode.
     
  5. BakaBehindKeyboard

    BakaBehindKeyboard Newbie

    Newcomer
    1
    May 14, 2018
    United States
    Unless you're describing the problem wrong, I'm pretty sure it's your Switch.

    Around 6 hours ago I pulled mine from the dock at 100%. 7.0.1, Atmosphere 0.8.6 (using autoRCM but that doesn't really matter here anyway). Checked it as of this post and it's at 99%. This was after tapping the power button to put it to sleep and leaving it there.

    Hopefully someone has some other advice for you. Just thought I'd let you know I have a similar setup and don't have that issue, plus there isn't any difference between tapping the power button for sleep or selecting it from the power menu.
     
    Chaching likes this.
  6. Unleanone999

    Unleanone999 GBAtemp Advanced Fan

    Member
    5
    May 15, 2018
    Togo
    It's either there's a problem in your battery or something is running in the background while your switch is in sleep mode. Also do you overclock your switch?
     
  7. Swiminaha

    Swiminaha Newbie

    Newcomer
    1
    Nov 29, 2018
    Austria
    Austria
    like unleanone999 says.. "Look on your screen,then check double,if you running a "game" on standby, just shut it down, then do how you doing it already.

    btw.. this "Drain fail" happend a few versions earlier too.. maybe a new codebug in some patches? who knows..
     
  8. LapCheong

    LapCheong GBAtemp Regular

    Member
    2
    Mar 6, 2019
    Australia
    I am ams 0.86 and my sleep drain is around 1%? over the past 12h. Make sure your switch is sleep mode with nothing running. Maybe put it in airplane mode? I should't matter.
    As a precaution check your ams maybe you are running a earlier version? There is no harm if you re download kosmos if you are using and replace all the folders again.
     
  9. reptarzilla
    OP

    reptarzilla Newbie

    Newcomer
    1
    Sep 25, 2018
    United States
    I don't overclock, and I always press "x" to close out any game that may be running before I put it to sleep. I'll try redoing the card this weekend, or maybe put CFW on my other switch and see how it performs. It's really strange.

    Thank you for all the replies! I was pretty certain I was doing it correct, and I'm a bit frustrated on how fast this sucker is draining in sleep mode. I downloaded the newest sdfiles last night, so the plan is to copy that over tonight and see if that fixes this sucker.
     
  10. reptarzilla
    OP

    reptarzilla Newbie

    Newcomer
    1
    Sep 25, 2018
    United States
    Quick update. I loaded CFW on a different switch and it's working fine. There's something up with that other one. Strange.
     
Loading...