Bad tickets

Discussion in 'Wii - Hacking' started by Knocks, Jul 19, 2008.

  1. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    Do we have a fix yet for the wad unpacker creating bad tickets like "kikekakikrules!!" or other shit like that. I think the bad ticket is the only reason people get erros when installing a language-modified wad. Right now I don't know of any other way to force language settings in a wad from another region, because it requires to be unpacked first, and that destroys the original ticket.
     
  2. Arakon

    Arakon GBAtemp Fan

    Member
    309
    1
    Apr 24, 2008
    Gambia, The
    the wadunpacker doesn't touch the ticket. the ticket was already fucked because the person who created the wad used kike's packer, which creates a bad ticket.
     
  3. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    I'm not sure if that's a good explanation.

    For example, I have an Japanese wad that installs fine on my NTSC-U Wii, even though the channel crashes because it's not language patched. So I unpacked the wad, forced the main.dol to Japanese only, and re-packed it. Now the Wad Manager gives me a "ret = -2011" error when it tries to install the ticket for the new wad. I first thought maybe I didn't patch properly, but this seems to be a ticket problem.
     
  4. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    use the .wwpacker

    its on this forum with a long guide
     
  5. linkinworm

    linkinworm GBAtemp Maniac

    Member
    1,349
    37
    May 30, 2008
    Birmingham (England)
    did you use the SHA1 on the ticket? befor you packer it again?
     
  6. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    No, i didn't
     
  7. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    odd when i switched to it i never got errors anymore
     
  8. alpha0000

    alpha0000 Advanced Member

    Newcomer
    77
    0
    Sep 5, 2007
    Hong Kong
    Maybe there're file system errors on your sd card. I encountered such problem before.

    Maybe you can format your sd card, put all the things up and then try installing the wad again.

    PS. What's the version of wwpacker? What's the version of your window?
     
  9. Knocks
    OP

    Knocks GBAtemp Advanced Fan

    Member
    559
    0
    Jun 12, 2006
    It's not an SD card issue. This only happens with wads that require forced language settings.