Backups working when burned to DVD, but not through USB external drive

Discussion in 'Wii - Hacking' started by DMPugh, Sep 23, 2009.

  1. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    I have a discussion posted in the Backup Loaders forum which shows the progression of my problem: http://gbatemp.net/index.php?showtopic=180977

    But here's the summary: I received a Wii from someone who had a previous Twilight Princess hack installed. I performed xzxero's simplistic Wii mod (found here: http://gbatemp.net/index.php?showtopic=171901), and made sure to perform each step carefully and to the letter. So whatever is done there is what is currently done to my Wii, with the files he provided.

    Here's what I've found. Certain games I've downloaded will not work on my external hard drives (I've tried two: an Adata CH91 320GB external, and a Western Digital Passport Essential 320GB external), but will conversely work fine when I burn them to DVD. I so far have succeeded twice in this, with the games Super Mario Galaxy and Punch-Out!! Wii (there could be more, but I ran out of discs).

    But this is where it gets even more interesting: certain games will run fine on my drives! There are three confirmed so far (which actually let me play the game without freezing): Metroid Prime Trilogy (using alt-dol), Elebits, and Resident Evil: The Umbrella Chronicles.

    Here's an example of what will happen: I'll put Super Mario Galaxy on my drive, I will go to load it, and I will notice the light on my Wiimote shut off for a second, then turn back on. The screen remains blank, and never progresses from this point. With Punch-Out!! Wii, I get to the screen where it says "Loading..." at the bottom right, but it hangs indefinitely on that screen as well, whereas the disc copy I have loads within about 4-5 seconds.

    So now I'll provide as much info as I can about my Wii, and hopefully someone out there can provide me with a solution!

    - System firmware 4.1U
    - cIOS v14 (have also tried 222 and 223 options in games, instead of 249, but none of those work either)
    - Apps used: NeoGamma R7, USB Loader GX, Configurable USB Loader (all default settings)
    - preloader has all system hacks activated. Disabling them does not help.
    - Using WBFS Manager 3.0 in Windows XP through Boot Camp on my 2008 Intel iMac (the ISOs are stored on my Mac partition, and I normally just point WBFS Manager to the Mac side, but I have went as far as copying some ISOs to the XP partition before adding to WBFS Manager, and this did nothing)
    - certain ISOs have been pre-scrubbed, but I am not sure which ones, or if that has an affect on the proceedings

    I will happily provide any further info needed in order to get this solved. Someone, ANYONE, please help me out!
     
  2. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    hmm sound like ISO's but they work when burned?
    interesting, something has to be wrong

    have you tried erasing from the wbfs drive and putting them on again?
     
  3. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    Yep, I've formatted over several times on each drive and it always does the same thing.

    I forgot that I've also tried flash memory (I have an Adata 8GB microSDHC card, and my roommate also has a Kingston Traveler thing). Same results.
     
  4. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    xzxero, I'm going to re-do your softmod guide in full soon just to make absolute sure everything has been performed correctly. Is it safe to literally do the entire guide over?
     
  5. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    yes its safe, but since you did it already, those games should work off a USB because they do when burned.
     
  6. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    New discovery!

    Just installed my burned copy of Super Mario Galaxy to the hard drive through USB Loader GX, and wouldn't you know it? It works.

    ???
     
  7. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    you had a bad rip in your wbfs drive.
     
  8. KiiNG

    Member KiiNG GBAtemp Regular

    Joined:
    Aug 20, 2009
    Messages:
    180
    Country:
    United States
    Not exactly related to the post, but just in case you don't know, OP, there's an OSX compiled WBFS utility. It doesn't have everything that other WBFS managers have, but it works wonderful for dumping ISOs to drives. WBFS Intelligent GUI (Windows) runs perfect through WiNE and VM, also. I'd go nuts rebooting to dump ISOs.. anywho, just a thought. :>

    WBFS for Mac OSX v.1.2
     
  9. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    I will be trying that out shortly, as soon as Punch-Out finishes installing through USB Loader GX and I've tested it.

    xzxero - Do you mean a bad rip as in the ISO was bad? Because it was the same ISO I used to make the DVD copy which inevitably worked. Or is it possible that WBFS Manager is messing with the ISOs every time?
     
  10. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    no i mean wbfs manager copied the iso onto your drive wrong i guess.
    sounds unlikely, but i guess that what happened.
     
  11. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    I'm gonna add a few more ISOs to make sure, but I think WBFS for Mac OSX is doing the trick.

    P.S. I got Error 002 when I went to play Punch-Out. Somehow my sd card was rendered unreadable in the process, and I had to reformat it. Is it safe to apply the 002 fix to every game I play, just to make sure this doesn't happen again?
     
  12. DMPugh
    OP

    Newcomer DMPugh Advanced Member

    Joined:
    Aug 3, 2008
    Messages:
    86
    Country:
    Canada
    Tried two more ISOs and both worked. I'm satisfied.

    Thanks SO MUCH for your help guys. This is one less headache of mine!
     

Share This Page