1. blawar

    blawar Developer
    Developer

    Joined:
    Nov 21, 2016
    Messages:
    1,306
    Country:
    United States
    The reason is preservation, and safety. We do not want to restore them now, but in the future, we will likely want to. XCI’s specifically are not as prolific as NSP and are at greater risk for being lost in the future. If we needed to pull a rare or lost XCI off of a switch, and it was forever corrupted by 4nxci or @duckbill007 , then that would be a truly said thing.

    always modify NCA’s in the least way possible, if not at all.
     
  2. hippy dave

    hippy dave BBMB
    Member

    Joined:
    Apr 30, 2012
    Messages:
    5,629
    Country:
    United Kingdom
    This feels like a stretch at best (throw all that responsibility at one tagged user, nice touch), but it's just hilarious in the context of you threatening recently to start watermarking all released game nsps because of a personal grudge. You're so full of shit it's comedy gold.
     
  3. yikkyon

    yikkyon GBAtemp Regular
    Member

    Joined:
    Sep 20, 2008
    Messages:
    236
    Country:
    United States
    NSZ files seem to be corrupted when installed but NSP files are perfectly fine. I have tried other NSZs and the same game with NSPs. I have also tried putting the NSZ in the SD and installing it from there. It's only NSZ files that corrupt and kicks me out to the HOME screen. Any thoughts?
     
  4. linuxares

    linuxares I'm not a generous god!
    Moderator

    Joined:
    Aug 5, 2007
    Messages:
    7,158
    Country:
    Sweden
    @blawar and @hippy dave I see where you both are coming from.

    @blawar can't you develop a dumper that can convert xci to proper NSPs? Yes by all means XCIs are proper dumps and converted nsps aren't proper as from the e-shop. Never the less they still work.
     
  5. Huntereb

    OP Huntereb GBAtemp Psycho!
    Member

    Joined:
    Sep 1, 2013
    Messages:
    3,252
    Country:
    United States
    We are aware of this issue and it will be resolved for 1.2.2. In the mean time, use 1.1.0 for nsz installs.

    I'll be doing a proper test of everything for 1.2.2, sorry for the inconvenience. :(
     
    yikkyon and hippy dave like this.
  6. blawar

    blawar Developer
    Developer

    Joined:
    Nov 21, 2016
    Messages:
    1,306
    Country:
    United States
    Yes, I plan to add this to Tinfoil. However it will not work with 4NXCI converted XCI's as they destroy info that makes the conversion back to XCI impossible.
     
  7. linuxares

    linuxares I'm not a generous god!
    Moderator

    Joined:
    Aug 5, 2007
    Messages:
    7,158
    Country:
    Sweden
    But can you push that to 4nxci then? :)
     
  8. hippy dave

    hippy dave BBMB
    Member

    Joined:
    Apr 30, 2012
    Messages:
    5,629
    Country:
    United Kingdom
    Nah it's a difference in approach, 4nxci chooses one method of conversion, which isn't compatible with the other method used by other apps.
     
  9. azoreseuropa

    azoreseuropa GBAtemp Guru
    Member

    Joined:
    Nov 6, 2002
    Messages:
    8,935
    Country:
    United States
    By the way.. good job! Excuse me but... Can I replace background of yours ? I don't like her on the background.
     
  10. Soojai

    Soojai Newbie
    Newcomer

    Joined:
    Dec 10, 2019
    Messages:
    1
    Country:
    Canada
    I'm not sure what I'm doing wrong here. I'm running current version of Atmosphere and Hekate to boot. I put Awoo in the switch folder. It launches just fine. I then choose to install a game and it installs immediately. Says the game is installed. I got to the main menu and the game isn't there.
     
  11. Vanth88

    Vanth88 Private
    Member

    Joined:
    Oct 1, 2007
    Messages:
    769
    Country:
    United States
    Maybe this has been answered before and I apologize if it has but is awoo only supposed to connect once per connection to ns usbloader?

    What happens is when I install a game or whatever it disconnects from ns after and when I attemp to click on LAN install it doesn't list anything until I disconnect NS and connect it again. I don't know if this is intentional or something on my end. I used NS USB .9 Windows 10 alternative. The only options I have enabled for NS are allow XCI installation and on Awoo I have Disable Anime and that's it.
     
  12. BitOSalt

    BitOSalt Newbie
    Newcomer

    Joined:
    Dec 10, 2019
    Messages:
    1
    Country:
    United States
    Good Afternoon everyone :) I was hoping someone might know whats up with my Awoo. Everytime I attempt to install an nsp through ns-usbloader, Im met with a message "performrequest:93:". It doesnt seem to matter what game I attempt it with. Im on an updated Atmosphere and Hekate if that accounts for anything. Any insight would be greatly appreciated! In the mean time I'll keep screwing around trying to fix it myself :P
     
  13. HookedBehemoth

    Newcomer

    Joined:
    Dec 26, 2018
    Messages:
    49
    Country:
    Germany
    Found and fixed that. Only happened with sd card installs.
     
    Soojai likes this.
  14. shivoooooo

    shivoooooo Member
    Newcomer

    Joined:
    Feb 14, 2019
    Messages:
    12
    Country:
    Japan
    @Huntereb I recommend putting this information as an index, because many new people will ask the same thing, over and over again

    Yes!
    Custom backgrounds
    • A custom backround image can be placed in /switch/Awoo-Installer as "background.png", 1280x720!
     
    azoreseuropa likes this.
  15. duckbill007

    duckbill007 GBAtemp Regular
    Member

    Joined:
    May 5, 2011
    Messages:
    109
    Country:
    Russia
    What do you mean files corrupted by me? I am not corrupting any files. I just told that 4nxci do resign and that I never had any issue with that after install. And do have issues with xci installed by tinfoil especially after FW upgrade.

    I have no idea about what wrong what patches exist or not. I am user and see following: "corrupted nsp" from 4nxci works, "not corrupted" from tinfoil not.

    As for me as user "corrupted" that works will be better.

    Also, all this is done "on the fly" while installing and as far as I understand you can not restore original bit-by-bit identical XCI from installed game on the system. And in this case - what the difference how severe they are corrupted?
     
  16. azoreseuropa

    azoreseuropa GBAtemp Guru
    Member

    Joined:
    Nov 6, 2002
    Messages:
    8,935
    Country:
    United States
    Thank you!!!!
     
    shivoooooo likes this.
  17. blawar

    blawar Developer
    Developer

    Joined:
    Nov 21, 2016
    Messages:
    1,306
    Country:
    United States
    Your understanding is incorrect, Tinfoil installed XCI's can be converted back to XCI's -- 4NXCI converted NSP's cannot.

    When you updated, you were missing ACID patches, hence why I told you that your issue was a user issue.
     
    Last edited: Dec 11, 2019
  18. duckbill007

    duckbill007 GBAtemp Regular
    Member

    Joined:
    May 5, 2011
    Messages:
    109
    Country:
    Russia
    How can it be done if only secure partition is used? other 3 partitions are lost so, restored image won't be bit-by-bit equal to original.
     
  19. blawar

    blawar Developer
    Developer

    Joined:
    Nov 21, 2016
    Messages:
    1,306
    Country:
    United States
    The normal partition can be rebuilt, it just holds a copy of the control NCA I believer. Update partition is not needed. SX will mount the resulting XCI and everything will be signed.

    bit for bit identical does not matter, as long as everything is signed. XCI’s can never be used to make flash carts because they don’t have all of the gamecart’s info anyway, they exist solely for mounting with SX and converting to NSP
     
  20. Huntereb

    OP Huntereb GBAtemp Psycho!
    Member

    Joined:
    Sep 1, 2013
    Messages:
    3,252
    Country:
    United States
    Awoo Installer 1.2.2

    What's new?

    - Fixed a bug that caused XCI installations from SD card to fail
    - Builds are now compiled with a properly built lib-zstd (large NSZ/XCZ files actually install now)
    - Audio notifications for warnings, errors, and complete installations
    - Can be disabled by turning your volume down :v)​
    - Home button is no longer blocked during installations
    - Users are now warned about potential instability using Applet Mode
    - Losing connection during a LAN/internet install no longer causes the software to crash
    - Google Drive API key can now be set in your config.ini
    - Will appear in your config after running the software and changing settings once​
    - Many behind-the-scenes changes for USB installations (Coming soon!)
    - Many other small changes and bug fixes


    Download

    This is intended behavior. If you'd like to start another install, just click "Upload to NS" two times after selecting "Install over LAN or Internet".

    I've seen this issue mentioned previously in the thread. If you're using Mac OS (or any OS really, it's just primarily an issue on Mac OS) you should check your firewall settings.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Installer, Installer, Bullshit