Hacking Atmosphere-NX - Custom Firmware in development by SciresM

isoboy

Well-Known Member
Member
Joined
Dec 23, 2016
Messages
1,127
Trophies
0
XP
2,051
Country
United States
I've just done what I put aside for a long time. Backed up my saves first, then all I did was delete the sx folder and a few files, copied over atmosphere and updated the apps that needed updating like fpt, save manager... copied over the all in one updater. Then I updated the firmware from 11 to the latest....it all seems to just work without a hitch. Now I need to figure out the best and easiest way to install games, updates and dlc. And get the freeshop thing working.
 

rob61

Well-Known Member
Newcomer
Joined
Oct 19, 2007
Messages
65
Trophies
0
XP
257
Country
United States
Switch was working with latest Atmosphere 1.3.2 and OFW. Today when I try to boot using TegraRcmSmash with fusee.bin and my dongle/jig it flashes the Atmosphere screen for about a half second then the screen goes blank. A few seconds later the Atmosphere logo screen flashes again, then goes black. Never boots back up. Any known fix? TegraRcmSmash (32 bit) provides the following:

No RCM device detected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
3,152
Trophies
2
XP
2,247
Country
United States
Switch was working with latest Atmosphere 1.3.2 and OFW. Today when I try to boot using TegraRcmSmash with fusee.bin and my dongle/jig it flashes the Atmosphere screen for about a half second then the screen goes blank. A few seconds later the Atmosphere logo screen flashes again, then goes black. Never boots back up. Any known fix? TegraRcmSmash (32 bit) provides the following:

No RCM device detected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected
RCM Device detected
Invoking TegraRcmSmash.exe with args : "C:\Program Files (x86)\TegraRcmGUI\favorites\fusee.bin"
TegraRcmSmash (32bit) 1.2.1-3 by rajkosto
Opened USB device path \\?\usb#vid_0955&pid_7321#7&2ee6241&0&1#{aa0dbd45-3117-f331-5c49-76bf65225042}
RCM Device with id C080031700000010C2A2406401101062 initialized successfully!
Uploading payload (mezzo size: 92, user size: 109088, total size: 175304, total padded size: 176128)...
Smashing the stack!
Smashed the stack with a 0x001f byte SETUP request!
Payload successfully injected
RCM device disconnected

Have you added anything new sys modules?

Try this:

temporarily move/rename your /atmosphere/contents directory to /atmosphere/contents.bk and reboot.
 

mrdude

Well-Known Member
Member
Joined
Dec 11, 2015
Messages
1,587
Trophies
1
Age
54
XP
4,448
Country
Hello, I accidantaly destroyed my ns-atmosphere payload injector, is there one that is good enough with an included jig you would recommand?

If possible not from china/aliexpress, I don't really want to wait weeks/months for it to come.
You can just use an android phone.
 

The Catboy

GBATemp's Official Catboy™: *smug nya~*
Member
Joined
Sep 13, 2009
Messages
25,718
Trophies
3
Age
31
Location
In front of my Switch
XP
28,583
Country
Antarctica
Hello, I accidantaly destroyed my ns-atmosphere payload injector, is there one that is good enough with an included jig you would recommand?

If possible not from china/aliexpress, I don't really want to wait weeks/months for it to come.
I use an old android phone as an injector.
 

impeeza

¡Kabito!
Member
Joined
Apr 5, 2011
Messages
1,874
Trophies
1
Age
44
XP
3,201
Country
Colombia
inject another payload, like hekate and enter on NYX (pressing VOL- while injecting) or tegraexplorer and let us to know how that go.
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
3,152
Trophies
2
XP
2,247
Country
United States
Hello, I accidantaly destroyed my ns-atmosphere payload injector, is there one that is good enough with an included jig you would recommand?

If possible not from china/aliexpress, I don't really want to wait weeks/months for it to come.

First your going to need a decent laptop.
This one should do:
https://www.amazon.com/ThinkPad-P17-Workstation-W-11955M-Display/dp/B09X5W19NP

Next you’re going to need a USB cable. I highly recommend this one for its strength and length. You don’t want to be all cramped up while you’re trying to work:
https://www.amazon.com/Logitech-45M-Strong-USB-Cable/dp/B08K2X9YBP

Oh…almost forgot. You’ll want a paper clip. I know, I know. Paper clips are awful and the can tear the shit out of the contacts in your joycons. Just be really careful! We’re just trying to get thing back up and running quickly you.

Here’s 100 for $1.30. You’ll never run out of jigs!
https://www.amazon.com/PROMISE-FLOURISH-Durable-Resistant-Personal/dp/B09GBKBYS9/

Feel free to mix and match! Be creative! These are just some quick suggestions I found while browsing the web.





The above is horrible advice BTW!
You can just grab one of these guys and call it a day:
https://www.amazon.com/Loader-Paylods-Swich-Connector-Archive/dp/B0B4MZHN6J
 
  • Haha
  • Like
Reactions: peteruk and impeeza

rob61

Well-Known Member
Newcomer
Joined
Oct 19, 2007
Messages
65
Trophies
0
XP
257
Country
United States
inject another payload, like hekate and enter on NYX (pressing VOL- while injecting) or tegraexplorer and let us to know how that go.
I was able to get Atmosphere running again by injecting hekate and then that was able to boot into atmosphere. However now I get The microSD card data is corrupted. I thought for sure that when updated the OFW I chose fat32. Hekate disc info report fat32. However, it seems the card may be corrupt. It won't run games. Is there anything to try before I reformat the SD card?
 

rob61

Well-Known Member
Newcomer
Joined
Oct 19, 2007
Messages
65
Trophies
0
XP
257
Country
United States
When I try to boot with the latest hekate, it shows "failed to init or mount SD!"
Press any key...
Then I select "Console info" from the hekate v5.8.0 menu, I select Storage Info/SD Card. It shows the SD card info, "Found FAT32 volume: Free 68578 MiB, Cluster : 64 KiB"

So it appears to be able to read the SD card. However, when hedate boots, it seems it can't mount the SD. I had problems before and had it serviced to install a new card reader. I'm wondering if there are further problems with it, but it had been working fine, and hekate can give SD info, it just can't "mount" the SD.

It shows "Warning: Nyx is missing", most likely because the SD is not mounted, as it is on the SD card when I check under Windows.

I did get it to boot once, and ran the disc speed test which it completed.

Any idea on what I might try next?
 

Bonovox40

Well-Known Member
Member
Joined
Apr 2, 2003
Messages
548
Trophies
0
XP
1,076
Country
United States
This is just to move the old deployments out of the way for both atmosphere and bootloader.

When you unzip the files at the top of your SDCard you will have new atmosphere and bootloader directories with nothing left over from the original deployment (but you have a .bk for backup if you want to roll back).

In the odd case you don’t have a new /atmosphere and /bootloader then we know there’s an issue with the transport method.

Make sense?
Been busy with work but tried this again and now it's worse. Before at least I was booting into the atmosphere but now it just shows a black screen with "A fatal error occurred when running Fusee. Incorrect fusee version! ...Press POWER to reboot."

I even tried deleting the Atmosphere folder and copying over everything again. Didn't help at all. What went wrong or what is preventing it from even booting past that incorrect fusee screen?!
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
3,152
Trophies
2
XP
2,247
Country
United States
Been busy with work but tried this again and now it's worse. Before at least I was booting into the atmosphere but now it just shows a black screen with "A fatal error occurred when running Fusee. Incorrect fusee version! ...Press POWER to reboot."

I even tried deleting the Atmosphere folder and copying over everything again. Didn't help at all. What went wrong or what is preventing it from even booting past that incorrect fusee screen?!

Did you download fusee.bin from the same place you downloaded Atmosphere?

You will need to place it in /bootloader/payloads/fusee.bin AGAIN (because we moved the /bootloader out of the way.)

1657335133239.png
 
Last edited by binkinator,
  • Like
Reactions: impeeza
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: +2