1. CaptainHIT

    CaptainHIT GBAtemp Fan
    Member

    Joined:
    Mar 2, 2011
    Messages:
    367
    Country:
    Germany
    Nearly 2 years iirc. I bought it together with Links Awakening when it was released.
     
    Last edited by CaptainHIT, May 6, 2021
  2. Solo761

    Solo761 Member
    Newcomer

    Joined:
    Jul 11, 2009
    Messages:
    23
    Country:
    Croatia
    As I mentioned, I tried exFAT AND FAT32 multiple times with same result. And I also used latest hekate and Atmosphere release.

    With this Kingston card only emuMMC in file worked. But I've run into new problems with that. It turns out with Atmosphere using file based emuMMC is highely unreliable. Tried to copy stuff from memory card and Atmosphere crashed, again, multiple times.



    I didn't exactly "switch" from FAT32 to exFAT, every time I did that that mean complete format of SD card and CFW setup from zero. It wasn't just copy everything from SD to HDD, format and copy back to SD.

    Today I tried few more times but again the same. Doesn't work with Kingston SD, but works with Samsung SD...
    But I got an idea thought to try just once more...

    This time I used Hekate 5.5.4, instead of latest 5.5.5, to reformat my SD card, prepare emuMMC partition and create. After that I repeated the usual procedure and this time it worked WITHOUT PROBLEMS. CFW booted fine from emuMMC on Kingston card. After that I updated emuMMC firmware to 12.0.1 using Daybreak. I had few demos in my sysNAND that were passed to emuNAND and since fw 10.0 implemented option to transfer games from SD to internal and vice-versa I tried that and it also worked without problems. In multiple "directions". I also managed to update to 12.0.1 with file based emuNAND, but this transfer of games would crash Atmosphere after few hundreds of megabytes.


    So all in all, if someone else stumbles on black screen on emuMMC setup (on clean SD), try older Hekate version. It seems something changed in SD routines in 5.5.5 that corrupted firmware while it was copied to emuMMC with this flavour of SD card. In my case 5.5.4, one version "older" was enough to avoid the issue.

    After I created partition and copied fw with Hekate 5.5.4 I updated it to 5.5.5, copied Atmosphere files to main parition and it still worked fine. So it seems there was some issue with how Hekate 5.5.5 does this process...
     
  3. Hayato213

    Hayato213 GBAtemp Guru
    Member

    Joined:
    Dec 26, 2015
    Messages:
    9,419
    Country:
    United States
    It probably have something to do with the SD, I never used any Kingston one, only Samsung and Sandisk so far for me. File based is slower compared to partition based.
     
  4. Solo761

    Solo761 Member
    Newcomer

    Joined:
    Jul 11, 2009
    Messages:
    23
    Country:
    Croatia
    Not just slower, I could live with that, but it was unreliable. In the end I wanted to go back to SX OS, but figured I'd try with older Hekate just to see what will happen and... it happened. So far everything I tried worked fine so I'm staying with Atmosphere it seems.


    This one has OK speed. Around 90 MB/s read and when I install something over USB it writes it at 35-45 MB/s, it actually depends on cable, I had one that I use for my cell phones, braided, thick, supposedly of quality and I get 35 MB/s with it. Today my cell phone was charging so I grabbed one from my drawer and now I get 42-45 MB/s... Same USB port on my PC... Crazy.

    As for spotty drives I have few 64 GB AData USB 3.0 flash drives. Read speed is about 20 MB/s, write is around 2 MB/s. If it was any slower it would go backwards :ha:
     
  5. impeeza

    impeeza GBAtemp Regular
    Member

    Joined:
    Apr 5, 2011
    Messages:
    173
    Country:
    Colombia
    you should read the thread about sigpatches:

    on that thread several people having similar issues have found answer.
     
  6. Vultix93

    Vultix93 Advanced Member
    Newcomer

    Joined:
    Dec 9, 2014
    Messages:
    90
    Country:
    Italy
    So haven't updated in a while, my system is on EMUMMC 10.2.0, and decided to update Atmosphere first and then pass it to the firmware. After installing Atmosphere 19.2 most of my homebrew don't work. I can't open Checkpoint, ChoiDujourNX( so I can't update), HB App store, and some others. What I'm supposed to do?
    Games works fine though
     
  7. impeeza

    impeeza GBAtemp Regular
    Member

    Joined:
    Apr 5, 2011
    Messages:
    173
    Country:
    Colombia
    You must to update the sigpatches. Search the web or go to https://gbatemp.net/threads/sigpatc...ate-fss0-fusee-primary-fusee-secondary.571543

    By the way, until ChoiDujourNX get updated you must use Daydream to upgrade the firmware.
     
    Last edited by impeeza, May 8, 2021
  8. Vultix93

    Vultix93 Advanced Member
    Newcomer

    Joined:
    Dec 9, 2014
    Messages:
    90
    Country:
    Italy
  9. impeeza

    impeeza GBAtemp Regular
    Member

    Joined:
    Apr 5, 2011
    Messages:
    173
    Country:
    Colombia
    Most of the hombrew should be updated to the new libraries. Is stated on the atmosphère release page and and almost every post related to atmosphère and 12.x firmware.

    Today almost all homebrew I use are updated to newest libraries. Or have several people working on it.

    So please read the release page of the homebrew you want to use and update them properly. If you found a non updated homebrew, you can:
    • Read if there is not a currently open issue for it and politely ask for update.
    • Make changes to the code, recompile and propose the corresponding comits to code.
    • Look for updated forks.
     
    Last edited by impeeza, May 9, 2021
  10. CaptainHIT

    CaptainHIT GBAtemp Fan
    Member

    Joined:
    Mar 2, 2011
    Messages:
    367
    Country:
    Germany
    Strangely it didn't help. I had the backup of the atmphspere/bootloader/sept folder. Copied it over and it worked. It's not a clean install though. :(
     
  11. CaptainHIT

    CaptainHIT GBAtemp Fan
    Member

    Joined:
    Mar 2, 2011
    Messages:
    367
    Country:
    Germany
    Ok, tried it again, this time I remembered something about the hekate_ipl.ini. I compared both my old ini file and the one from the fresh install.
    There is an entry in the emuMMC section: "kip1=atmosphere/kips/*"
    In my older install it is: "kip1=nosigchk"

    After changing this, the problems are gone!
     
    Last edited by CaptainHIT, May 11, 2021
  12. impeeza

    impeeza GBAtemp Regular
    Member

    Joined:
    Apr 5, 2011
    Messages:
    173
    Country:
    Colombia
  13. Solitario

    Solitario GBAtemp Regular
    Member

    Joined:
    Feb 18, 2018
    Messages:
    146
    Country:
    Brazil
    ^^
     
    Last edited by Solitario, May 12, 2021
  14. mondul

    mondul GBAtemp Regular
    Member

    Joined:
    Aug 8, 2018
    Messages:
    114
    Country:
    Colombia
    New Atmosphere is out.

    0.19.3 is Atmosphère's forty-ninth official release.

    fusee-primary was last updated in: 0.19.3.

    With thanks to the @switchbrew team, Atmosphère 0.19.3 is bundled with hbl 2.4.1, and hbmenu 3.4.0.

    The following was changed since the last release:

    • Support was added for 12.0.2.
    • A number of minor issues were fixed, including:
      • An issue was fixed in dns.mitm that caused a crash when games attempted to resolve the IP address of nullptr.
      • An issue was fixed in erpt that would cause an abort when booting without having ever booted stock previously.
      • An issue was fixed in (file-based) emummc that caused an error on system format/downloading certain games.
    • General system stability improvements to enhance the user's experience.
    Download from here:
    https://github.com/Atmosphere-NX/Atmosphere/releases/tag/0.19.3
     
    Last edited by mondul, May 12, 2021 - Reason: Add release info
    Tyvar1 and Mata84 like this.
  15. Baoulettes

    Baoulettes The lonely man
    Member

    Joined:
    May 25, 2011
    Messages:
    775
    Country:
    France
    No idea if that the right place but I guess it is,
    Since latest update of Atmo I have quite some issues :
    First the most annoying :
    Unable to read game card.
    So before explaining more I will tell step by step what I did :

    I was on 12.0.1 FW with Atmo 0.19.1
    It worked fine without error just since it was updated to support latest FW I said "why not"

    I have first updated Atmo to 0.19.3 here without issues
    (every time I empty my content folder so it force me to update my homebrew)

    Since it was working fine there I proceed to update FW with official method (Settings-console-update)
    It boot fine but now I am unable to make it read any games from card slot (so definitely a legit game)

    I tried rebooting etc no change.
    I tried to shutdown and start again after some seconds
    I tried several different game from Mario kart 8 to Zelda with Mario Maker.
    I tried booting original FW ( I do not care about burnt fuse)

    What could cause the reader to actually not read games?

    PS: I have absolutely zero nsp installed and do not plan to do any sort of workaround or things, I use Atmo only for tesla menu.
    Also I never downgrade or anything so in theory the FW should be pretty clean from games card reader issue ?
     
  16. fille

    fille GBAtemp Fan
    Member

    Joined:
    Mar 28, 2014
    Messages:
    419
    Country:
    Belgium
    Last edited by fille, May 14, 2021
  17. Baoulettes

    Baoulettes The lonely man
    Member

    Joined:
    May 25, 2011
    Messages:
    775
    Country:
    France
  18. petspeed

    petspeed GBAtemp Advanced Fan
    Member

    Joined:
    Nov 13, 2009
    Messages:
    769
    Country:
    Denmark
    Copy BCT.INI from E:\atmosphere\config_templates\ to E:\atmosphere\config\
    Edit the file and add this under the [stratosphere] section:
    nogc = 0

    If you use Hekate to boot CFW you might also need to make sure that you have this in your hekate_ipl.ini:
    autonogc = 0
     
  19. mattyxarope

    mattyxarope GBAtemp Fan
    Member

    Joined:
    Jan 15, 2019
    Messages:
    449
    Country:
    United States
    Does anyone have a problem upon first booting? The first title I try always errors out, but from then on I can choose any title successfully...
     
  20. petspeed

    petspeed GBAtemp Advanced Fan
    Member

    Joined:
    Nov 13, 2009
    Messages:
    769
    Country:
    Denmark
    What happens when you get the error? Does the switch reboot?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - development, Atmosphere, Firmware