Atmosphere-NX - Custom Firmware in development by SciresM

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Waze0613, Feb 17, 2018.

  1. designgears

    designgears GBAtemp Regular

    Member
    4
    Aug 8, 2016
    United States
    Whoever in ReSwitched discord I helped get their switch booting again, glad I could help out! Unfortunately, I was banned because mentioning "other opensource cfw" (ReiNX in this case) is apparently considered piracy.

    On that note, @SciresM Atmosphere is unable to boot in certain circumstances where ReiNX can and even corrects the issue so that Atmosphere can boot. Downgrading with ChoiDour (not homebrew NX version) causes it, and fake linking an account causes it.

    I would post it on a github issue, but mentioning things ReSwitched views as piracy gets closed and ignored.
     
    Last edited by designgears, Apr 19, 2019
  2. laramie

    laramie GBAtemp Advanced Fan

    Member
    4
    Dec 15, 2014
    United States
    sounds like an updated boot0/1
     
  3. xenon

    xenon GBAtemp Regular

    Member
    2
    May 19, 2006
    Italy
    Hi, I am trying to compile the current Atmosphere (master) but I am hitting this error:

    MYPATH/Atmosphere/stratosphere/loader/source/ldr_nso.cpp:278:9: error: 'sha256CalculateHash' was not declared in this scope

    I understand Atmos switched to libnx's implementation of SHA256 operations and my build is not finding the associated function. I have successfully complied the latest libnx and I have edited Atmos's makefile to include my libnx build (results in compiling with -IMYPATH/Atmosphere/stratosphere/loader/../../../libnx/nx//include).

    That path contains switch.h, which in turn includes switch/crypto/sha256.h, which defines the sha256CalculateHash function, which is what is causing the build error. I am not a huge expert of compilers, but I can't see what's wrong/missing. Any tips? Thanks in advance!

    — Posts automatically merged - Please don't double post! —

    @SciresM should you ever see this... :)
     
  4. designgears

    designgears GBAtemp Regular

    Member
    4
    Aug 8, 2016
    United States

    You need to make install the libnx master
    https://github.com/switchbrew/libnx

    Or checkout atmos 0.8.7 tag and compile from there with current libnx.
     
    Last edited by designgears, Apr 19, 2019
  5. xenon

    xenon GBAtemp Regular

    Member
    2
    May 19, 2006
    Italy
    Brilliant, thanks! :) Installing libnx did the trick. My Atmos doesn't work, but still I'm happy. ;]
     
  6. midstor

    midstor GBAtemp Regular

    Member
    5
    Aug 1, 2018
    United States
    ReSwitched is the best ppl ever no lie 100% JK
    #TXGang #ReiGang #UltraGang #XKGang? #AceGang
     
  7. JJTapia19

    JJTapia19 I fight for my friends.

    Member
    10
    May 31, 2015
    Puerto Rico
    Brace yourself! June 15 is coming.
     
  8. Sabishinbo

    Sabishinbo GBAtemp Regular

    Member
    2
    Sep 27, 2015
    United States
    If I downgrade to 6.x or 4.x using my nand backup, will I lose all of my save file progress and the games installed on nand?
     
  9. Fredfrog6

    Fredfrog6 Member

    Newcomer
    1
    Apr 19, 2019
    United States
    When will an update for Atmosphere be released that allows for cfw support on 8.0?
     
  10. RattletraPM

    RattletraPM GBATemp's official 蒸気イーブイ

    pip Reporter
    15
    Jan 18, 2017
    Italy
    Shinjuku Station
    Later today, apparently.
    Source
     
    PHiLiPZ, ApolloCheese and Sabishinbo like this.
  11. Sabishinbo

    Sabishinbo GBAtemp Regular

    Member
    2
    Sep 27, 2015
    United States
    i would legitimately let sciresm impregnate me t b h
     
  12. stick267

    stick267 GBAtemp Advanced Fan

    Member
    4
    Dec 17, 2018
    United States
    You'll lose both but you can backup/restore your saves with Checkpoint.
     
  13. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    Curious.. I don't need to restore my backup but if you want to restore your backup.. You must be on fat32 to do this ?

    Mine is formatted fat32 but installed exfat on ChoiNX.
     
  14. designgears

    designgears GBAtemp Regular

    Member
    4
    Aug 8, 2016
    United States
  15. SciresM

    SciresM GBAtemp Advanced Fan

    Member
    16
    Mar 21, 2014
    United States
    Happy June 15th!
     
  16. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    Anybody?

    Very good but I will stay with 3.0.0 update to 7.0.1 with ChoiNX for now.
     
  17. Philliyxx

    Philliyxx GBAtemp Regular

    Member
    4
    Sep 21, 2018
    United States
    You can restore NAND fat32 or exfat in releases 4.9+
    • Support for split files restore Thanks to @emvym3two
      You can now restore using parts or FAT32. The only condition it that all parts must be in the sd card.
      It protects from fake sd cards, bad sectors and frequent I/O corruption. Aka, ~100% of cases.
    I believe NXManager can also do this.
     
    Last edited by Philliyxx, Apr 20, 2019
  18. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    I already joiner them to one file. rawnand.bin. Is it fine to use for fat32 or exfat?
     
  19. designgears

    designgears GBAtemp Regular

    Member
    4
    Aug 8, 2016
    United States
    Fat32 has a max file size of 4GB
     
  20. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    So I should use other SD for exfat only to restore one file rawnand.bin ? Correct?
     
Loading...