atmosphere don't boot with hekate

raging_chaos

Well-Known Member
Member
Joined
Oct 27, 2020
Messages
250
Trophies
0
XP
711
Country
United States
(After) replacing fss0=atmosphere/package3 (to) payload=/bootloader/payloads/fusee.bin when i apply a theme (in emunand) the theme is also modified in CFW sysnand (and stock)

Edited the quote to make it easier to follow, hope you don't mind. Don't use fusee to boot stock in this case. Use package3.

[Stock (SYSNAND)]
fss0=atmosphere/package3
kip1patch=nosigchk
stock=1
emummc_force_disable=1
icon=bootloader/res/icon_switch.bmp

The same goes for if you want to boot to sysnand using Atmosphere.

[CFW (SYSNAND)]
fss0=atmosphere/package3
kip1patch=nosigchk
atmosphere=1
emummc_force_disable=1
icon=bootloader/res/icon_payload.bmp

Don't forget to update sigpatches if need to.
 
Last edited by raging_chaos,

alba93

Well-Known Member
OP
Newcomer
Joined
Feb 2, 2019
Messages
73
Trophies
0
Age
43
XP
816
Country
France
Edited the quote to make it easier to follow, hope you don't mind. Don't use fusee to boot stock in this case. Use package3.



The same goes for if you want to boot to sysnand using Atmosphere.



Don't forget to update sigpatches if need to.

my switch doesn't boot anymore with package3
This is my main concern
 

raging_chaos

Well-Known Member
Member
Joined
Oct 27, 2020
Messages
250
Trophies
0
XP
711
Country
United States
So I ended up grabbing a spare SD card and I retried all of your steps from your original post. I can at least confirm there is nothing wrong with the latest hekate and atmosphere because it worked without issue. I even used the hekate_ipl.ini you had posted with fss0. The suggestion is always to start over from scratch by redownloading everything, reformatting with official SD Card Formatter tool, following the rentry guide or something similar, or just flat out using a different SD card. It's not easy figuring out why fss0 won't work for some users it could be anything.

As for how fusee works, it completely ignores whatever arguments are in hekate_ipl.ini so commands like emummcforce=1 are not necessary. Your hekate_ipl.ini should pretty much look like this since you can only boot fusee:

[config]
autoboot=0
autoboot_list=0
bootwait=3
backlight=100
autohosoff=0
autonogc=1
updater2p=1
bootprotect=0

[Atmosphere Fusee]
payload=atmosphere/fusee.bin
icon=bootloader/res/icon_payload.bmp

To boot into sysnand with fusee you need to disable your emuMMC before launching by going into the "emuMMC" menu, then click "Change emuMMC" and then click "Disable" at the top. You'll have to reenable emuMMC using the same menu when you want to use CFW by selecting your Raw partition (SD Raw 1/2/3). Someone had brought up being able to use arguments but CTCaer pretty much said he's not interested.
 
Last edited by raging_chaos,
  • Like
Reactions: binkinator

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
3,059
Trophies
2
XP
2,201
Country
United States
As for how fusee works, it completely ignores whatever arguments are in hekate_ipl.ini so commands like emummcforce=1 are not necessary.

whah!?! I did not know this. Thank you.

The suggestion is always to start over from scratch by redownloading everything, reformatting with official SD Card Formatter tool, following the rentry guide or something similar, and just flat out using a different SD card. It's not easy figuring out why fss0 won't work for some users it could be anything.

…for the record he has already started from scratch once before. I’m thinking it’s the card.
 

alba93

Well-Known Member
OP
Newcomer
Joined
Feb 2, 2019
Messages
73
Trophies
0
Age
43
XP
816
Country
France
thanks raging_chaos for your feedback

in my previous postes I've already made a clean installation of the system => issue not fixed
I've also tried to disable the emunand to boot on the CFW of the nand => it works but it is not very user friendly
I did not know that fusee doesn't take into account the hekate_ipl.ini parameters

By injecting fusee :
  • I always boot to the emunand
  • I need to disable the emunand to access the CFW from the nand
  • I need to turn off my switch to boot on the OFW of the nand
with hekate it was easier...

I've just ordered a new SD card hoping that it will fix my issues
i'll keep you informed
 
  • Like
Reactions: binkinator
General chit-chat
Help Users
    Skelletonike @ Skelletonike: got an LG one last month and it was pretty good, was on sale so got it for 400€ (normal price...