Atmosphère 0.9.1 released, adds 8.1.0 support

Discussion in 'GBAtemp & Scene News' started by RattletraPM, Jun 19, 2019.

  1. fst312

    fst312 GBAtemp Advanced Fan

    Member
    6
    Nov 4, 2008
    United States
    New York
    Can’t wait till emummc is ready, I know there is a tutorial on how to use the current version but I know I might make a mistake and ruin my other switch that I really want to use it on.
     
  2. MarcusCarter

    MarcusCarter Furret Freek

    Member
    6
    Jan 7, 2012
    United States
    Johto Pokemon Fan Club
    Yes! A GBAtemp user with common sense! I thought those were all but extinct! You've restored my faith in this website! :yay:
     
    burt111 and fst312 like this.
  3. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    If your Switch are unpatched to fuseé geleé then just make a full nand backup with Hekate (BOOT0, BOOT1 and rawnand) before make any modification, you gona can comeback all time with this backup if you made some mistake.
     
    Heichart and fst312 like this.
  4. mrdude

    mrdude GBAtemp Advanced Fan

    Member
    6
    Dec 11, 2015
    I've just updated to Atmosphere 0.9.1

    Firmware on Emunand 8.1.0 - emunand freezes on Nintendo Logo.
    Reinstalled firmware 8.0.1 - emunand works fine.

    Seems there's an issue using emunand which has firmware 8.1.0 installed.

    8.1.0 fimware on emunand - works fine with SXOS.
     
  5. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    There are a bugs to solve on emuMMC implementation, the 8.1.0 should work on sysnand atleast.

    Please let a issue with all details possible on: https://github.com/Atmosphere-NX/Atmosphere/issues
     
    mrdude likes this.
  6. mrdude

    mrdude GBAtemp Advanced Fan

    Member
    6
    Dec 11, 2015
  7. ModderFokker619

    ModderFokker619 GBAtemp Advanced Fan

    Member
    6
    Oct 2, 2015
    United States
    California
    Getting black screen before switch logo

    TX SX OS 2.8 loads ofw and cfw

    Tried various brands of micro sd exfat and fat32

    I think somethings up with this switch as it only loads ofw from tx sx boot option screen

    This started from 8.1.0 system update
     
  8. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    On sysnand or emuMMC?
     
  9. goncalodoom

    goncalodoom GBAtemp Fan

    Member
    3
    Sep 12, 2009
    Portugal
    portugal
    Does it really support 8.1.0? Getting ""Failed to launch CFW" after updating through ChoiDujourNX to 8.1.0 and latest atmosphere...
     
  10. ModderFokker619

    ModderFokker619 GBAtemp Advanced Fan

    Member
    6
    Oct 2, 2015
    United States
    California

    Sysnand black screens loading direct with no autorcm
    Sysnand and TX CFW only currently load through tx sx options menu to load cfw/ofw - Tried loading atmo payload through tx menu and black screen
    Atmo always black screens before switch logo
    When in sysnand exfat and fat 32 cards are being detected

    This all came about from an 8.1.0 update
     
  11. Owenge

    Owenge GbaTemp browser

    Member
    6
    Feb 13, 2017
    United States
    ◤__◥
    SXOS and Atmossphere: I aM sPeEd
     
  12. gizmomelb

    gizmomelb GBAtemp Advanced Fan

    Member
    7
    Jul 13, 2006
    Australia
    it didn't have to - but it should show all the TX haters that TX did NOT use Sept, because the updated Sept wasn't even available before TX did their update.

    So can we please stop with the usual shitbaggery between CFW? They both have their unique features, so let's be thankful there is a CHOICE.
     
    Josshy0125 likes this.
  13. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    @SciresM: There are a some affected people that can't boot with the last release. Boot problems seems related with updates through ChoiDujourNX, so probably not related with a Atmosphére.

     
    Last edited by Chocola, Jun 20, 2019
  14. Josshy0125

    Josshy0125 GBAtemp Regular

    Member
    3
    Jun 16, 2019
    United Kingdom
    Sounds to me like it wasnt... ready prior to its release :unsure:
     
    ModderFokker619 likes this.
  15. ModderFokker619

    ModderFokker619 GBAtemp Advanced Fan

    Member
    6
    Oct 2, 2015
    United States
    California
    Will have to wait then.
     
  16. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    Probably a compile mistake or missed changes to git before compile, the public builds and the dev builds differ a bit.

    — Posts automatically merged - Please don't double post! —

    Disable all the kip patches and all modifications and try to boot with a fresh atmosphére release, I try it now and work, so seems some incompatibility or error with modules system.
     
  17. ModderFokker619

    ModderFokker619 GBAtemp Advanced Fan

    Member
    6
    Oct 2, 2015
    United States
    California

    Tried that and black screen.
     
  18. Darksabre72

    Darksabre72 Blue Falcon

    Member
    5
    Nov 26, 2016
    United States
    can't wait to try this when they get most of them bugs fixed :)
     
  19. Voxel

    Voxel Master of moonjumps

    Member
    14
    GBAtemp Patron
    Voxel is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 27, 2015
    United Kingdom
    Fwiw, I updated from 8.0.1 to 8.1.0 via settings on emunand and didn't get a black screen on the Switch logo or anything. Just missing the sig patches to run stuff right now until they're updated. (so I've just downgraded back for the time being)
     
  20. Chocola

    Chocola GBAtemp Meowgular

    Member
    3
    Sep 18, 2018
    Korea, South
    Neko Paradise
    Boot problems seems related with updates through ChoiDujourNX, so probably not related with a Atmosphére, users that update through oficial way (Settings menu > Console > Check for updates) we don't have any problem.

    Probably @rajkosto need to update his homebrew for support the changes on 8.1.0
     
Loading...