Are new PSP's firmware flashable?

Discussion in 'PSP - Hacking & Homebrew' started by WeaponXxX, May 31, 2007.

May 31, 2007
  1. WeaponXxX
    OP

    Member WeaponXxX Too F'in Blonde

    Joined:
    Nov 4, 2004
    Messages:
    2,868
    Location:
    Currently in Chicagoooooooo
    Country:
    United States
    I sold my 1.5 PSP a while back cause nothing was good on it IMO, anyway now some shit is out that I'd like to play. Can I pick up a new PSP and Mod it or is 1.5 still needed?
     
  2. jimmy j

    Member jimmy j Awesome for hire.

    Joined:
    Apr 22, 2007
    Messages:
    894
    Location:
    the congo
    Country:
    United Kingdom
    From what I understand you can rollback newer firmware to 1.5 or you can install hacked firmware that will behave like 1.5 (ie. let you play emus and backups) but it still lets you play newer games.

    I've seen a few boxed&new psps on ebay with modded firmware (I think it was called darkalex firmware)
     
  3. Parsaw

    Member Parsaw GBAtemp Regular

    Joined:
    Sep 18, 2006
    Messages:
    263
    Location:
    Rocklin, CA
    Country:
    United States
    The LATEST firmware is currently NOT downgradeable.
     
  4. WeaponXxX
    OP

    Member WeaponXxX Too F'in Blonde

    Joined:
    Nov 4, 2004
    Messages:
    2,868
    Location:
    Currently in Chicagoooooooo
    Country:
    United States
    Yea I am familiar with Dark Alex's firmware...I guess if anyone can give me a hand what exactly I need to do it would be appreciated.

    Step 1) Buy a PSP with firm ware (X or lower)
    Step 2) Downgrade firmware by.....
    Step 3) Flash PSP??

    Just guesses....appreciate the help. All the forums I read basically talk as if everybody still has the 1.5s which doesn't really help me now
     
  5. larvi

    Member larvi GBAtemp Regular

    Joined:
    Jun 24, 2006
    Messages:
    233
    Country:
    United States
  6. wabo

    Member wabo GBAtemp Maniac

    Joined:
    Dec 14, 2003
    Messages:
    1,082
    Location:
    Canada
    Country:
    Canada
    You can downgrade from firmware 3.03 and below.
    From 2.81 to 3.03, you need a GTA Liberty City Disc from the first batch that was made. It has the firmware 2.0 on it. If you go and buy the game new today on some store shelves, it wont work. You absolutly need a first edition copy. With some luck you can rent it or find it in some flea market or you can try ebay, theres an handful of them but they mostly go at 50$.

    I recently downgraded my 2.81 unit. I paid 65$ dollars for the PSP, 1 gig stick, 1 game and 1 UMD movie but i had to pay 60$ for a boxless copy of GTA. [​IMG]

    So what i did is:
    -Upgrade my 2.81 with Sony's official 3.03
    -Use the 3.03 downgrader (wich needs GTA LC) to downgrade to 1.5
    -Upgrade to 3.40 OE after that from the 1.5

    So now it's just like the official 3.40 except i can drop iso and cso in the ISO folder and run them from the psp just like a UMD game. Sweet lovin, it was worth all the effort for sure.
     

Share This Page