Hacking Anyone using 9.0.1 and atmosphere 0.9.4

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
Hello,
Wanted to ask, if anyone are using mentioned Custom FW and is it stable to play games etc, like, It won't brick my Nintendo Switch by loading and using it on random (I'm aware of game cartridge bug)? If something happens (like bricking) will backup of the NAND flash will help to recover switch to original state any time without any possible problems?
Thanks for answers!
 

Smoker1

Well-Known Member
Member
Joined
Feb 17, 2015
Messages
4,403
Trophies
1
Location
California
XP
4,697
Country
United States
I thought I was Updating to 9.0.1, but for some reason, it is 9.0.0 . I had the Card Bug, but I got it fixed. Otherwise, works perfectly.
 

fvig2001

Well-Known Member
Member
Joined
Aug 21, 2006
Messages
726
Trophies
0
XP
2,149
Country
Philippines
A lot of people have upgraded. I think the fear is due to the sigpatches. You need more sigpatches this time in my experience. I remember having problems with my xci games that I converted to NSP due to having only part of the sigpatches.
 

snoofly

Well-Known Member
Member
Joined
Aug 18, 2015
Messages
1,012
Trophies
0
Age
52
XP
2,082
Country
United Kingdom
Firmware 9.0.1 and Atmosphere 0.9.4 is perfectly fine to use in all cases, save perhaps some esoteric homebrew that was never recompiled with latest libnx to support the controller update.
Sigpatches for 9.0.0 work for 9.0.1, nothing was changed in that regard.
 
  • Like
Reactions: Oracleofire

OkazakiTheOtaku

no thanks, I don't want a custom title
Member
Joined
Jul 20, 2016
Messages
1,460
Trophies
1
Location
127.0.0.1
XP
3,081
Country
Japan
Does 9.0.1 affect compatibility of any homebrew?
No, because Atmosphere MITMs the controller input to make older homebrew work fine. SciresM has expressed that at some point these mitigations will be removed from Atmosphere, but hopefully by that point all of the homebrew affected will have been updated to not need it.
 

Oracleofire

Well-Known Member
Newcomer
Joined
Mar 14, 2009
Messages
91
Trophies
0
XP
681
Country
United States
Firmware 9.0.1 and Atmosphere 0.9.4 is perfectly fine to use in all cases, save perhaps some esoteric homebrew that was never recompiled with latest libnx to support the controller update.
Sigpatches for 9.0.0 work for 9.0.1, nothing was changed in that regard.
No, because Atmosphere MITMs the controller input to make older homebrew work fine. SciresM has expressed that at some point these mitigations will be removed from Atmosphere, but hopefully by that point all of the homebrew affected will have been updated to not need it.
Awesome, all I wanted to know. Thanks!
 
Last edited by Oracleofire,
  • Like
Reactions: OkazakiTheOtaku
General chit-chat
Help Users
    DEMONGreninjaPG @ DEMONGreninjaPG: what?