Any way to edit profile and fake link account?

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by lolboy, Dec 15, 2018.

  1. lolboy
    OP

    lolboy GBAtemp Advanced Fan

    Member
    6
    Jul 16, 2009
    Netherlands
    Did not work for me. Just to be sure I downgraded to 6.1.0 and still nothing. After Switch logo the screen goes black.
    I also tried to whipe-out all data (factory reset) and used the files and no luck.

    Bummer, I have no idea what I am doing wrong.
     
    Last edited by lolboy, Dec 16, 2018
  2. ReikaRin

    ReikaRin Advanced Member

    Newcomer
    2
    Mar 21, 2018
    Indonesia
    maybe the way you are using hackdismount
     
  3. lolboy
    OP

    lolboy GBAtemp Advanced Fan

    Member
    6
    Jul 16, 2009
    Netherlands
    Hmmm I can’t imagine but possible.
    I believe I am doing it right because when I restore the org files, everything starts working again.
     
  4. ReikaRin

    ReikaRin Advanced Member

    Newcomer
    2
    Mar 21, 2018
    Indonesia
    what is org files ? original ?
     
  5. lolboy
    OP

    lolboy GBAtemp Advanced Fan

    Member
    6
    Jul 16, 2009
    Netherlands
    Yes.

    I follow this steps:

    1: Open the backup of my nand in hacdismount (also tried physical device)
    2: Open SYSTEM parition
    3: Insert biskey 2
    4: Click on mount
    5: Manually back SAVE and SAVEMETA folders to desktop
    6: Delete folders from mounted drive
    7: Copy over the the new files with linked account to mounted drive
    8: Click unmount
    9: Shutdown hacdiskmount
    (If edited rawnand.bin I restore the modified nand in hekate, if physical drive then I take no further steps)
    10: Restart Switch and run cfw (hekate)
    11: Switch loads until the logo and goes dark.

    Then I repeat the same steps and put the backup folders (Save, saveMeta) back and when I start the Switch, everything works again.

    I use latest sdfiles(with hekate 4.5).
    Tried on 6.0.1, 6.1.0 and 6.2.0
     
    Last edited by lolboy, Dec 16, 2018
  6. Sumandora

    Sumandora GBAtemp Regular

    Member
    2
    Nov 13, 2018
    Germany
    I think there's a method but idk what this method is.
     
  7. lolboy
    OP

    lolboy GBAtemp Advanced Fan

    Member
    6
    Jul 16, 2009
    Netherlands
    I hope so, it would be very nice.
     
  8. dizne

    dizne Newbie

    Newcomer
    1
    Dec 20, 2018
    United States
    Signed up to say I managed to get this to work it took a while but I'm 6.2 and used it mounting the physical device.
     
    hippy dave likes this.
  9. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Be careful with that, some people have bricked by just mounting the internal NAND on a PC, Windows did its thing and mangled the contents enough for the Switch to brick.
     
  10. dizne

    dizne Newbie

    Newcomer
    1
    Dec 20, 2018
    United States
    I made sure to have NAND backups in place etc prior to starting. I might restore my previous accounts as I did not take full saves I only had a few backed up etc but not sure how fussed as I recreated all the other accounts already.
     
    Last edited by dizne, Dec 20, 2018
  11. ffew

    ffew Member

    Newcomer
    1
    Dec 11, 2018
    United States
    It works, thank you.
    Also it is not necessary to copy all files, 8000000000000010 is enough to transfer linked account (at least for my switch).

    By the way, if you delele 8000000000000090, 8000000000000091, 8000000000000092 from system folder - all news will be deleted from switch.
     
    Last edited by ffew, Dec 24, 2018
    thaikhoa and Psychdelic like this.
  12. helfire

    helfire Newbie

    Newcomer
    1
    Aug 6, 2018
    United States
    Looks like goldleaf 0.2 can copy files from the sdcard to system nand now - might be easier than editing your nand and restoring it.
     
    Bst22322 and cearp like this.
  13. TidusWulf

    TidusWulf Real Aloha

    Member
    5
    Jul 27, 2007
    United States
    Hawaii
    That's pretty neat. Can someone else confirm that using that 6.1.0 save file/folder can be safely copied to a 6.2.0 Switch using goldleaf? I'm too scared to be the one to take the leap, but I know there's a few games I want to play that require a NNID to run, and I don't have one.

    Did you do it on 6.2.0? Are you saying you only copied that one folder, using hacdiskmount, and you now effectively have an NNID?

    Also, I'm looking at \saveMeta\8000000000000010\ and it's an empty folder?
     
    Last edited by TidusWulf, Jan 6, 2019
  14. ffew

    ffew Member

    Newcomer
    1
    Dec 11, 2018
    United States
    my english is not very well, sorry.
    8000000000000010 is a file in system save folder (not meta). I copied it after switch reset (after first launch when you need create user) on 6.2.0 exFAT using hacdiskmount. After this i got someone's profile (you will lose old profile) with linked nintendo account on my switch, everything works without problem (but without reset i got black screen after logo).
    if you don't want lose game saves you must backup it using hacdiskmount (user partition) or using devmenu (or homebrew app) before reset.
     
    Last edited by ffew, Jan 6, 2019
    Jedis likes this.
  15. N3wbs

    N3wbs Advanced Member

    Newcomer
    1
    Feb 10, 2016
    Canada
    In the matrix
    I tried same on my switch 6.1 that doing the same thing of you with my switch .. stuck on logo or black screen and if i put the original backup save and metasave .. allworking again .. i tryed to reset before .. doing something but nothing work
     
  16. lolboy
    OP

    lolboy GBAtemp Advanced Fan

    Member
    6
    Jul 16, 2009
    Netherlands
    Try different cfw that worked for me. Try latest ReinX or Hekate.
     
  17. TidusWulf

    TidusWulf Real Aloha

    Member
    5
    Jul 27, 2007
    United States
    Hawaii
    Well, backing up saves and all that wouldn't be the end of the world I guess... I'd still have to reinstall a handful of games tho.. :/
     
  18. N3wbs

    N3wbs Advanced Member

    Newcomer
    1
    Feb 10, 2016
    Canada
    In the matrix
    That not working with sx os 2.5 with Emunand backup on sd

    I will retry tonight to let work thank for the tip
     
  19. TidusWulf

    TidusWulf Real Aloha

    Member
    5
    Jul 27, 2007
    United States
    Hawaii
    Did you get it to work?
     
  20. dizne

    dizne Newbie

    Newcomer
    1
    Dec 20, 2018
    United States
    For the issue of getting stuck on logo after replacing only 10 / 11 folders, I had to boot CFW first to get a successful boot then I could reboot into OFW without getting stuck I was booting into AMS, hope that helps.
     
Loading...