Any reason to NOT update from 3.2 to 4.1?

Discussion in 'Wii - Hacking' started by pitweasel, Apr 4, 2014.

  1. pitweasel
    OP

    pitweasel Advanced Member

    Newcomer
    69
    0
    Mar 31, 2009
    United States
    I've performed various soft mods over the course of the last five years, and my Wii is pretty much a software Frankenstein at this point. I have to remove the SD card to boot it, USB Loader GX freezes the console on launch, and now the Multi Mod Manager won't install any .wad files (error -2011). All of these are problems that did not exist upon initially hacking.

    Instead of trying to chase down each individual problem, I'd like to use ModMii to just re-hack the console. But one of the first options is "which menu version do you want to upgrade to", with 4.1 being the lowest.

    Is there any good reason that I should pursue each one of my problems one by one instead of simply using MM to upgrade and re-hack?
     
  2. AwesomeMarioFan

    AwesomeMarioFan RiiConnect24 Dev

    Member
    162
    28
    Jun 21, 2013
    United States
    Honestly, the only thing I see different is the available exploits, it's actually easier to hack 4.3U than earlier versions. You also have to make sure you don't install any incompatible system menu themes. In my opinion, at that point I would probably do a fresh reset anyway since system menus under 4.0 don't support transferring channels & saves to/from the SD card.

    If you plan to pursue them one by one:
    - Removing SD Card to Boot: You can probably fix this by Preparing the SD Card again with the HackMii installer, since it is most likely caused by a bad boot.elf on the SD card.
    - USB Loader GX Freezing: You can try updating the version of it, or installing d2x CIOS over your old one, since that one seems to work for me.
    - MMM not installing WADs: Make sure you are installing to IOS36, are sure that CIOS is installed correctly, and that you tried another WAD Manager such as Yet Another WAD Manager.