Hacking Question Any point on staying on 2.3.0 firmware?

AlhazenTheMad

Member
OP
Newcomer
Joined
Apr 27, 2013
Messages
17
Trophies
0
Age
33
XP
172
Country
United States
Should I stay on this firmware, or should I just update to 3.0.0 with my Pokken Tournament DX revision 000? Based on the firmware status guide by Nah3DS, 2.3.0 and 3.0.0 are interchangeable? It also seems as though things are being developed primarily for 3.0.0? Any suggestions?
 
Last edited by AlhazenTheMad,

ihaveahax

Well-Known Member
Member
Joined
Apr 20, 2015
Messages
5,986
Trophies
2
XP
6,943
Country
United States
SciresM has said there is no real point staying on 2.0.0 - 2.3.0 now, so you can update to 3.0.0.
unknown.png
 

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
26
Location
Las Vegas, Nevada
XP
4,386
Country
United States
SciresM has said there is no real point staying on 2.0.0 - 2.3.0 now, so you can update to 3.0.0.
unknown.png
I love that message. Mostly because 4.x "fixable in the long term, but not short term" and then it ends up getting a fix in short term. But otherwise yes that post is good.
Cfw and trustzone will be released for 1.0.0 first, then 2.x-3.0.0, then 3.0.x, and finally 4.x.
 

SoslanVanWieren

Banned!
Banned
Joined
Feb 6, 2017
Messages
1,809
Trophies
0
XP
817
Country
Australia
Idk why they have to delay it on the newer firmwares the exploit already works and its going to get patched anyways. is it just so its fair for people who kept there switches on a lower firmware?
 

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
26
Location
Las Vegas, Nevada
XP
4,386
Country
United States
Idk why they have to delay it on the newer firmwares the exploit already works and its going to get patched anyways. is it just so its fair for people who kept there switches on a lower firmware?
Didn't I already explain why to you (might have been someone else, don't remember)? The Deja vu exploit is the same, but the exploits to privilege escalate enough to access Deja vu are different between them. Along with that the cfw will likely need to be modified to work on each firmware
 
  • Like
Reactions: satan89

Duhasst0

Well-Known Member
Newcomer
Joined
Jul 12, 2015
Messages
91
Trophies
0
Age
38
XP
327
Country
United States
Idk why they have to delay it on the newer firmwares the exploit already works and its going to get patched anyways. is it just so its fair for people who kept there switches on a lower firmware?

No, not at all actually. You want to stay on earlier fw, because bugs get patched out, which is where exploits live. They develop one that works for an early fw wait for a new one and check it against new, check and see if they are patched out. Release if it is, or hold off until is. Then as cfw comes out you update to the lastest cfw until the end of time. But always being behind the ofw to keep access to Homebrew.
 

SoslanVanWieren

Banned!
Banned
Joined
Feb 6, 2017
Messages
1,809
Trophies
0
XP
817
Country
Australia
No, not at all actually. You want to stay on earlier fw, because bugs get patched out, which is where exploits live. They develop one that works for an early fw wait for a new one and check it against new, check and see if they are patched out. Release if it is, or hold off until is. Then as cfw comes out you update to the lastest cfw until the end of time. But always being behind the ofw to keep access to Homebrew.
with the 3ds they relased exploits that weren't even patched yet.
 

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
26
Location
Las Vegas, Nevada
XP
4,386
Country
United States
with the 3ds they relased exploits that weren't even patched yet.
But the 3ds had pretty poor security, and Nintendo didn't have bug bounties set up. Meaning Nintendo usually didn't know about vulns until they were released. Along with that it has hardmod downgrading at the very least, and softmod downgrading before arm9 exploits popped up for latest firmware. The switch has no chance of being downgraded, and with its much tighter (albeit still flawed) security, any exploit could be the last for at least a long time. On top of that bug bounty program makes it so even vulns that homebrew devs don't know about can be patched if others find them first. The switch is a very different beast and the devs would rather play the waiting game to potentially get exploits to last across more firmwares than expend them all in one go.
 

RitchieRitchie

Well-Known Member
Member
Joined
Nov 15, 2013
Messages
787
Trophies
0
Age
48
XP
742
Country
Total noob here so please hate me for being stupid, but don't they have the keys for 1-2.3 fw? It seemed like that was a big thing (not that I really understood it) so wouldn't staying on 2.3 be better?
 

Duhasst0

Well-Known Member
Newcomer
Joined
Jul 12, 2015
Messages
91
Trophies
0
Age
38
XP
327
Country
United States
Total noob here so please hate me for being stupid, but don't they have the keys for 1-2.3 fw? It seemed like that was a big thing (not that I really understood it) so wouldn't staying on 2.3 be better?

Yes, stay low. They have some keys, but not console specific keys.
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
22,047
Trophies
3
Location
Space
XP
11,321
Country
Norway
Total noob here so please hate me for being stupid, but don't they have the keys for 1-2.3 fw? It seemed like that was a big thing (not that I really understood it) so wouldn't staying on 2.3 be better?
That's exactly why 3.0 is better. You can't run 3.0+ games without either having the keys or being on 3.0 (which has the keys built in)
 
  • Like
Reactions: Xyphoseos

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
26
Location
Las Vegas, Nevada
XP
4,386
Country
United States
Total noob here so please hate me for being stupid, but don't they have the keys for 1-2.3 fw? It seemed like that was a big thing (not that I really understood it) so wouldn't staying on 2.3 be better?
Keys only mattered when they didn't have trustzone. Now that they have trustzone sploits, having the keys makes no difference
 
Last edited by TheCyberQuake,

Nkrlz

Active Member
Newcomer
Joined
Jan 7, 2016
Messages
39
Trophies
0
XP
105
Country
Monaco
Apart from the fact that CFW will come much faster to 2.0.0 and 3.0.0, wouldn't it be "better" (in the sense that you can paly more games/play online, until the next update) to update to the latest (4.x something) if they got trustzone hax there?
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: Good morning