Hacking Any old Browserhax and/or oot3dhax experts here? (a9lh related)

smallmedicap

Well-Known Member
OP
Newcomer
Joined
Nov 1, 2015
Messages
66
Trophies
0
Age
54
XP
227
Country
United States
Some of you might remember from my previous thread that I still use a9lh sometimes to test a couple things. So, yes, I am well aware that a9lh is outdated. And that b9s is awesome. Etc. Etc. Just think of this thread as historical purposes.

Anyway.

On old 3DSs while on 2.1.0 I use browserhax by going to http://dukesrg.github.io/2xrsa.html?arm11.bin to execute SafeA9LHInstaller.

This got me wondering what I would do if they stop hosting that URL. So that is my first question:

Can someone tell me what exactly I need to host a mirror of that on my website?

(I tried just saving that page with mozilla and then hosting that... It looked like it was going to work great but when I try it on my 3DS it seems to work but then says "part of the page has failed to load" or something of that nature. I'm missing something I guess.)



I've never had the need over the years to use oot3dhax so I am not familiar with it at all. (Back then I always just used Cubic Ninja.) That leads me to my second question:

Can someone familiar with oot3dhax tell me if I could just use that to execute SafeA9LHInstaller while I am on unhacked 2.1.0?

That way I can bypass browserhax entirely. That would be awesome since then I would not even have to enter Internet Settings. As far as I am aware there was a version 1 of oot3dhax that should do it:

oot3dhax
Version1: 2.0 to 9.2
Version2: 9.2 to 11.4

I'm not exactly sure how to get that Version1. I'm assuming the newest releases are Version2.

I'm going to order a copy of Zelda just to mess around with this. But I assume someone here will know whether or not it should work.


Also, if anyone has any ideas about all of the other various ARM11 Userland exploits that there have been over the years feel free to make a suggestion. (Though I am pretty sure from looking at https://wiki.gbatemp.net/wiki/List_of_3DS_exploits that only oot3dhx Version1 and/or browserhax are the only ones that work on 2.1.0.) Again all I need it for is to execute SafeA9LHInstaller's .bin files.
 

smallmedicap

Well-Known Member
OP
Newcomer
Joined
Nov 1, 2015
Messages
66
Trophies
0
Age
54
XP
227
Country
United States
Ouch.

It seems like I may have asked a tough one!

Or perhaps people who might know are on holiday...

berry xmas everyone

:-)
 

squall14716

Well-Known Member
Member
Joined
May 16, 2011
Messages
1,294
Trophies
0
XP
1,182
Country
United States
I don't know the answer about how to rehost 2xrsa, but you can always install boot9strap, use that to get your otp.bin, include that in the a9lh folder, and launch SafeA9LHInstaller.bin using soundhax+udsploit+safehax on 9.0-11.3.
 
  • Like
Reactions: MrJason005

smallmedicap

Well-Known Member
OP
Newcomer
Joined
Nov 1, 2015
Messages
66
Trophies
0
Age
54
XP
227
Country
United States
Ah, okay that totally makes sense.

I feel like I actually thought of that a couple months ago and it totally slipped my mind since I am so accustomed to the original way.

So instead of going to 2.1.0 to get otp, I can just go to any version where soundhax still worked. Since with b9s I already have otp.

And all I have to do is have otp in the a9lh folder and it won't care if I am not on 2.1.0....

Perfect. Cheers!


(I'd still be interested in information about oot3dhax Version1 if anyone sees this and knows how it works.)
 

mikey420

Well-Known Member
Member
Joined
Dec 11, 2015
Messages
911
Trophies
0
Age
29
XP
483
Country
United States
Can oot3ds run on 2.10? If so it's possible to make that work but if 2.10 is too old for that game where it will ask you to update when you insert the card then no this isn't going to work. As for the web host well the error you received is pretty typical of the browserhax. Did you try it a few times (assuming you have all the correct files in place.)
 

squall14716

Well-Known Member
Member
Joined
May 16, 2011
Messages
1,294
Trophies
0
XP
1,182
Country
United States
Can oot3ds run on 2.10? If so it's possible to make that work but if 2.10 is too old for that game where it will ask you to update when you insert the card then no this isn't going to work. As for the web host well the error you received is pretty typical of the browserhax. Did you try it a few times (assuming you have all the correct files in place.)
It likely depends on whether they updated the update on newer releases of the cart. 2.0/2.1 was the current version when OoT3D was released.
 

You may also like...

General chit-chat
Help Users
    K3N1 @ K3N1: You gonna record in their building