Any news on sxos update

Discussion in 'Switch - Backup Loaders & Modchips' started by mickthestud, Sep 16, 2019.

Thread Status:
Not open for further replies.
  1. Baoulettes

    Baoulettes The lonely man

    Member
    6
    May 25, 2011
    France
    C:\Users\Baoulettes\Desktop\GBATemp
    Some people do have legit games and online sub with :)
    That the main reason I update, to be able to play my mario kart or mario maker.
    And there the lastest FW is always required :)
    Except if you use a weird method to bypass it but I doubt that really safe :P
     
  2. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    Likewise, but it’s ok to update sysnand to 9 to play online.
    Running sx 8.1 on emunand has no drawback presently is what I’m saying, aside from not being able to read your carts.
     
  3. RedHunter

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    Updating will also break autorcm, and for people like me who switch a lot between sysnand and emunand it's not only annoying but also dangerous because you can damage the console always using the jig, also because I'm using a paperclip.
    That's why I'm waiting for the update.
     
  4. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Updating does not break AutoRCM. Its because SX OS does not offer true support for firmware 9.0. You can have AutoRCM enabled with Atmosphere then have SysNAND on 9.0 and EmuNAND on 8.1 with everything working fine.
     
  5. OperationNT

    OperationNT GBAtemp Fan

    Member
    6
    May 1, 2016
    France
    As the FW 9.0.0 contains a cartridge slot update, it probably has an impact on XCI loader support.
    This is maybe why, this time, Team Xecuter cannot simply copy/paste Atmosphere's code... :)
     
  6. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    GC firm update is console wide afaik.
    SX OS Emunand loads XCIs fine on my system which has sysnand 9.0.0 so I don't think there is any need for them to update any code their end to support XCIs going forward.
     
  7. kamesenin888

    kamesenin888 GBAtemp Maniac

    Member
    8
    Oct 20, 2007
    well even the gc is updated on 8.1 emunand, xci still works fine

    for people that are wondering
    if you have emunand on 8.1, you can update your sysnand just fine to play your originals,

    difference between 9.0(emucc) and 8.1 emunand is just the satisfaction of being updated, people be serious, just wait a little to just update to see that you have a 9.0 version and nothing else
     
    Last edited by kamesenin888, Sep 20, 2019
  8. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    One big pro for Atmosphere: You know all those times your console crashes from homebrew, and you have to reboot into OFW only to power off so you can boot back into RCM and inject the payload again? That doesn't happen in Atmosphere. Atmosphere has way better error handling in homebrew, so it won't crash your console, and even if your console does crash for some reason, thanks to Atmo's "reboot to payload" feature, you can get right back into CFW with a press of the power button.
    That was the one thing that made me switch. Trying to install stuff with Goldleaf or Tinfoil and having the system repeatedly crash gets old very quickly when getting back to where I was is such an ordeal.
     
  9. snoofly

    snoofly GBAtemp Advanced Fan

    Member
    8
    Aug 18, 2015
    United Kingdom
    Yeah that IS a great feature of Atmosphere and was actually why I used it quite a bit back along as well, but if you got a trinket it’s not an issue for SX either.
     
  10. KungFuzion

    KungFuzion GBAtemp Fan

    Member
    5
    Feb 5, 2015
    Picked my copy up of Links awakening after work today, enjoying it so far but i've noticed some frame rate drops when moving around. Hope Ninty drops a patch soon which brings me to when sx will drop a update.....??? My sysnand is on 4.0.1 and I dont want to update that. I just like using my emunand. I'm guessing the new zelda update when it arrives will be on 9.X. SX is very quiet lately & makes me wonder if they will even bring 9.x support out.
     
    Last edited by KungFuzion, Sep 20, 2019
  11. fringle

    fringle GBAtemp Regular

    Member
    4
    Apr 16, 2009
    Canada
    I'm not sure if this is the case for everyone. I had an emunand working perfect on 8.0.1 but once the system got updated to 9.0.0 the emunand corrupted and would no longer boot. Not sure what caused it. I also have a non corrupted backup of the emunand 8.0.1 on my pc and that refuses to boot since the update as well. Tried converting to atmosphere and the issues followed. My solution was to start over with a fresh emunand on atmosphere and wait for sx.
     
  12. Zangetsu276

    Zangetsu276 Member

    Newcomer
    1
    May 20, 2019
    Brazil
    I hope it releases soon. My Switch arrived today, and while it's a hackable model, it's on OFW 9.0.0 so I can't do shit with SX OS, for now it's just a useless box.
     
  13. DuveltjeDG

    DuveltjeDG GBAtemp Regular

    Member
    3
    Apr 5, 2019
    Netherlands
    Why not use atmosphere instead? Really weird to wait for something that needs be paid for when there are free options that work better.
     
  14. Zangetsu276

    Zangetsu276 Member

    Newcomer
    1
    May 20, 2019
    Brazil
    It's because I bought SX OS beforehand, but I'm considering to use Atmosphere and when SX OS updates, switch to SX OS.
     
  15. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    Nevermind
     
    Last edited by EmulateLife, Sep 20, 2019
  16. EmulateLife

    EmulateLife GBAtemp Psycho!

    Member
    7
    May 30, 2016
    United States
    Dupe
     
    Last edited by EmulateLife, Sep 20, 2019
  17. CKkio23

    CKkio23 Advanced Member

    Newcomer
    2
    Jun 17, 2018
    United States
    i purchased zelda no 9.0 required playing on my emmunand :)
     
  18. kamesenin888

    kamesenin888 GBAtemp Maniac

    Member
    8
    Oct 20, 2007
    A friend of mine had this problem because he left a game inside, besides that everything is working
     
    fringle likes this.
  19. fringle

    fringle GBAtemp Regular

    Member
    4
    Apr 16, 2009
    Canada
    Interesting. Yes there was and still is a game card inside. Going to give this a try now with my backup emunand. Thanks for the tip. Much appreciated.
     
  20. a2a

    a2a Member

    Newcomer
    2
    Feb 10, 2017
    I will just leave this here — screen cap from TX forums. Itsa’ commin’... justa be patient...

    C01A9C49-7196-4DAE-BF66-6DCD9D02DD82.

    (No direct linky, sorry, as requested by gbatemp mods... but easy enough to browse to and find yourself...)
     
  21. Hayro

    Hayro Advanced Member

    Newcomer
    2
    Oct 17, 2016
    France
    Is it possible to downgrade from 9.0 emuNAND to 8.1.0 emuNAND?
    edit : nvm, I found a way.
     
    Last edited by Hayro, Sep 21, 2019
Loading...
Thread Status:
Not open for further replies.