Any hope for a wiikey update?

Discussion in 'Wii - Hacking' started by shonosuke, May 29, 2007.

  1. shonosuke
    OP

    shonosuke GBAtemp Fan

    Member
    452
    6
    Dec 6, 2003
    Netherlands
    Netherlands
    I want to play bleach and one piece on my pal wii [​IMG]
    There is no modchip/opensource/region patcher that lets you play games like mario party 8 and bleach wii and one piece on a pal console right?
     
  2. jaxxster

    jaxxster The Heretic

    Member
    2,423
    0
    Oct 31, 2006
    South East London
    nope...wont be a patcher. Only way is a modchip that modifies the consoles bios.
     
  3. ih8crouch

    ih8crouch GBAtemp Regular

    Member
    141
    0
    Dec 27, 2006
    didnt an update sort compatability with a few specific games last time? not that i hold any hope of wiikey update happening
     
  4. sekhu

    sekhu moo?

    Member
    1,156
    0
    Feb 14, 2007
    wiikey team would have you believe that those games can be played with their update, but there doesn't seem to be a chance that there will be a working update released. maybe when pigs fly.
     
  5. Darkforce

    Darkforce DERP!

    Former Staff
    2,911
    2
    Nov 5, 2002
    UK
    I hear news that the new PAL Wiikey update will display a message upon bootup that says: 'BUY A NTSC WII AND STOP F**KING WHINING!'

    Honestly, people knew the Wii wasn't going to be region free when it came out so if playing imports was such a big priority why didn't you just import a Wii from abroad in the first place?!

    The Wiikey/Wiinja/Cyclowii etc.. are all based on exactly the same exploit, a first gen method of playing backups... it's not going to be perfect! Nor is it all Wiikeys fault! Exploits have limitations and until a new exploit or discovery is made not much is going to change. So instead of complaining about the few games you can't play, why not be thankful you can already play 100+ games at no cost.

    And for the record Bleach on Wii is pretty 'meh', I don't understand why PAL owners are so desperate to play it!

    [​IMG]
     
  6. Xeijin

    Xeijin GBAtemp Fan

    Member
    495
    0
    Mar 25, 2007
    London, UK
    Coz t3hre all Anime Fanboys!!!!11
     
  7. sekhu

    sekhu moo?

    Member
    1,156
    0
    Feb 14, 2007
    I think for most the biggest gripe about the wiikey is not playing a select few gamecube and wii titles as you state, overall it's not the best chip out of the box, but it does play most of the games for a fair price. and even if you have clone can't really complain. I'm not particularly bothered at the wiikey not getting an update (though I would like to play eternal darkness again) but it's unfair on those that are hanging on the teams every word when it comes to an update only to disappoint them with lack of communication. they haven't been the most professional when it comes to communicating with their customers
     
  8. StacMaster-S

    StacMaster-S GBAtemp Fan

    Member
    367
    0
    Mar 16, 2007
    United States
    Albany, NY
    I am definitely looking forward to the next update, but as of right now there are only two games I can't play on the system, and for the cost of the modchip it is certainly hard to complain!

    Some communication would be nice, but hopefully WiiKey is just making sure the update is extremely solid before releasing it. I know a lot of DS-X owners (like myself) have been horribly burned with their most recent firmware release.
     
  9. Hanafuda

    Hanafuda GBAtemp Advanced Maniac

    Member
    1,912
    698
    Nov 21, 2005
    United States

    I just started researching and it seems most people say it is the best out of the box. What would you recommend over the wiikey? (and why?)
     
  10. jaxxster

    jaxxster The Heretic

    Member
    2,423
    0
    Oct 31, 2006
    South East London
    cyclowiz...Has all the same features but plays every GC game you throw at it. No need to mess about with config disks.
     
  11. Hanafuda

    Hanafuda GBAtemp Advanced Maniac

    Member
    1,912
    698
    Nov 21, 2005
    United States

    doesn't cyclowiz require iso region patching if I want to play a USA game on a japanese console? Not a big deal I've done it before w/ Saturn, but the problem would be all the commercial USA Gamecube games we've got ... need to play them on a japanese Wii. With the Wiikey its just a matter of turning on the regionlock override, but with cyclowiz I'm thinking we'd be SOL.

    please help me with this question, especially if I'm wrong.
     
  12. jaxxster

    jaxxster The Heretic

    Member
    2,423
    0
    Oct 31, 2006
    South East London
    nope, with the cyclowiz you dont have to patch anything...no region override settings either. Just stick in an unpacthed import game in and it does on the fly patching.
     
  13. sekhu

    sekhu moo?

    Member
    1,156
    0
    Feb 14, 2007
    the negative of the cyclowiz is that you have to install a switch to update the cylcowiz, I don't recall what the update did, but iirc the update was important. If you can buy a cylcowiz preflashed with the update then that's your best bet, otherwise go for an open source solution like OpenWii which works better than a wiikey, has dvd updates and so on. Wiikey team messed up the wiikey by not having a working audiofix solution, so it's partially defective out of the box
     
  14. Hanafuda

    Hanafuda GBAtemp Advanced Maniac

    Member
    1,912
    698
    Nov 21, 2005
    United States
    well, I guess if the wiikey update (i.e. subject of the thread) does come along with a proper audiofix then that gripe will be off people's list, although I have to say I'm a big GCN fan and actually have a couple games that are on the "streaming audio" list (Eternal Darkness, WaveRace) and I still don't think its that big of a deal.

    even if I found the cyclowiz preflashed with the update, it would be pretty silly to assume there won't be any more updates in the future ... so wiring in the switch complete with some way of accessing it from outside (without needing to disassemble the whole thing again) would probably be necessary, huh?

    think I'll wait just a little bit longer and see what happens.