Any Guides for Repairing Mega Drive/Genesis v1 Headphone Output?

tech3475

Well-Known Member
OP
Member
Joined
Jun 12, 2009
Messages
3,003
Trophies
1
XP
4,218
Country
I recently hooked up my old MD/MCD/32X but the headphone jack on it is extremely quiet and the volume slider doesn't do anything.

Are there any decent guides anyone is aware of for this type of issue? As I'm struggling to find one?

Thank you.
 
D

Deleted User

Guest
Doesn't the Genesis/Mega Drive have regular audio output through both the RF and AV Connections? You may be better off just using that.
 

tech3475

Well-Known Member
OP
Member
Joined
Jun 12, 2009
Messages
3,003
Trophies
1
XP
4,218
Country
Doesn't the Genesis/Mega Drive have regular audio output through both the RF and AV Connections? You may be better off just using that.

Only in mono, at least on the v1. I’d also need to buy a new patch cable for the 32x to use the AV audio output as my current one uses the headphone jack.
 

tech3475

Well-Known Member
OP
Member
Joined
Jun 12, 2009
Messages
3,003
Trophies
1
XP
4,218
Country
Well, after many months I finally got it open.

As far as I can see, there are no blown caps and after cleaning the volume slider there was no difference. However, after I pushed the contact in a little, the volume did slightly increase and there is now a change in volume while sliding it where there was none before.

This leads me to think that the volume slider is broken, anyone know of any decent guides to either replace the slider or install a bypass?
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
22,129
Trophies
3
Location
Space
XP
11,469
Country
Norway
Last edited by The Real Jdbye,
  • Like
Reactions: tech3475

tech3475

Well-Known Member
OP
Member
Joined
Jun 12, 2009
Messages
3,003
Trophies
1
XP
4,218
Country
So after all this time I have an update, I believe it turns out it was 2 things:
1) The Capacitors coming out of the YM2612
2) The CXA1034 (The amp chip)

I decided to just recap the whole board and have replaced the chip and so far the headphone jack and the RF audio output seem to be working.

I'm going to try reapplying the RetroRGB mod so I have rear audio.
 

tech3475

Well-Known Member
OP
Member
Joined
Jun 12, 2009
Messages
3,003
Trophies
1
XP
4,218
Country
Let me know how it goes as I'd be interested in doing that mod too.

I've just quickly tried it (albeit using a 3.5mm jack not an extension cable) and it seems to work, however, I'm not sure I recommend it.

The main downside is that this is only going through the pre-amp of the CXA1034 (line level?) and on my TV (a cheap Tesco one, only used for projects) it's at 100% before it's close to comfortable.

Perhaps if using a separate sound system it may be better.

Due to the above, I haven't tested the actual audio quality.

I also haven't tested it with the Mega CD since the MD is still in pieces and the MCD is setup with a different MD in the 'tower of power'. So I don't know if the sound will still be distorted like it was before.

One thought I've had is to maybe 'convert' the front headphone jack to rear (desoldering the connector and soldering in the cables for the rear) or just tapping into the headphone jacks pins, but I don't know how 'safe' that might be for the console.

For now I think I'm just going to finish up and leave things as they are (i.e. working), maybe revisiting it another day.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: https://youtu.be/VfCYZ3pks48