Always the latest versions of cfg-loader-mod and nintendon-t!

Discussion in 'Wii - Backup Loaders' started by SwedishGojira, May 13, 2014.

  1. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    I have set up a build server for homebrew at http://homebrew.svalas.net.
    So far I have builds of "cfg-loader-mod" and "nintendon-t" (both normal and UStealth-enabled). The sources are checked, and built if updated, every third hour. Enjoy!
     
    siFippo, Lemzy101, worm28 and 2 others like this.


  2. WiiFreasko

    WiiFreasko GBAtemp Regular

    Member
    100
    30
    Jan 8, 2013
    Thailand
    the nintendont dol size is 3k larger than the one I have!
    Are you using the latest Devkit to compile?
     
  3. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    I'm using devkitPPC r26, libogc 1.8.10 and libFAT 1.0.10 (and Maxternals libFAT mod for UStealth support). Also I'm compiling on Linux if that matters.
     
  4. WiiFreasko

    WiiFreasko GBAtemp Regular

    Member
    100
    30
    Jan 8, 2013
    Thailand
    ok thanks, that makes sense now because the official dol is made with devkitPPC 27
     
  5. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Yes. I had trouble building cfg-loader-mod using r27 so I had to stick to r26 to be able to use the same buildsystem for them both. I might set up different ones for them in the future though as it is pretty easy to just symlink the version of devkitPPC you want before you build.
     
  6. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Just for kicks... could you check out my updated files from the site and compare it to the official dol. I have rebuilt it with devkitPPC r27 and was curious if there's any difference.
    I'm not at home so I can't do it myself at the moment.
     
  7. WiiFreasko

    WiiFreasko GBAtemp Regular

    Member
    100
    30
    Jan 8, 2013
    Thailand
    me neither :P, will check later
     
  8. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    I have now changed my build scripts for nintendont so they make complete .zip-files ready to unpack to your SD-card with everything needed to run including the font files. Get the latest revision from my website :)
     
  9. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,097
    4,492
    Jan 17, 2013
    Mexico
    One question,
    How can I make the latest version of Nintendont compatible with UStealth?
    Can you help me out on what I need to compile it for myself?
     
  10. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    ı guess you figured this out already as you have posted your MOD.
     
  11. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,097
    4,492
    Jan 17, 2013
    Mexico
    Haha yeah one step ahead now.
    Thanks anyway!
     
  12. worm28

    worm28 GBAtemp Advanced Fan

    Member
    686
    128
    Jun 2, 2013
    United States
  13. jamallego

    jamallego Newbie

    Newcomer
    6
    0
    Sep 10, 2014
    Colombia
    thanks for the link
     
  14. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Thank you for noticing! I'm not really sure why this did happen.
    Right now I use a script to check if a new version of cfg-loader is available and it somehow failed at detecting the version number pf the source. I am going to move improve this process to be the same as for nintendont soon and hopefully it won't happen again.
     
    worm28 likes this.
  15. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    I have now moved the build system for cfg-loader-mod to the same method used for nintendont.
    I won't know for sure if it works correctly until next time it needs to build cfg-loader-mod if it really works or not, but it should.
    Just shout out if you guys notice something wrong ;)
     
    xavix likes this.
  16. worm28

    worm28 GBAtemp Advanced Fan

    Member
    686
    128
    Jun 2, 2013
    United States
    Hey swedishGojira just thought i would let you know that your website http://homebrew.svalas.net. is not building a new version of nintendont also when i download cfg usb loader there is only one boot.dol in the pack there is no Ustealth.dol
     
  17. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Thank you for notifying me of that! There was a small error in my build script from when I changed the build method for cfg-loader-mod to the same system I use for nintendont. Unfortunately there had not been any updates for cfg for a while or I would have noticed this sooner.
    When you posted this I was already on my way to Singapore to visit my GF so I've been busy. Now it is fixed though and an updated build has been posted on my site.

    BTW. Have anyone tried to use the new update-function on my Ustealth builds of nintendont? I have modified the source to update the dol from my site instead of the default one so you will not lose Ustealth functionality. But I have not been able to try it out yet myself.
     
  18. shoemaker

    shoemaker GBAtemp Regular

    Member
    121
    42
    Jul 22, 2014
    United States
    Another error that has come up: r206 and r207 UStealth versions do not include the boot.dol file.
     
  19. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Sorry guys, but this seem to be a new build error related to multidol loading. I'm guessing those building on Windows can still build, but I get error message on my linux build system.
    I have no Idea how to fix this unfortunately. You guys will just have to wait until someone looks at the source and corrects it. :(
     
  20. SwedishGojira
    OP

    SwedishGojira Advanced Member

    Newcomer
    63
    17
    Mar 14, 2009
    Sweden
    Please Download the r208 UStealth build from my site and report if it is working properly.
    I have made a crude workaround and now it builds, but I have no way of knowing if it is actually working.