All USB loaders now freeze at installing a backup

Discussion in 'Wii - Backup Loaders' started by DrDean, Sep 9, 2012.

  1. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    This is a recent issue I've had. My games have backed up perfectly before, but upon installing them they usually just freeze in USB Loader GX and WiiFlow. Silent Hill Shattered Memories always freezes at 1.48%, Xenoblade Chronicles freezes around 0.54%, etc. I am fairly certain this is because I've tried to make my Wii play Gamecube games using DIOS MIOS and installing the WAD for it has messed something up some how, as it's the only thing that has changed since the last time I attempted to backup a game. It also does not appear to be these specific games; trying to reinstall a game I've installed previously also freezes at an early point. Is there a way to uninstall DIOS MIOS and return to my original MIOS? Would reinstalling WiiFlow and USB Loader GX help? Thanks in advance.
     
  2. chop

    chop GBAtemp Fan

    Member
    487
    20
    Apr 14, 2010
    Pontefract
    You remove Dios-Mios by reinstalling MIOS10. you can get it from ModMii,
     
  3. shanefromoz

    shanefromoz GBAtemp Advanced Fan

    Member
    966
    34
    Jun 18, 2007
    yes but i think what he is saying it thats it a bug and needs to be fixed.
     
  4. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    Installing the MIOS10 wad from ModMii didn't seem to work. Games still freeze at install. Only difference is that Shattered Memories is freezing at 1.45% now instead of 1.48%. I guess I must have messed something else up. Dang. :(
     
  5. chop

    chop GBAtemp Fan

    Member
    487
    20
    Apr 14, 2010
    Pontefract
    Have you tried playing your games from the disc channel, perhaps your laser has gone.
     
  6. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    Games from the disc work fine.

    It's okay if installing from disc doesn't work, I suppose. I could always just rip the disc to my PC and do it that way; it just takes a lot longer.
     
  7. PsyBlade

    PsyBlade Snake Charmer

    Member
    2,204
    254
    Jul 30, 2009
    Gambia, The
    Sol III
    My guess would be filesystem corruption or (less likely) hardware damage

    somethings to try

    -scan the FS for errors to rule out nr. 1

    -try filling to 100% witth a pc (since it can choose a different location to write to
    -run a nodestructive read/write test (eg with "badblocks -vns" iirc)
    -check the SMART data of the drive (eg with smartctl)
     
  8. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    How would I go about scanning the filesystem?

    Games already on the drive also still run fine.
     
  9. PsyBlade

    PsyBlade Snake Charmer

    Member
    2,204
    254
    Jul 30, 2009
    Gambia, The
    Sol III
    wbfs:
    wiimms wwt

    other on windows:
    rklick drive, preferences(iirc), scan for errors
    or chkdsk on console

    other in linux:
    fsck
     
  10. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    That didn't work. It did say that there was a file system error, but it had fixed it, and didn't say anything about it again after scanning after that. I've tried multiple games and they still freeze. WiiFlow gets a crash screen immediately trying to install a game, and USB Loader GX does the freezing. Configurable USB loader also freezes.

    Do you think re-homebrewing it would work?
     
  11. PsyBlade

    PsyBlade Snake Charmer

    Member
    2,204
    254
    Jul 30, 2009
    Gambia, The
    Sol III
    just that there was a problem with the FS does not mean that the HW is good
    you need to check that too
    run badblocks or wharever the windows guys use instead
     
  12. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    6,042
    2,517
    Jan 14, 2012
    Ideas factory :)
    Try cleanrip
     
  13. DrDean
    OP

    DrDean Newbie

    Newcomer
    8
    0
    Sep 5, 2012
    Canada
    Hm, it does appear to be the drive and not any of my loaders. I tried a USB thumbstick I had and all my loaders worked fine with installing a game onto it.

    I did something stupid the other day and unplugged the drive while it was checking for bad blocks. Now it doesn't want to check for them again, or tell me if the file system is clean. However, I think I will try to format the drive and spend an afternoon replacing the games on it. I'll update if that works.

    Update: Yeah, reformatting it seems to have worked. Sloppy and heavy handed, but it worked. :P Thanks for all the help, guys.
     
  14. Ntbear

    Ntbear Newbie

    Newcomer
    1
    0
    Jul 3, 2013
    Reformat didn't work for me. All backups freeze at <2% with usbloadergx or wiiflow.

    Discs play fine, tried several different usb disks, some ntfs, some fat32, always a freeze.

    Had an ancient softmod, i recently ran hackmii on top of it and installed all the wads it gave me, hadn't tried backups before that.
     
  15. Carmanfan316

    Carmanfan316 Newbie

    Newcomer
    1
    0
    Sep 22, 2013
    United States
    Taylor, Michigan
    I'm dealing with the same issue. So any info would be helpful. I am using a 16 GB flash drive.