All of my photos have corruped :(

Discussion in 'Computer Games and General Discussion' started by moozxy, Sep 5, 2008.

Sep 5, 2008
  1. moozxy
    OP

    Member moozxy hamboning

    Joined:
    Jul 22, 2007
    Messages:
    1,466
    Country:
    United Kingdom
    I keep all my photos I take on my external harddrive and I went to look at some just now but they wont open and I get an error msg of:
    "The archive is either in unknown format or damaged" and also the Winrar alert telling me to buy it after the 40day trial pops up...

    The whole of my summer photos have gone [​IMG]
    Is there a way to recover them?
     
  2. Doomsday Forte

    Member Doomsday Forte GBAtemp Maniac

    Joined:
    Apr 22, 2007
    Messages:
    1,272
    Country:
    United States
    Shot in the dark, but what's the extension of your archives? I'm presuming that after 40 days, WinRAR semi-locks down, and you'll only be able to open .ZIP and .RAR files with it. I could be wrong.

    If you are using .ZIP or .RAR for your archives, I'd try opening the file elsewhere on another computer if possible. Or, try to get the full version of WinRAR and try again.

    Apart from that...well, I have no idea, honestly. =\
     
  3. moozxy
    OP

    Member moozxy hamboning

    Joined:
    Jul 22, 2007
    Messages:
    1,466
    Country:
    United Kingdom
    They're all jpgs :/

    Posts merged

    Also I can see them all as thumbnails but cant open them.
     
  4. BiscuitBee

    Member BiscuitBee Semi-Resident Cookie-Bug

    Joined:
    Jul 30, 2008
    Messages:
    689
    Location:
    Canada
    Country:
    Canada
    [​IMG]

    There are some rar repair programs out there... actually, I think WinRAR has one built-in...

    Also, try opening them with the free 7zip program (which is pretty comparable to in winRAR these days).
     
  5. BiscuitBee

    Member BiscuitBee Semi-Resident Cookie-Bug

    Joined:
    Jul 30, 2008
    Messages:
    689
    Location:
    Canada
    Country:
    Canada
    ...Well, that's odd....

    Try dragging a file into Firefox/Internet Explorer or opening them with an image editing program (paint, photoshop, paintshop pro, picasa)
     
  6. Doomsday Forte

    Member Doomsday Forte GBAtemp Maniac

    Joined:
    Apr 22, 2007
    Messages:
    1,272
    Country:
    United States
    Hmm...the fact that you can still see them in thumbnail form is odd. What all do you have in terms of graphics programs that can open .jpgs? Paint, Photoshop, Paintshop Pro, Nero PhotoSnap, hell, maybe even Firefox could do it. I'm assuming you're trying to open them and your computer defaults to using Windows Picture and Fax viewer or whatever. Try it in any or all of those above, and if nothing works, then I have absolutely no idea what you can do. =\

    Edit: Damn you BiscuitBee! ;_;
     
  7. BiscuitBee

    Member BiscuitBee Semi-Resident Cookie-Bug

    Joined:
    Jul 30, 2008
    Messages:
    689
    Location:
    Canada
    Country:
    Canada
    Jinx! You owe me a coke [​IMG]
     
  8. moozxy
    OP

    Member moozxy hamboning

    Joined:
    Jul 22, 2007
    Messages:
    1,466
    Country:
    United Kingdom
    Ok, wtf they open with Firefox..
    I'll try on paint and photoshop now.

    EDIT:
    Works...

    Eh soo it's just something to do with Windows Photo Gallery? :/
     
  9. Doomsday Forte

    Member Doomsday Forte GBAtemp Maniac

    Joined:
    Apr 22, 2007
    Messages:
    1,272
    Country:
    United States
    Yeah yeah...;P Make your way south a bit and perhaps I'll do just that. Ahaha.

    If the pictures are opening in anything but WinPFViewer, either the program is screwed up, or it could be your external drive. To be safe, move your pictures temporarily and see if anything else screws up on the drive. You can never be too sure, you know?
     
  10. moozxy
    OP

    Member moozxy hamboning

    Joined:
    Jul 22, 2007
    Messages:
    1,466
    Country:
    United Kingdom
    Might not have anything to do with this but I think the photos wouldn't open after I had defragged the HDD.
     
  11. BiscuitBee

    Member BiscuitBee Semi-Resident Cookie-Bug

    Joined:
    Jul 30, 2008
    Messages:
    689
    Location:
    Canada
    Country:
    Canada
  12. moozxy
    OP

    Member moozxy hamboning

    Joined:
    Jul 22, 2007
    Messages:
    1,466
    Country:
    United Kingdom
    Eh weeeeiiirrrdd
    I put the default to Windows Photo viewer and they're working now..
    Looks like it got changed to Winrar to some strange reason >_>
     
  13. BiscuitBee

    Member BiscuitBee Semi-Resident Cookie-Bug

    Joined:
    Jul 30, 2008
    Messages:
    689
    Location:
    Canada
    Country:
    Canada
    Yay! Glad it's all working again!

    ... now, burn some DVDs so you have two copies of your photos ALL THE TIME [​IMG] I try to do this every month.

    EDIT:
    ... and I usually fail due to being lazy. My last backup is from the beginning of the summer.
     

Share This Page