All of my legitimately purchased games are gone (Fixed)

Discussion in '3DS - Flashcards & Custom Firmwares' started by Woodchuck, Jan 18, 2016.

  1. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    My NANDS are unlinked, and when I go into emuNAND all of my titles just vanished, except for legit CIAs that I installed with FBI, illegit CIAs, and system titles. It happened when I tried to update YouTube on emuNAND. They don't show up under HANS or SDVT, and they can't be booted with DevMenu.

    But my SD card still has the same amount of free space, so they must still be on the SD card.
    EDIT: Fixed, just make a new backup, format emuNAND, link NNID, and restore your emuNAND backup.
     
    Last edited by Woodchuck, Jan 22, 2016


  2. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    And I get an error when going into the eShop, so I cannout check if I can redownload them :(
     
  3. Hero-Link

    Hero-Link Hero of Derrr

    Member
    1,188
    56
    Nov 6, 2002
    Portugal
    N3DS? O3DS?

    emunand version? cfw you are using? need more info to help :P
     
  4. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    rxTools, sysNAND 9.2, emuNAND 10.3, old 3ds.

    have a backup of my SD card so I am going to see if it works with that
     
  5. shinji257

    shinji257 61396C68206D61737465722072616365 :3

    Member
    325
    27
    Apr 9, 2007
    United States
    What error do you get when accessing eshop?
     
  6. thaikhoa

    thaikhoa GBAtemp Maniac

    Member
    1,146
    331
    Sep 16, 2008
    You need to sign in your NNID on the two nands in order to access eshop on emunand. I think that you've formatted emunand without backing up your sdcard or system format sysnand to unlink without removing the sdcard.
     
  7. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    Oh, the eShop part I didn't do.

    But I had my SD card out when formatting sysNAND and made an SD card backup and restored it while making emuNAND
     
  8. the assaf

    the assaf GBAtemp Fan

    Member
    480
    154
    Jun 2, 2013
    You must have a problem with your NNID. I had this problem few days ago, and I formatted my emunand and system to delete all NNID from my system and I set it back. If in system settings-software management you see your titles in grayscale with x, that is the problem
     
  9. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    Happened to me.
    After i unlinked my nands,
    for some reason my sysnand cloned itself into the folder of my emunand.
    See in your Nintedon3DS Folder if you have cloned folders?
    i made sure it was a clone folder, deleted it, and all my games showed up again on emunand

    Also backup again before deleting anything if there are possible clone folders (just in case)
     
    Last edited by LeSpaz, Jan 18, 2016
  10. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    Right now I am restoring my old 3DS folder from my SD card backup(basically the same thing), so hopefully this works. Thanks!
     
  11. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    from your backup you only have two folders with random strings of text yeah?
    and each one should only have a single folder each
     
  12. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    Yes, but I also have a "Private" folder from my Wii or maybe DSi, but that's been there always and I never had problems with it.
     
  13. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    Wait, now I have three. How can I tell which one I have to delete?
     
  14. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    you've already rebuilt your db databases correct?
     
  15. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    I have restored my backup with the right dbs, but now there is three folders. Probably because that backup was when I had linked NANDs?
     
  16. Vanth88

    Vanth88 Private

    Member
    744
    200
    Oct 1, 2007
    United States
    Florida
    I had an issue earlier where I couldn't access saves, backup saves, or previous titles yet everything else was fine like it showed my name, profile, friends list, etc. The problem is your emunand is using a different profile ID so you can't use those games, or saves.

    What you'll want to do is... well it's actually rather simple. Make sure you have your original sysnand backup (Nand.bin), place that file in the root of your SD card. Also be sure to have a backup of your original Nintendo 3DS folder which includes the folder with all of those games and stuff, and have EmuNand9.

    First you probably want to fix that eshop error so go to system settings and format your 3ds from within emunand. This won't delete everything but it will wipe out the profile.
    After that login to NNID from within Emunand and once you've logged in and everything's working as it should, restart the 3DS and load EmuNand9 from sysnand.
    You'll want to find the option Clone Nand.bin to Emunand, and select that. It'll replace emunand with your original nand backup.
    After that DO NOT REBOOT INTO EMUNAND, take the SD card out (or use ftp from HBL in sysnand) and make sure to copy over the original intendo 3DS folder with your profile and stuff.
    Finally load up Emunand and you'll find everythings there. Be sure to update again to 10.x.
     
    Last edited by Vanth88, Jan 18, 2016
  17. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    But they worked on emuNAND when they were unlinked earlier.
    EDIT: And if I format emuNAND my SD card contents will be wiped, right?
     
  18. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    Well your sysNAND will be the one that didn't have a dbs folder in it since thats the one that was formatted.
    what happened with my problem,
    For some reason the sysnand folder (had alll the same text) was INSIDE my emunand folder.
    Probably happened during emunand installing or something.
    Taking that folder out of the emunand folder solved my problem that was similar to yours.
    Cant guarantee if this same thing happened tho.
     
  19. Vanth88

    Vanth88 Private

    Member
    744
    200
    Oct 1, 2007
    United States
    Florida
    You probably missed a step, or something happened. If you go into Nintendo 3DS and there's 2 different folders then you're using a different ID.
     
  20. Woodchuck
    OP

    Woodchuck Advanced Member

    Newcomer
    59
    13
    Jan 17, 2016
    United States
    Yes, but the ID with my purchases working was emuNAND, sysNAND had the different ID with no purchases.
    I have two folders that have a folder inside that is the same name, and one that has one with a different name. All three folders have only one folder inside of it, and one of them has a few folders inside of that one, and the other two have one folder inside of the subfolder.