All demos turned into black squares after installing FBI

Discussion in '3DS - Homebrew Development and Emulators' started by darien95, Feb 4, 2017.

  1. darien95
    OP

    darien95 Newbie

    Newcomer
    8
    0
    Mar 14, 2009
    United States
    I recently installed FBI on my 11.2.0.35U Old 3DS. Since I use a 2GB SD card, I had to backup many of my normal 3DS files to make space for everything. After installing FBI and restoring the original files to the SD card, all the demos I had suddenly appeared as gifts, and when I opened them they were black squares. Each demo still states how many times I've played it, but when I try to play one of the black square demos, I get a message saying the sd card was removed. I've tried two different SD cards with the same issue. I also restored my NAND that I had from before installing FBI using dgtools, but I still have the same issue, although FBI is gone. How can I get the demos to display properly and run as they used to?
     
  2. Robz8

    Robz8 Coolest of TWL

    Member
    6,808
    2,874
    Oct 1, 2010
    United States
    Most demos don't contain save data, so you can re-install them.
     
  3. darien95
    OP

    darien95 Newbie

    Newcomer
    8
    0
    Mar 14, 2009
    United States
    I forgot to mention I have some save data on a couple of them that I'd like to keep. Is there a way I can restore those without re-installing?
     
  4. Skyshadow101

    Skyshadow101 The Sky Is The Limit!

    Member
    924
    318
    May 22, 2016
    United States
    The Underground
    JKSM is probably your best bet. Install it and try to back up the saves through there. If you can't, try creating a save-data backup through system settings, then reinstall the demo and restore it in system settings.

    JKSM would be far easier though.
     
  5. darien95
    OP

    darien95 Newbie

    Newcomer
    8
    0
    Mar 14, 2009
    United States
    On JKSM, there is one item that shows as three question marks, which I don't know if it's a demo or not, and when I try to export the save from it, it says error opening save archive. In the system settings save-data backup, they seem to be there as question marks, but when I try to back one up, it says there is no save data that can be backed up.

    The e-shop offers the repair option, and says they need to be repaired and the saves won't be deleted, but as it soon as it starts downloading I get error code 007-7120, which requires me to delete them, and re-download them, losing the save data.

    Would completely removing the hacks from my 3DS make them work again? Or what could've caused them to be corrupted that I can reverse?
     
  6. darien95
    OP

    darien95 Newbie

    Newcomer
    8
    0
    Mar 14, 2009
    United States
    So I found a way to solve this. First I found the demos on my sd card in the Nintendo 3DS\ac3c5e13a1efb7883b08814dc916b46d\title\00040002 directory that have a data folder with a .sav file in them and backed up the .sav files. Then I deleted all the question marks in system settings so I could re-download the demo from the e-shop and have it run as normal, and after re-downloading the demo from the e-shop I replaced the new .sav file with my original one. And that enabled me to use my original saves on the newly downloaded demos.
     
    Last edited by darien95, Feb 4, 2017