AKAIO 1.5 update WITH DSi FW 1.4 - NOOB question

Discussion in 'Acekard' started by rudyl01, Sep 23, 2009.

Sep 23, 2009
  1. rudyl01
    OP

    Newcomer rudyl01 Newbie

    Joined:
    Aug 27, 2009
    Messages:
    9
    Country:
    United States
    Hello All-

    Pretty new to the world of AK2i, I, like many others switched over from R4 - my question is this, and I know it's been asked, but a clear cut answer seems hard to come by - it's absolutely great to have all of this knowledge here in the forums, along with folks willing to share it, so please bear with me here - I have read the threads and it's hard to discern the clear answer when there's so many people offering up answers, so here goes..............

    My AK2i is currently working on the DSi WITH the AK 1.4 fix - in other words, the DSi firmware has been upgraded to 1.4 - IF I wanted to use the AKAIO 1.5, could I? And if so, how does one go about it? From what I read on setting up AKAIO, the first thing it reads is "format the micro SD card"........wouldn't that wipe the AK 1.4 fix off? Everything from there is pretty straight forward I think..........follow the steps and it should work, right?

    Any and all answers welcomed! Thanks!
     
  2. italianmod

    Newcomer italianmod Advanced Member

    Joined:
    Apr 22, 2009
    Messages:
    89
    Country:
    United States
    Just install it the same way you did with AKAIO 1.4.1, download it and put contents into the root of your microSD.

    Formatting is just for when you first setup your microSD.
     
  3. rudyl01
    OP

    Newcomer rudyl01 Newbie

    Joined:
    Aug 27, 2009
    Messages:
    9
    Country:
    United States
    Thanks for the quick response - just so that I'm straight, even though I have the AK2i 1.4 fix, I do NOT have to remove THAT in any way, just simply install AKAIO 1.5?
     
  4. antonkan

    Member antonkan GBAtemp Maniac

    Joined:
    Jun 13, 2009
    Messages:
    1,063
    Location:
    Burlington, ON
    Country:
    Canada
    Just delete the existed _aio folder and akmenu4.nds on the root of your SD card and place the new one.
     
  5. italianmod

    Newcomer italianmod Advanced Member

    Joined:
    Apr 22, 2009
    Messages:
    89
    Country:
    United States
    Think about it like this. The acekard has firmware which is what makes it work. Then there is the operating system which is either what you download from the acekard site or AKAIO. It is called firmware but that is not exactly the right name for it. The 1.4 fix changed the firmware of the acekard. The AKAIO update is just an operating system.

    Its the same thing as updating Microsoft Windows to the new version, you are not changing the computer, just the operating system.

    I hope I didn't confuse you more.

    Also antonkan is right, delete those files first, I forgot to mention that.
     
  6. striderx

    Member striderx GBAtemp Regular

    Joined:
    Jun 16, 2007
    Messages:
    238
    Location:
    USA
    Country:
    United States
    I'm with rudyl01, the posters in these forums have yet to give a clear answer to his question... the same one that I have. I'm pretty sure I know what I need to do, but I'd just like someone with greater intimate knowledge of this card and the code that powers it to offer a polite, comprehensive answer. Compared to the early R4 community and the current CycloDS community, the Acekard community seems to either relish torturing the n00bs or are just indifferent. Neither approach is useful.

    So, to futher clarify italianmod's explanation (thanks for trying) of the "firmware"... The Acekard2i has some rewritable storage on the card itself which was modified by the Danny Phantom DSi Firmware 1.4 fix.You did this by putting an .nds file on your Acekard2i and running it. When executed, this file had the ability to overwrite the existing AceKard2i firmware with a version that was compatible with DSi Firmware 1.4. If you've ever flashed the BIOS on your PC then this is the same thing for the AceKard2i.

    There are two files that can do this -- ak2ifw_update_14_DSL.nds and ak2ifw_update_14_DSi.nds.

    ak2ifw_update_14_DSi.nds can be run on a DSi, but ONLY before updating the DSi firmware to 1.4. Once you do this the card will work on a DSi with firmware up to 1.4. Whether it will still work with DSi firmware beyond 1.4 can't be predicted. It's likely Nintendo will do their best to break flashcard compatibility with every firmware release.

    If you update the DSi firmware to 1.4 before updating the AceKard2i firmware, then you're stuck. The DSi can't launch the AceKard2i to run the .nds file. But there's another way to do that.

    ak2ifw_update_14_DSL.nds can be run on a plain DS (phat or lite) and it can also update the firmware on the AceKard2i. If you updated the DSi firmware to 1.4 before the AceKard2i firmware then this is your only option. You need to use a DS to update the AceKard2i firmware. You can't use a DSi at FW 1.4. The ak2ifw_update_14_DSL.nds file can also update multiple Acekard2i's in succession.

    Now none of what I've been describing has anything to do with the AKAIO software that was just released or any prior version. As italianmod described it, this is like the operating system of the card. Users and developers of earlier cards made the tactical error of referring to this software as firmware. Technically it isn't. An R4 has firmware but it can't be replaced by running an .nds file from the microSD card (at least not the first ones, I don't know about the swarms of zombie R4 clones that are out there). If I understand the situation correctly, the Danny Phantom firmware that fixed the AceKard2i for DSi FW 1.4 surprised a lot of people because the community didn't think firmware on any current Slot-1 card could be updated from the microSD card. Most expected only those cards that used a DS cartridge to USB device could do that (the Supercard DSonei is one that can do this).

    Anyway, the AKAIO software remains on the microSD card and is confined to just that card. If you want to use AKAIO 1.4 and AKAIO 1.5, then go ahead. Just load them on separate cards and switch between them at will. From an AKAIO standpoint, the AceKard and the DS/DSi only knows what's on the microSD card. The only thing the Danny Phantom firmware does is permit running on a DSi with firmware 1.4. It neither adds nor removes any inherent functionality.

    Formatting your microSD will do nothing to the 'firmware' because it's not on the microSD card.

    Sorry for the long post. I needed to get that out both for myself and the suffering n00bs I see in these fora. I hope it helps. If I got any of the details wrong, please let me know.

    striderx
     

Share This Page