akaio 1.5 no longer setting modified time on saves with ak2?

Discussion in 'Acekard' started by Shaxy, Sep 23, 2009.

  1. Shaxy
    OP

    Newcomer Shaxy Newbie

    Joined:
    Feb 3, 2008
    Messages:
    3
    Country:
    United States
    Anyone know about this? On the AK2 with AKAIO 1.4.1 proper and the 5/30 loaders whenever a game made a change to a save file, the "modified time" for the save file would change to the time that it was changed. I'd been using this modified time as a basis for backing up my save files.

    With AKAIO 1.5 and either the 9/22 or 9/23 loaders the save files seem to be missing a modified time completely. Looking at any save file changed with AKAIO under Windows shows a blank spot for the modified time area. Looking at the save files inside AKAIO's file properties window shows all these saves with the modified time of "1979/11/30 04:41:49(GMT)".

    Testing AKAIO 1.5 on my AKRPG though, that still sets the modified time correctly so it's just the AK2 that has this issue.
     
  2. Rascal

    Member Rascal GBAtemp Fan

    Joined:
    Apr 23, 2008
    Messages:
    429
    Country:
    United States
    Definitely a new bug. On my AK2i, there is NO DATE at all. I will go report the bug at the AKAIO forums.
     
  3. zero383

    Member zero383 GBAtemp Advanced Fan

    Joined:
    Apr 4, 2009
    Messages:
    649
    Location:
    Vancouver - #1 City in Canada
    Country:
    Canada
    With AKAIO 1.4.1 and my AK2i it never updated the date/time either. What program are you using to backup your saves? I use Microsoft SyncToy and there is an option to "check file contents" which essentially compares the file data instead of just looking at the modified time.
     
  4. Rascal

    Member Rascal GBAtemp Fan

    Joined:
    Apr 23, 2008
    Messages:
    429
    Country:
    United States
    The last loaders, dated 6/1/09, for AKAIO 1.4.1 actually DID update the date/time of SAV files. Since I'm using a Mac, I'm using a custom RSYNC script to backup my uSD. RSYNC is copying the undated SAV files, but I actually use the date/time to know which SAV files I need to restore to my retail carts on a monthly basis.
     
  5. Chris_Skylock

    Member Chris_Skylock GBAtemp Advanced Maniac

    Joined:
    Dec 26, 2008
    Messages:
    1,501
    Location:
    Philippines
    Country:
    Philippines
    no date bug here. shows updated date. i wonder what's your problem.

    Using AKAIO 1.5
     
  6. syko5150

    Member syko5150 GBAtemp Syko!

    Joined:
    Apr 25, 2009
    Messages:
    3,091
    Location:
    California
    Country:
    United States
    I'm not experiencing this problem with my acekard i have AKAIO 1.5 with the 9/23 loader and the modified date/time on my saves still show.
     
  7. Rascal

    Member Rascal GBAtemp Fan

    Joined:
    Apr 23, 2008
    Messages:
    429
    Country:
    United States
    Not just me having the problem. So the two of you are saying that SAV files for games that you've played after upgrading to AKAIO 1.5 are updating their modified dates?
     
  8. syko5150

    Member syko5150 GBAtemp Syko!

    Joined:
    Apr 25, 2009
    Messages:
    3,091
    Location:
    California
    Country:
    United States
    yup before using AKAIO 1.5 i reformatted my microsd with Panasonic SD Formatter then installed the AKAIO 1.5 files.
     
  9. Shaxy
    OP

    Newcomer Shaxy Newbie

    Joined:
    Feb 3, 2008
    Messages:
    3
    Country:
    United States
    Hmm... well the hardware involved is probably important too. The AKRPG updates the time with 1.5 (and everything else... AKRPG has always updated the time for me), just not my AK2. What hardware are you all using? I'm using an AK2 (green PCB) on a NDS lite.
     
  10. Rascal

    Member Rascal GBAtemp Fan

    Joined:
    Apr 23, 2008
    Messages:
    429
    Country:
    United States
    I'm using an AK2i HW:81 on a DSi running Nintendo firmware 1.4.
     
  11. syko5150

    Member syko5150 GBAtemp Syko!

    Joined:
    Apr 25, 2009
    Messages:
    3,091
    Location:
    California
    Country:
    United States
    idk it works fine for me i have 1.5 AKAIO on a Red Japanese DSi i dont have 1.4 firmware though since i can careless about anything the DSi has to offer at this point and time...
     
  12. Leonidas

    Member Leonidas GBAtemp Fan

    Joined:
    Aug 27, 2009
    Messages:
    479
    Location:
    sLOVEnia
    Country:
    Slovenia
    I have the same problem, the date inside Ak2i is exactly the same as yours (1979/11/30 04:41:49), but on my PC the file date is shown like 1.1.1985 for some reason, so there is definitely a mess up with timestamp somewhere. Regardless, I've posted this in the official 1.5 release thread as well, and so far about 5 people have reported this problem. The timestamp worked fine in 141 with 30/5 loader, because I'm still using those saves and the date difference is immediately apparent. Still the saves seem to work fine. The loader I'm using is the current one from 23/9.

    I have an Ak2i HW 81, not updated to 1.4FW, and using it on a Black Eu DS Lite. Also all patch settings are on Disable (DL Play, Soft-reset,Cheat). And the date shown inside AKAIO works fine as well.

    My guess is this must be a loader bug of some sort.
     
  13. Achilles

    Member Achilles GBAtemp Regular

    Joined:
    Feb 28, 2005
    Messages:
    160
    Country:
    United States
    Same problem here with the saved games with no modified date at all... I'm on AKAIO 1.5 on a HW:81 Acekard 2i with DSi firmware 1.4 using the 9/23 loader.
     
  14. Leonidas

    Member Leonidas GBAtemp Fan

    Joined:
    Aug 27, 2009
    Messages:
    479
    Location:
    sLOVEnia
    Country:
    Slovenia
    First say Normmatt rocks 5 times
    .
    .
    .
    .
    .
    Then download the fix here. I've tested it, and it does give a timestamp now.
     
  15. elixirdream

    Member elixirdream GBAtemp Legend

    Joined:
    May 27, 2008
    Messages:
    10,007
    Location:
    6th Dimention
    Country:
    Malaysia
    double confirm that it is fixed [​IMG]
     
  16. Rascal

    Member Rascal GBAtemp Fan

    Joined:
    Apr 23, 2008
    Messages:
    429
    Country:
    United States
    Great news. I just got Normmatt's email from the bug report that I submitted for this. I'm glad that he was able to re-create it and fix it so fast.

    Normmatt Rocks!
     
  17. Shaxy
    OP

    Newcomer Shaxy Newbie

    Joined:
    Feb 3, 2008
    Messages:
    3
    Country:
    United States
    Sweet. Fixed for me as well. Normmatt rocks. :D
     

Share This Page