AK2i update file for EUR/US DSi (HWID 44)

Discussion in 'Acekard' started by acekard, May 28, 2009.

  1. acekard
    OP

    acekard Member

    Newcomer
    31
    1
    Nov 22, 2006
    Switzerland
    This update file is to resolve the issue of AK2i can only be run on DSi which set language to English. You do not need to update if you're using JAP DSi.
    How to use
    1.Set the language of your DSi to English.
    2.Copy ak2ifw_update_hw44.nds to your MicorSD card and put it to AK2i.
    3.Launch AK2i and select to run the update file.
    4.Follow the instructions of the update program to finish update.

    Notice
    This update file can be only used on AK2i which has HWID "44". You can press "start" then select "help" in AK's menu to check your HWID.
    There're two HWID of AK2i. The update file for HWID "81" can be found at www.acekard.com/download.php#ak2.

    You can find the update file at www.acekard.com/download.php#ak2.
     


  2. LUGiA

    LUGiA GBAtemp Fan

    Member
    425
    0
    May 14, 2008
    is it safe to run the update on a DS Lite (havent got a DSi yet)
     
  3. lenselijer

    lenselijer GBAtemp Advanced Maniac

    Member
    1,502
    7
    Mar 27, 2006
    Netherlands
    Can someone edit the update file so it also can update normal ak2 cards?

    My card has the following hardware:

    CHIP ID: 0fc2
    HW: 4040
     
  4. Minox

    Minox Spytech Employee

    Supervisor
    6,022
    2,601
    Aug 27, 2007
    What would you gain from doing so?
     
  5. indask8

    indask8 New Member Forever

    Member
    987
    119
    Apr 19, 2007
    France
    Look at the Flag...
    This updater only fix a part of the flash memory... doing so will give you a brick instead of a acekard2i.

    I tried this on my AK2i HW44 worked perfectly, now boot in french.

    AK Team Rocks. [​IMG]

    You can use this updater on any DS, I used it on my DS Lite.
     
  6. zero383

    zero383 GBAtemp Advanced Fan

    Member
    649
    0
    Apr 4, 2009
    Canada
    Vancouver - #1 City in Canada
    This update is for AK2i for use on DSi ONLY. Normal AK2 cards don't have the language problem (they don't even work on the DSi) so why are you wanting to update it?
     
  7. indask8

    indask8 New Member Forever

    Member
    987
    119
    Apr 19, 2007
    France
    Look at the Flag...
    Yes it's no use to update it if you use a DS Lite.

    But if you plan to buy a DSi, you still can do it now with any DS... you won't have to search again for that updater once your DSi will be at home.
     
  8. coredalae

    coredalae Newbie

    Newcomer
    5
    2
    May 25, 2009
    Netherlands
    wondering this aswell, want to update this for a friend of mine but dont have a DSi myself..

    edit: ok thnx boudincaca, i'll just run it on my ds lite!
     
  9. lenselijer

    lenselijer GBAtemp Advanced Maniac

    Member
    1,502
    7
    Mar 27, 2006
    Netherlands
    to convert my old stock of acekard2 so that they work on the dsi [​IMG]

    too bad its only a partial update and not a full flash [​IMG]
     
  10. cory1492

    cory1492 GBAtemp Maniac

    Member
    1,497
    24
    Jun 23, 2005
    Canada
    Home, WhereElse?
    lenselijer: it's not going to be just the flash contents that are important, but the ASIC contents that actually uses it - you know, the stuff they aren't going to release unless they want to be cloned.
     
  11. zero383

    zero383 GBAtemp Advanced Fan

    Member
    649
    0
    Apr 4, 2009
    Canada
    Vancouver - #1 City in Canada
    I'm pretty sure the internal hardware is different between the AK2 and AK2i as well so a full flash wouldn't be able to convert it anyways.
     
  12. manaphy4ever

    manaphy4ever GBAtemp Advanced Fan

    Member
    505
    1
    May 7, 2008
    Bosnia and Herzegovina
    Bahrain
    Good cause my Hardware of My Acekard2i is 44 can't wait to get a dsi soon [​IMG]
     
  13. donelwero

    donelwero GBAtemp Fan

    Member
    352
    10
    Jul 17, 2008
    Mexico
    León, Gto.
    That's nice!! finally!

    Thx Acekard team!
     
  14. nuke888

    nuke888 Advanced Member

    Newcomer
    67
    0
    Jul 27, 2006
    United States
    acekard

    In quality of expert I have two Acekard Ak2i one hw44 the other hw81 I have to sell one Whats the best should i keep for me ? HW81 ?
     
  15. nuke888

    nuke888 Advanced Member

    Newcomer
    67
    0
    Jul 27, 2006
    United States
    U CAN UPDATE WITH ALL THE DS/DSLITE/DSI I have flashed both hw81 and hw44 on a black
    cracked/flashme DSlite.
     
  16. elixirdream

    elixirdream GBAtemp Legend

    Member
    10,007
    2
    May 27, 2008
    Malaysia
    6th Dimention
    thanks! finally my HW44 can be updated
     
  17. bollocks

    bollocks GBAtemp Advanced Fan

    Member
    662
    0
    Apr 29, 2005
    they are functionally identical i believe. but if acekard have to update the firmware again (say, to circumvent some lockout mechanism introduced by nintendo in a future DSi firmware) there may well be a weeks-long gap between the 81 and 44 updates as there was this time. so i'd provisionally say keep the 81.
     
  18. Minox

    Minox Spytech Employee

    Supervisor
    6,022
    2,601
    Aug 27, 2007
    Actually the one with HWID 44 is the newest one even though it may sound strange.
     
  19. Normmatt

    Normmatt Former AKAIO Programmer

    Member
    2,142
    544
    Dec 14, 2004
    New Zealand
    Actually HWID 81 is the newest.
     
  20. derlamer

    derlamer Newbie

    Newcomer
    1
    0
    Aug 23, 2007
    Gambia, The
    finally got my dsi with acekard in german - the update worked like a charm. thx guys!!!