Tutorial [AIO] PS4 Exploit Guide

  • Thread starter KiiWii
  • Start date
  • Views 2,893,085
  • Replies 21,796
  • Likes 178

godreborn

Welcome to the Machine
Member
Joined
Oct 10, 2009
Messages
31,302
Trophies
2
XP
20,786
Country
United States
to whomever I was talking with about compiling super mario 64 on the ps4, I think the problem is the llvm+clang version. it's hard to say what version could've been used with no real information. I think open orbis 0.5 was used.
 

zekro94

Well-Known Member
Member
Joined
May 5, 2013
Messages
107
Trophies
0
Age
28
XP
480
Country
to whomever I was talking with about compiling super mario 64 on the ps4, I think the problem is the llvm+clang version. it's hard to say what version could've been used with no real information. I think open orbis 0.5 was used.
I was the one who couldn't compile it. In the ports github he says he used orbis 5.0 but even with that it doesn't compile. As you say, llvm+clang version is the unknown variable that might make it compile if we knew the version. I read somewhere that they chenged something in later clang version, something about fuse_array if I remember

Edit: Found the thing I was talking about
 

Attachments

  • Screenshot_20220630-103230_Firefox.jpg
    Screenshot_20220630-103230_Firefox.jpg
    581.9 KB · Views: 5

godreborn

Welcome to the Machine
Member
Joined
Oct 10, 2009
Messages
31,302
Trophies
2
XP
20,786
Country
United States
I was the one who couldn't compile it. In the ports github he says he used orbis 5.0 but even with that it doesn't compile. As you say, llvm+clang version is the unknown variable that might make it compile if we knew the version. I read somewhere that they chenged something in later clang version, something about fuse_array if I remember
I think the problem might actually be with the gcc version. the error doesn't seem to change with different llvm versions. and, I discovered that one out of scope error is part of gcc. I think it's gcc 6.5.0, but it's a major pita to get installed.
 

zekro94

Well-Known Member
Member
Joined
May 5, 2013
Messages
107
Trophies
0
Age
28
XP
480
Country
I think the problem might actually be with the gcc version. the error doesn't seem to change with different llvm versions. and, I discovered that one out of scope error is part of gcc. I think it's gcc 6.5.0, but it's a major pita to get installed.
In theory it should be possible if you use clang 10 or below and llvm13, since that is the version clang asks for
 

Attachments

  • 20220526_222631.jpg
    20220526_222631.jpg
    1.9 MB · Views: 4

jnl1

Well-Known Member
Member
Joined
Jan 12, 2020
Messages
288
Trophies
0
Age
34
XP
824
Country
Germany
Will Gran Turismo 7 (although with online save, i know) also be available soon? Or is its FW requirement too high (I think it is 9.04)?
 

subworx

Well-Known Member
Member
Joined
Sep 12, 2019
Messages
212
Trophies
0
XP
635
Country
Germany
Will Gran Turismo 7 (although with online save, i know) also be available soon? Or is its FW requirement too high (I think it is 9.04)?
It can be backported, but to my knowledge pretty much everytthing there is bound to being online, the game is mostly unplayable offline.
 
  • Like
Reactions: KiiWii

PopperTop

Well-Known Member
Newcomer
Joined
Jan 4, 2021
Messages
63
Trophies
0
Age
32
XP
365
Country
Croatia
Will Gran Turismo 7 (although with online save, i know) also be available soon? Or is its FW requirement too high (I think it is 9.04)?
GT7 is 9.03 and has been dumped in private, there's an archive unpack tool for it released by Flatz.

Who knows when it'll be released but the game will be pretty worthless if there's no debug menu or a save game with all tracks and cars unlocked. As I believe they've locked it even further behind the online servers compared to GT Sport. 🤮
 
  • Like
Reactions: jnl1

arfgh

Well-Known Member
Member
Joined
Oct 3, 2019
Messages
673
Trophies
0
Age
92
XP
1,019
Country
Armenia
it seems that the ego is a big problem for some ps4 sceners. What a lack. But who cares that kind of ppl, finally all will be reached, by one way, or another.
 

Smiths

AKAIO Person of Interest TAGS ARE THE BEST
Developer
Joined
Feb 24, 2003
Messages
1,437
Trophies
0
Location
The land of Dairy Queen
Website
www.gamergeddon.com
XP
1,715
Country
United States
1.04 patch with it too. that's a 9.51.

ps4 scene going old school. these youngsters could use a little of this

I had to inject avplayer to fix the cutscenes not playing just skipping so im not sure if this injection works on 6.72+ as i dont have one to test.

damn that's some extracting movies and downsampling then reinserting them to fit a 800MB CD level stuff going on
 
  • Like
Reactions: KiiWii

godreborn

Welcome to the Machine
Member
Joined
Oct 10, 2009
Messages
31,302
Trophies
2
XP
20,786
Country
United States
so back4blood 1.08 a 9.60 patch as now been released. Wish that we could know how its done so we could do our own patches etc.
I know how it's done, but it's complicated and I'm not an expert on it. You essentially use a disassembler. Unfortunately, that's one thing I hate about the scenes, mostly the Playstation ones. Some information just isn't shared. I don't believe any knowledge should be hidden or restricted, but that's just me.
 
  • Like
Reactions: rantex92

KiiWii

Editorial Team
OP
Editorial Team
Joined
Nov 17, 2008
Messages
14,101
Trophies
2
Website
defaultdnb.github.io
XP
19,037
Country
United Kingdom
I know how it's done, but it's complicated and I'm not an expert on it. You essentially use a disassembler. Unfortunately, that's one thing I hate about the scenes, mostly the Playstation ones. Some information just isn't shared. I don't believe any knowledge should be hidden or restricted, but that's just me.
You cannot decrypt encrypted binaries with a disassembler. Someone out there is passing decrypted content to these teams. No doubt in my mind.
 
  • Like
Reactions: rantex92
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Your username is pretty close to @The Real Jdbye